#1  
Old 5th August 2010, 13:23
hzzg6y hzzg6y is offline
Junior Member
 
Join Date: Aug 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Dovecot with Mysql

Hi,

I am firsttime on this forum. Thanks for having such a wonderful ISPCONFIG 3 software. I have installed the ISPconfig 3 software on my cloud server with CentOS 5.5 . I have used courier temporarirly as I want to use Dovecot with mysql support. I need help to have Dovecot installed on server with mysql support. I feel that dovecot on centos5.5 do not support mysql.
Please can you help with detail information on this.
Reply With Quote
Sponsored Links
  #2  
Old 5th August 2010, 13:53
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

The ispconfig perfect server guide explains in detail the installation of ispconfig 3 with dovecot on centos 5.5:

http://www.howtoforge.com/perfect-se...64-ispconfig-3
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 5th August 2010, 16:28
hzzg6y hzzg6y is offline
Junior Member
 
Join Date: Aug 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Please see on page 4.

There's a Dovecot package in the CentOS repository, but unfortunately it doesn't support MySQL. Therefore we must remove the existing Dovecot and install another Dovecot package (from ATrpms) which comes with MySQL support:

yum remove dovecot

rpm -ivh http://dl.atrpms.net/all/dovecot-1.2...el5.x86_64.rpm
rpm -ivh http://dl.atrpms.net/all/dovecot-sie...el5.x86_64.rpm

rm -fr /usr/lib/dovecot/
ln -s /usr/lib64/dovecot/ /usr/lib/dovecot

The above RPM package do not exist... I mean it is not available at the path mentioned below. I am looking for right package having dovecot which support Mysql. Please advice.
Reply With Quote
  #4  
Old 6th August 2010, 07:44
veuster veuster is offline
Member
 
Join Date: Jul 2010
Posts: 30
Thanks: 11
Thanked 0 Times in 0 Posts
 
Default change version

You just have to change the version to the latest.

Just check in dl.atrpms.net for list of available version.

For now, it's:

Code:
rpm -ivh http://dl.atrpms.net/all/dovecot-1.2.13-1_111.el5.x86_64.rpm
rpm -ivh http://dl.atrpms.net/all/dovecot-sieve-0.1.17-5.el5.x86_64.rpm
Hope it helps.

Last edited by veuster; 6th August 2010 at 07:46.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Webmail problems with only one domain? compner Installation/Configuration 14 16th February 2010 16:59
ISPConfig3 Mail Warn Errors reason8 General 3 25th November 2009 13:58
Postfix can't received email from exterior astra2000 Server Operation 5 17th October 2009 23:26
Add ons for ISPConfig 3 virtue Installation/Configuration 24 16th October 2009 17:30
Management/system config/settings & /server/settings not working!! dactor Installation/Configuration 9 6th February 2008 09:11


All times are GMT +2. The time now is 00:58.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.