Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th June 2006, 16:09
nysprite nysprite is offline
Junior Member
 
Join Date: Jun 2006
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default I have problem can't access port 81 on Public IP

my home network is

[ADSL Modem]=====eth1(192.168.1.2) Server eth0 (192.168.2.1)=====> PC(Windows)

When I access from https://192.168.2.1:81/ it's work
But I try to access from Public router https://xxx.xxx.xxx.xx:81/ it's doesn't work show This page cannot be displayed

I already NAT port 81 on router and iptables /etc/sysconfig/iptables follow

:PREROUTING ACCEPT [10:480]
:POSTROUTING ACCEPT [1:104]
:OUTPUT ACCEPT [1:104]
-A POSTROUTING -o eth1 -j MASQUERADE

any Idea help me plz.. thank you

Sprite
Reply With Quote
Sponsored Links
  #2  
Old 9th June 2006, 10:12
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,503
Thanks: 813
Thanked 5,265 Times in 4,129 Posts
Default

Have you checked that your provider does not block port 81?

If you tried to connect from inside your local network to your public IP, this might have been blocked by your router as IP spoofing attempt.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 6th September 2007, 12:50
shellNewbie shellNewbie is offline
Junior Member
 
Join Date: Sep 2007
Posts: 12
Thanks: 1
Thanked 0 Times in 0 Posts
Default Cannot access IspConfig control panel on port 81

I still cannot seem to access the control panel of ISPConfig from my windows

output from iptables -L

root@servera:/home/lyme# iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

output from netstat -tap

root@servera:/home/lyme# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:mysql *:* LISTEN 3949/mysqld
tcp 0 0 *:www *:* LISTEN 5882/apache2
tcp 0 0 *:81 *:* LISTEN 4375/ispconfig_http
tcp 0 0 *:ftp *:* LISTEN 6065/proftpd: (acce
tcp 0 0 *:smtp *:* LISTEN 5984/master
tcp 0 0 *:https *:* LISTEN 5882/apache2
tcp6 0 0 *:imaps *:* LISTEN 4058/couriertcpd
tcp6 0 0 *op3s *:* LISTEN 4098/couriertcpd
tcp6 0 0 *op3 *:* LISTEN 4076/couriertcpd
tcp6 0 0 *:imap2 *:* LISTEN 4038/couriertcpd
tcp6 0 0 *:ssh *:* LISTEN 4206/sshd
tcp6 0 0 *:smtp *:* LISTEN 5984/master
tcp6 0 444 servera.lymedaisy.c:ssh ::ffff:192.168.200:1521 ESTABLISHED5660/sshd: lyme [pr

I have edited the hosts file on my pc to include various combinations and get to the parent directory of Ubuntu 7.04 by typing in www.mydomain.com

by typing /etc/init.d/ispconfig_server start in the bash shell I get this:

/root/ispconfig/httpd/bin/apachectl startssl: httpd (pid 4375) already running
FreshClam is already running!
ISPConfig system is now up and running!

so I know ISPConfig is there and appears to be working ok.

Can someone tell me which of the services I need to enable here in my router and what ports to put in .. also if I need to add a particular entry for ISPConfig on port 81.

sorry if I am being annoying ... just want to at least see the control panel !!

Thank you for your help.
Reply With Quote
  #4  
Old 7th September 2007, 07:59
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,503
Thanks: 813
Thanked 5,265 Times in 4,129 Posts
Default

Please try to connect with another browser, e.g. firefox. Internet Explorer does not provide extensive error messages.

Please try to connect by IP address to port 81, to make sure that this is not a name resolving problem. esxample:

http://192.168.0.100:81/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 8th September 2007, 22:34
shellNewbie shellNewbie is offline
Junior Member
 
Join Date: Sep 2007
Posts: 12
Thanks: 1
Thanked 0 Times in 0 Posts
Default SSL problem

thanks till for above

Firefox (on Fedora core 7 this time) tells me that my domain has an invalid SSL cert.

My question is do I accept defaults for key generation during installation of Ubuntu 7.04 ( I mean the Apache installed as per The perfect setup .... Howto" ) in the same way as outlined for the ISPConfig install here:

http://www.ispconfig.org/manual_installation.htm

?

To be clear .. do I accept defaults for BOTH Apaches?
Reply With Quote
  #6  
Old 9th September 2007, 16:07
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,503
Thanks: 813
Thanked 5,265 Times in 4,129 Posts
Default

The setup script does not craete certificates for both apache webservers, it creates juts the certificate for one apache server, the one that runs on port 81.

To create a new ssl cert, have a look here:

http://www.howtoforge.com/forums/showthread.php?t=121
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
shellNewbie (10th September 2007)
  #7  
Old 10th September 2007, 18:27
shellNewbie shellNewbie is offline
Junior Member
 
Join Date: Sep 2007
Posts: 12
Thanks: 1
Thanked 0 Times in 0 Posts
Default Postfix Configuration

Can you please tell me what is the best email address to use during certificate creation for postfix (using the Ububtu 7.04 "Perfect setup - How to")

where the questionmarks are.

Country Name (2 letter code) [AU]:XX
State or Province Name (full name) [Some-State]:XXXXX-XXXXXXXXX
Locality Name (eg, city) []:XXXXXXXX
Organization Name (eg, company) [Internet Widgits Pty Ltd]:XXXXXXXXX XXXX
Organizational Unit Name (eg, section) []:Home
Common Name (eg, YOUR name) []:XXXXXXX.XXXXXXXX.com
Email Address []:?????????????????
Reply With Quote
  #8  
Old 11th September 2007, 18:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Use one of your own email addresses. In fact, you can use any email address there.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 12th September 2007, 08:27
shellNewbie shellNewbie is offline
Junior Member
 
Join Date: Sep 2007
Posts: 12
Thanks: 1
Thanked 0 Times in 0 Posts
Default Working fine now

Finally everything is working really well:

Ububtu 7.04 server configured as per -
http://www.howtoforge.com/perfect_setup_ubuntu704

ISPConfig installed and accessible on my local machine.

Thanks to falko, till and chuckl for your help.

Reply With Quote
  #10  
Old 12th September 2007, 08:36
shellNewbie shellNewbie is offline
Junior Member
 
Join Date: Sep 2007
Posts: 12
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default Working fine now

Finally everything is working really well:

Ububtu 7.04 server configured as per -
http://www.howtoforge.com/perfect_setup_ubuntu704

ISPConfig installed and accessible on my local machine.

Thanks to falko, till and chuckl for your help.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
Questions in regards to ISP-Server Setup - Ubuntu 5.10 "Breezy Badger" rbrantley HOWTO-Related Questions 16 10th April 2006 18:26
How to install BFD (Brute Force Detection) domino Tips/Tricks/Mods 9 31st March 2006 22:40
FTP access problem... ctroyp General 7 12th October 2005 17:07
Access Denied on Port: 81 nandhu Installation/Configuration 2 10th August 2005 14:05


All times are GMT +2. The time now is 20:00.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.