Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 4th August 2010, 15:12
HyperAtom HyperAtom is offline
Member
 
Join Date: Jan 2010
Posts: 79
Thanks: 7
Thanked 3 Times in 3 Posts
Default Wordpress Auto Update/Plugin Installation Problem

Hi all, everytime I try to autoupdate wordpress, the updater is unable to write to the configuration files. All the permissions are as they should be.

When updating or installing plugins, I get

Could not create directory. /web

Folder permissions are 775 on /web /plugins /upgrade /upload

Trawling through the forums, I did see something about the php setting in the control pannel having an effect on wordpress auto update http://www.howtoforge.com/forums/sho...d.php?p=232821

I am using Fast-CGI with SuExec enabled
Reply With Quote
Sponsored Links
  #2  
Old 4th August 2010, 15:54
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

I guess the files are not owned by the correct User. Chown all files and folders inside the web directory recursively to the web user and client group of this website. I run several wordpress installs on ISPConfig 3 with suexec and fast-cgi and the auto update works fine with ispconfigs default settings.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 4th August 2010, 16:31
HyperAtom HyperAtom is offline
Member
 
Join Date: Jan 2010
Posts: 79
Thanks: 7
Thanked 3 Times in 3 Posts
Default

Hmm strange, ive checked all the directories and theyre all owned by web1 and ground client0 which is fine. Guess i'll have to look into it.
Reply With Quote
  #4  
Old 20th August 2010, 03:48
yoplait yoplait is offline
Senior Member
 
Join Date: Dec 2009
Posts: 144
Thanks: 50
Thanked 14 Times in 11 Posts
Default

Same problem on my side, and the rights seems to be good...
Maybe wordpress is running with the www-data:www-data user, or something like that ?
I can see files created by wordpress with theses rights... HyperAtom, do you have the same ?
Reply With Quote
  #5  
Old 20th August 2010, 15:06
HyperAtom HyperAtom is offline
Member
 
Join Date: Jan 2010
Posts: 79
Thanks: 7
Thanked 3 Times in 3 Posts
Default

Since my server was only a test system, I reinstalled to 3.0.3 beta and updating hasn't failed in wordpress since.
Reply With Quote
  #6  
Old 10th December 2010, 18:09
GenNS GenNS is offline
Junior Member
 
Join Date: Dec 2010
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm also having troubles.

I followed the Perfect Server guide for Ubuntu, just to set up a WordPress hosting server in a LAMP environment.

I found ISPConfig3 pretty easy to use in terms of setting up new clients and sites, and it was pretty smooth sailing as far as getting WordPress installed.

However, I can't auto-update WordPress or plugins, and I get other strange error messages.

For instance, on the first blog I set up, when I go to the Dashboard, in several places I see this error message:

Quote:
Cannot open file (/var/www/clients/client1/web1/web/wp-content/backup/.htaccess)Cannot write to file (/var/www/clients/client1/web1/web/wp-content/backup/.htaccess)
Also, if I go to the Permalinks page in Settings, at the bottom, I get this message:

Quote:
If your .htaccess file were writable, we could do this automatically, but it isnt so these are the mod_rewrite rules you should have in your .htaccess file. Click in the field and press CTRL + a to select all.
(with the textarea after it)

Trouble is, since my only experience with Linux etc. is having followed the Perfect Server guide to get this set up, I'm not even sure where that file is.

I found a post someplace about making sure to CHOWN the web directory to the ISPConfig3 user via a command like this:

Quote:
chown -R web1:client1 /var/www/clients/client1/web1/web
...which I've done for the three clients I've set up so far. But on this one particular client (my own blog), I still get those error messages I've listed above and cannot auto-update anything.

I've also checked numerous WordPress blogs, forums and posts and haven't found anything useful in terms of a solution.

Is there maybe some step I've missed in ISPConfig3? Or can somebody offer any help or suggestions here?

Thanks much in advance,

GenNS
Reply With Quote
  #7  
Old 10th December 2010, 21:54
GenNS GenNS is offline
Junior Member
 
Join Date: Dec 2010
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Actually I've tried the auto-update on the other two blogs and they all fail.

And I tried updating the Akismet anti-spam plugin and it failed as well, giving me this error:

Quote:
An error occured while updating Akismet: Could not create directory. /web.
After I attempt either type of update (WP autoupdate or plugin update) the admin and blog are unavailable, just giving me this message:

Quote:
Briefly unavailable for scheduled maintenance. Check back in a minute.
Reply With Quote
  #8  
Old 10th December 2010, 22:16
renders renders is offline
Junior Member
 
Join Date: Jan 2008
Location: Ontario Canada
Posts: 25
Thanks: 1
Thanked 6 Times in 4 Posts
Default

Should the files be owned by client0 or client1? If you don't select the client, it defaults to client0..

Rob
Reply With Quote
  #9  
Old 10th December 2010, 23:10
GenNS GenNS is offline
Junior Member
 
Join Date: Dec 2010
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Are you referring to the example CHOWN I pasted in my original post?

In ISPConfig3, Web1 goes with Client1 and so on.

Or maybe I'm misunderstanding what you're asking.
Reply With Quote
  #10  
Old 11th December 2010, 17:57
renders renders is offline
Junior Member
 
Join Date: Jan 2008
Location: Ontario Canada
Posts: 25
Thanks: 1
Thanked 6 Times in 4 Posts
 
Default

I noticed on my install that if I am logged in as the control panel admin, I can assign the web site to a particular client. If I don't select the client, it defaults to client0.. I have only one client setup on my system and only client1 exists in the drop down.

I am wondering if defaulting to client0 breaks the permissions..

Rob
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual users... Ubuntu 8.04 spaceuser HOWTO-Related Questions 12 19th June 2008 09:04
ISPConfig installation problem. Cannot make OpenSSL BlueStream Installation/Configuration 13 18th October 2005 11:01
Installation problem xma Installation/Configuration 15 26th September 2005 14:22
Installation problem: PHP problem? hgoor Installation/Configuration 7 21st August 2005 23:15
Installation Problem _InFeCtOr Installation/Configuration 5 8th August 2005 16:34


All times are GMT +2. The time now is 01:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.