Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 20th February 2007, 07:49
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

This line is definitely there, please have another look at the file. The exact file path is /home/admispconfig/ispconfig/lib/config.inc.php
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Sponsored Links
  #12  
Old 20th February 2007, 17:27
jonwatson jonwatson is offline
Senior Member
 
Join Date: Feb 2007
Posts: 176
Thanks: 15
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by jonwatson
Change the line:

$go_info["server"]["apache2_php"] = 'both';

to:

$go_info["server"]["apache2_php"] = 'addtype';

Erk..when I do this I get the PHP file printed out in my browser. Debian 3.1.

Any ideas? This is freaking me out...
Does anyone know how to fix this?
Reply With Quote
  #13  
Old 20th February 2007, 17:40
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

You quoted the fix in your post. Edit the file and change a setting of one of your websites and hit save to let ISPConfig rewrite your configuration.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #14  
Old 20th February 2007, 18:09
jonwatson jonwatson is offline
Senior Member
 
Join Date: Feb 2007
Posts: 176
Thanks: 15
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by till
You quoted the fix in your post. Edit the file and change a setting of one of your websites and hit save to let ISPConfig rewrite your configuration.
I should have quoted my entire post

When I put that fix in place, PHP pages print out the code to the browser instead of being handed off to the PHP engine for rendering.

I suspect this is because on page 5 of the Debian Perfect HowTo, we are told to comment out:

/etc/mime.types
Code:
#application/x-httpd-php                                phtml pht php
#application/x-httpd-php-source                 phps
#application/x-httpd-php3                       php3
#application/x-httpd-php3-preprocessed          php3p
#application/x-httpd-php4
and in /etc/apache2/mods-enabled/php4.conf:

Code:
<IfModule mod_php4.c>
#  AddType application/x-httpd-php .php .phtml .php3
#  AddType application/x-httpd-php-source .phps
</IfModule>
So I *think* (not sure) that by changing the line: $go_info["server"]["apache2_php"] = 'addtype';
we are telling Apache to use addType to handle PHP, yet we have commented it out and therefore Apache doesn't know what to do with it.

Am I making sense or babbling?
Reply With Quote
  #15  
Old 20th February 2007, 18:45
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

The lines must be commented out, ISPConfig adds the nescessary addtype stamenets in the vhost.

Please set the $go_info["server"]["apache2_php"] = 'addtype'; and the change a value in one of your seites.

The have a look at the file Vhost_ispconfig.conf and post a vhost definition from a vhost / website where PHP is enabled.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #16  
Old 20th February 2007, 19:47
jonwatson jonwatson is offline
Senior Member
 
Join Date: Feb 2007
Posts: 176
Thanks: 15
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by till
The lines must be commented out, ISPConfig adds the nescessary addtype stamenets in the vhost.

Please set the $go_info["server"]["apache2_php"] = 'addtype'; and the change a value in one of your seites.

The have a look at the file Vhost_ispconfig.conf and post a vhost definition from a vhost / website where PHP is enabled.

Strangely, the problem seems to have gone away now. I did restart ISPConfig this morning. Perhaps there was something hanging.

Anyhow...things appear to be Ok now. Thanks for the help.
Reply With Quote
  #17  
Old 1st May 2007, 18:11
Grizzly Grizzly is offline
Member
 
Join Date: Feb 2006
Posts: 41
Thanks: 0
Thanked 0 Times in 0 Posts
Post php still not opening opensuse10.2 Ispconfig

Keep getting the following error in /var/log/error_log

ed May 02 18:02:05 2007] [error] [client ::1] client denied by server configuration: /srv/www/
[Wed May 02 18:02:06 2007] [error] [client ::1] client denied by server configuration: /srv/www/
[Wed May 02 18:02:07 2007] [error] [client ::1] client denied by server configuration: /srv/www/
[Wed May 02 18:02:08 2007] [error] [client ::1] client denied by server configuration: /srv/www/

what should this setting be in /etc/apache2/default-server.conf


I hope this is all that is still wrong there are no other error messages
Reply With Quote
  #18  
Old 2nd May 2007, 14:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

What's the output of
Code:
ls -la /srv/www
? Where does ISPConfig install the web sites?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #19  
Old 4th May 2007, 19:21
Grizzly Grizzly is offline
Member
 
Join Date: Feb 2006
Posts: 41
Thanks: 0
Thanked 0 Times in 0 Posts
Default Results of ls -la /srv/www

just shows all my sites and the administrators for those sites
Ispconfig is configured to install under /srv/www
Reply With Quote
  #20  
Old 4th May 2007, 20:27
Julius Julius is offline
Junior Member
 
Join Date: May 2007
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Hello guys

I have this problem too. I have modified successfully the file but i dont know what to do in the ispconfig panel to update the website and so to let ispconfig te rewrite the configuration files.Help!!!

thanks
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[error] an unkown filter was not added: PHP Arien Installation/Configuration 12 7th October 2006 14:17
configuring IPTABLES firewall adityavpratap HOWTO-Related Questions 9 27th May 2006 21:42
Frustrated with ISPConfig install! woozyerdaddee Installation/Configuration 4 19th May 2006 03:38
Installation Fails... :( cyberstorm Installation/Configuration 1 15th January 2006 18:07
Install stop at uuwish, UUDeview SeaWolf Installation/Configuration 6 4th October 2005 23:53


All times are GMT +2. The time now is 02:02.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.