Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 30th July 2010, 19:47
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

Quote:
Originally Posted by Batmanatthenewb View Post
Falko,

When I run dig www.effininsurance.com (My domain name) from my web server I receive the following:

;; ANSWER SECTION;
www.effininsurance.com. 3600 IN CNAME effinsurance.com.
effininsurance.com. 3600 IN A 68.178.232.99

the IP 68.178.232.99 is what shows up on my domain registrars website under the "Total DNS Contral". This is not my external IP Address. My external address is 24.106.106.99.
That's the problem. The records must point directly to your external IP and not via a forward.

Code:
mh1:~# dig ns effininsurance.com

; <<>> DiG 9.3.4 <<>> ns effininsurance.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 51434
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;effininsurance.com.            IN      NS

;; ANSWER SECTION:
effininsurance.com.     3600    IN      NS      ns03.domaincontrol.com.
effininsurance.com.     3600    IN      NS      ns04.domaincontrol.com.

;; Query time: 409 msec
;; SERVER: 213.133.98.98#53(213.133.98.98)
;; WHEN: Fri Jul 30 19:57:48 2010
;; MSG SIZE  rcvd: 88

mh1:~#
Also, your ISPConfig server(s) are not authoritative for the domain. The authoritative nameservers are ns03 and ns04.domaincontrol.com.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Sponsored Links
  #12  
Old 1st August 2010, 17:47
veuster veuster is offline
Member
 
Join Date: Jul 2010
Posts: 30
Thanks: 11
Thanked 0 Times in 0 Posts
Default to be continued

Quote:
ANSWER: This is what show in my DNS settings:
BIND User root
BIND Group bind
BIND zonefiles directory /etc/bind
BIND named.conf path /etc/bind/named.conf
/etc/bind/named.conf.local

What should it be changed to?
Don't need to change anything. I check the guide you used and it doesn't use chrooted BIND. So, it's fine, don't change anything here.

Quote:
Last but not least, don't forget to change the named.conf according to your setting.
Especially, in line :

listen-on port 53 { 127.0.0.1;};

allow-query { localhost; };

localhost and 127.0.0.1 needs to be changed or added with the ip or ip range that is allowed to query your server (this means which address can access your name server).
I don't know your setting because it seems you're on LAN. I use VPS so I changed the localhost and 127.0.0.1 to { any; }; which means that all address can access it.

ANSWER: named.conf has no line that says anything about "Listen" or "allow-query" It only has:

include "/etc/bind/named.conf.options";
include "/etc/bind/named.conf.local";
include "/etc/bind/named.conf.default-zones";
Check in named.conf.options or named.conf.default-zones, the line should be there somewhere. Maybe this is the problem, because you said Forbidden error, that is maybe because the access is limited for your nameserver.

Is the router already set up to forward all request at port 80 (http) to your local server? I don't know exactly how to do this, but I think you already did this. Because you also use it as nameserver, maybe port 53 must be forwarded also (don't know for sure, needs a confirmation if anyone know this)

There are 2 way to set your DNS :
1. From your domain provider :
You will set your A Record, NS, MX etc from your domain provider. In ISPConfig you only need to create client and site, don't need DNS. If you change the A Record to your IP then that means you're using this method
2. From your ISPConfig 3 server :
This is what you use if you follow the Own Nameserver guide. In your domain provider, actually what you need to set up is only NS record (stands for Name Server record). And then you create A Record, NS, MX etc from ISPConfig server.

If you already follow the guide for number 2 and it still didn't work, can you tell me what did you create in DNS section of ISPConfig 3 server?
Reply With Quote
  #13  
Old 2nd August 2010, 07:36
Batmanatthenewb Batmanatthenewb is offline
Junior Member
 
Join Date: Sep 2008
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Thank you Falko and veuster.

I got it figured out and working on Friday night. Got rid of the set up that was trying to create and use my own name servers. I switched the name servers back to those of Federal Domain, switched the "A" record to point to my IP Address and everything works fine.

Now that I have two sites up and running, the addition of any others will be easy to set up. Just mirror what I have with the new domains.

The integration between the webserver, ftp server, and email server in ISPConfig is great.

Thank you for your help
Sam
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fresh Install of Ubuntu 10.04 and ISPConfig 2 happz Installation/Configuration 10 29th July 2010 15:25
Ftp problems timeout reny2000 General 6 23rd December 2009 11:09
ISPConfig 3.0.0.7 Beta released till General 78 24th December 2008 11:47
Ubuntu 8.04 server edition ISPconfig installation error malinens Installation/Configuration 4 30th July 2008 07:30
Ubuntu 8 LTS Server ISPCONFIG t.roijers General 12 26th April 2008 11:15


All times are GMT +2. The time now is 20:06.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.