#1  
Old 23rd July 2010, 23:14
rusty rusty is offline
Member
 
Join Date: Dec 2007
Posts: 45
Thanks: 5
Thanked 0 Times in 0 Posts
Default User & Admin Permissions

Sorry if asked and answered, this is a hard one to research.

I setup a CP user and limited him to his client group. He sees only his client website, however his changes do not save. Changed him from user rights to admin rights. Now he can make and save changes to the settings, however he now can see all the websites on the server, not just those for his client/group.

Is there something wrong with my server (if so what) or is this a bug?

Setup Ubuntu Perfect Server 10.04 ISPConfig 3

Thanks.
Reply With Quote
Sponsored Links
  #2  
Old 23rd July 2010, 23:19
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

You can not add cp users manually as described in the warning message in the cp user list. tHis function is onyl there to be able to add a second admin user. CP users were added automatically by the system when you add a client.

To fix this:

remove the CP user that you added manually and then add a client instead.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 24th July 2010, 00:25
rusty rusty is offline
Member
 
Join Date: Dec 2007
Posts: 45
Thanks: 5
Thanked 0 Times in 0 Posts
 
Default

I did not add cp user manually. However, removing the client automatically removed the cp user. Then added new client and only changed the sections that client can see (sites only) in the cp user area and it seems to work.

Thanks very much for the help.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Statistic not working mzo Installation/Configuration 49 20th April 2011 13:19
Vhosts...conf not synced to changes crypted General 50 24th April 2010 01:54
Anything I can do against illegal login-requests? schmidtedv Installation/Configuration 17 7th November 2008 10:25
web admin user without email bolero Feature Requests 1 5th September 2008 13:52
issue with no admin user allocated djtremors General 8 14th September 2006 10:50


All times are GMT +2. The time now is 13:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.