Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Developers' Forum

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th July 2010, 21:28
george_yohng george_yohng is offline
Junior Member
 
Join Date: Jun 2010
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default ISPConfig 3 latest SVN problems

Hello,

I have been modifying the 'Perfect Server' script for OpenSUSE 11.3, and found the following problems.

I'm using the latest ISPConfig SVN.
  • run-getmail.sh doesn't want to get executed, /var/log/messages says: /usr/sbin/cron[17880]: Permission denied. Strangely enough, my previous very similar installation on 11.2 (also with the SVN) works correctly.
  • Upon installation, the following is seen:
    ...
    Reconfigure Permissions in master database? (yes,no) [no]: yes

    PHP Notice: Undefined variable: hosts in /tmp/trunk/install/lib/installer_base.lib.php on line 310
    Reconfigure Services? (yes,no) [yes]: yes
    ....
  • Mail filters do not get updated. Upon creating a mail filter for the e-mail box, no files or directories are created in /var/vmail/mailfilters.
  • I couldn't make AWstats work. I assume, this functionality is still in development.

Last edited by george_yohng; 20th July 2010 at 21:33.
Reply With Quote
Sponsored Links
  #2  
Old 21st July 2010, 10:32
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,012
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

1) Please check that you have security extensions like selinux and apparmor diabled as it may prevent the excution from scripts like getmail.sh
2) You have a wrong error reporting setting in php.ini. ISPConfig requires this error reporting level:

error_reporting = E_ALL & ~E_NOTICE

Quote:
Mail filters do not get updated. Upon creating a mail filter for the e-mail box, no files or directories are created in /var/vmail/mailfilters.
Thats ok. Mailfilters in a dovecot setup are not in this location. Dovecot mailfilters are in the .sieve file which is in the maildir.

Quote:
I couldn't make AWstats work. I assume, this functionality is still in development.
No, its finished and working on my servers. Please check the paths to the awstats files in the server settings.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.

Last edited by till; 21st July 2010 at 10:40.
Reply With Quote
  #3  
Old 21st July 2010, 16:50
george_yohng george_yohng is offline
Junior Member
 
Join Date: Jun 2010
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello,

Apparmor and selinux are turned off. However run-getmail.sh still reports permission denied.

This looks a SuSE problem somehow, because even replacing it with /bin/bash -c echo "Hello" would result in permission denied.

Thanks,
George.
Reply With Quote
  #4  
Old 21st July 2010, 16:54
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,012
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

- Does the getmail user exist in /etc/passwd?
- Is the run-getmail.sh file owned by user getmail?
- If you run "su getmail" and then execute the run-getmail.sh file manually, which error do you get?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 21st July 2010, 16:59
george_yohng george_yohng is offline
Junior Member
 
Join Date: Jun 2010
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default

getmail user exists in /etc/passwd
File run-getmail.sh is owned by getmail:ispconfig, and is rwxr--r--
If I run su getmail, I was getting this:
virt:/srv/www/truepianos.com/web/private # su getmail
su: incorrect password

Thank you for the hint, running "passwd getmail" and setting it a password fixed the problem.

I wonder, if this can be automated somehow within ISPconfig, and whether there can be any other parts of ISPconfig, where this may occur.
Reply With Quote
  #6  
Old 21st July 2010, 17:03
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,012
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

The user getmail shall not have a password as it is a passwordless system account. Giving him a password will make the setup less secure and might allow external attacks on this account. There must be a different way to get around the changes in opensuse that causes this problem as it works without password in all linux distriubutions and versions.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 21st July 2010, 17:06
george_yohng george_yohng is offline
Junior Member
 
Join Date: Jun 2010
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default

The situation is like this. /etc/shadow by default contains this line:

getmail:!:14807:0:99999:7:::

In the password field there is an exclamation sign. If I replace the exclamation sign with '*', like for mysql user, then everything starts to work.

ispapps, ispconfig and web1 users also have an exclamation sign in their password field. I wonder, should it affect any functionality of ispconfig?

The exclamation sign doesn't seem to be a problem with OpenSuSE 11.2, but 11.3 somehow make cron react to it like this.

Here is a part of the original shadow file:

tss:!:14807:0:99999:7:::
vmail:*:14807:0:99999:7:::
vscan:*:14807:0:99999:7:::
mysql:*:14807:0:99999:7:::
getmail:!:14807:0:99999:7:::
ispapps:!:14807:0:99999:7:::
ispconfig:!:14807:0:99999:7:::
web1:!:14807:0:99999:7:::
dnsmasq:*:14808:0:99999:7:::
ntop:*:14810:0:99999:7:::

Last edited by george_yohng; 21st July 2010 at 17:17.
Reply With Quote
  #8  
Old 21st July 2010, 22:52
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,012
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

I will check that.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 21st July 2010, 22:56
george_yohng george_yohng is offline
Junior Member
 
Join Date: Jun 2010
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
I will check that.
Would it be possible also to look about mailfilters, because they don't seem to be installed into /var/vmail/mailfilters/domain.com/user

Just an empty mailfilters directory exists there.
Reply With Quote
  #10  
Old 21st July 2010, 23:08
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,012
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
 
Default

Do you use courier or dovecot?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3 - CentOS 5.4 - SSL Problems!?! owainbaber Installation/Configuration 4 26th July 2011 18:12
Problems with ISPConfig 2.2.33 Golden Installation/Configuration 2 18th September 2009 20:10
Problems with Yum following The Perfect Server - CentOS 5.3 x86_64 Guide GOPalmer HOWTO-Related Questions 7 1st July 2009 15:20
ISPConfig 2.3.2-dev released till General 9 4th June 2007 11:46
Users and websites aren't created Glorfindel Installation/Configuration 9 23rd February 2006 05:20


All times are GMT +2. The time now is 18:50.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.