Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th August 2014, 23:55
daviz_zamora daviz_zamora is offline
Member
 
Join Date: Apr 2014
Posts: 31
Thanks: 3
Thanked 0 Times in 0 Posts
Unhappy Dovecot error after installation ISPConfig

Dovecot gives me an error when installing ISPConfig, and creating email accounts, ignores me, not work for me .. I have wrong? What should I change?



Thank you.
Reply With Quote
Sponsored Links
  #2  
Old 14th August 2014, 07:14
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,388
Thanks: 833
Thanked 5,486 Times in 4,318 Posts
Default

The error means that you must have entered something wrong durung ssl cert creation when ispcomfig asked for the ssl cert details which caused the postfix and dovecot ssl cert to be not created. if this is a new installation, then run the uninstall.php script to remove ispconfig, then run the install.php script again to reinstall it.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 14th August 2014, 15:00
ArrChi ArrChi is offline
Junior Member
 
Join Date: Aug 2014
Posts: 8
Thanks: 2
Thanked 0 Times in 0 Posts
Default

You have to generate new certificate and change default path. This problem I noticed in IspConfig3p2 pack.

To fix your problem on shell:

openssl req -x509 -nodes -days 7300 -newkey rsa:2048 -keyout /etc/ssl/private/smtpd.pem -out /etc/ssl/private/smtpd.pem

and then:

vi /etc/dovecot/dovecot.conf


and change default ssl path:

ssl_cert = </etc/ssl/private/smtpd.pem
ssl_key = </etc/ssl/private/smtpd.pem


and

/etc/init.d/dovecot restart or service dovecot restart


Don't forget to chmod correct permission for cert excluding outside access!

You can notice the same problem with postfix certificate. To fix you have to change in main.cf ssl path (and|or) generate new cert or use dovecot pem.

Regards,
Arkadiusz Zug
Reply With Quote
  #4  
Old 16th August 2014, 03:49
daviz_zamora daviz_zamora is offline
Member
 
Join Date: Apr 2014
Posts: 31
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by ArrChi View Post
You have to generate new certificate and change default path. This problem I noticed in IspConfig3p2 pack.

To fix your problem on shell:

openssl req -x509 -nodes -days 7300 -newkey rsa:2048 -keyout /etc/ssl/private/smtpd.pem -out /etc/ssl/private/smtpd.pem

and then:

vi /etc/dovecot/dovecot.conf


and change default ssl path:

ssl_cert = </etc/ssl/private/smtpd.pem
ssl_key = </etc/ssl/private/smtpd.pem


and

/etc/init.d/dovecot restart or service dovecot restart


Don't forget to chmod correct permission for cert excluding outside access!

You can notice the same problem with postfix certificate. To fix you have to change in main.cf ssl path (and|or) generate new cert or use dovecot pem.

Regards,
Arkadiusz Zug
Thanks for reply, say error, look screenshot:



Thanks.
Reply With Quote
  #5  
Old 16th August 2014, 07:59
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,388
Thanks: 833
Thanked 5,486 Times in 4,318 Posts
Default

run:

mkdir /etc/ssl/private


and try again.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
ArrChi (17th August 2014)
  #6  
Old 17th August 2014, 01:06
daviz_zamora daviz_zamora is offline
Member
 
Join Date: Apr 2014
Posts: 31
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
run:

mkdir /etc/ssl/private


and try again.
Thanks, but don't work mail... not start nor in outlook and thunderbird... I restart postfix and Dovector, and say ok... but is not where the problem comes
Reply With Quote
  #7  
Old 17th August 2014, 09:32
ArrChi ArrChi is offline
Junior Member
 
Join Date: Aug 2014
Posts: 8
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by daviz_zamora View Post
Thanks, but don't work mail... not start nor in outlook and thunderbird... I restart postfix and Dovector, and say ok... but is not where the problem comes
Have you check mail log ?
Reply With Quote
  #8  
Old 18th August 2014, 20:55
daviz_zamora daviz_zamora is offline
Member
 
Join Date: Apr 2014
Posts: 31
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by ArrChi View Post
Have you check mail log ?
Yes, but it's empty
Reply With Quote
  #9  
Old 27th August 2014, 13:03
Amorphous Amorphous is offline
Member
 
Join Date: Jun 2009
Posts: 61
Thanks: 27
Thanked 1 Time in 1 Post
Default

Hello,
I have just installed a fresh ISPConfig 3.0.5.4p3, and yes, after the first install.php with all the proper settings, and trust me, i allready have at least 4 or five years since i work with ISPConfig, and is not my first install, indeed the certificate smtpd.cert is not in the correct folder.
With the manual settings and commands

To fix your problem on shell:

openssl req -x509 -nodes -days 7300 -newkey rsa:2048 -keyout /etc/ssl/private/smtpd.pem -out /etc/ssl/private/smtpd.pem

and then:

vi /etc/dovecot/dovecot.conf


and change default ssl path:

ssl_cert = </etc/ssl/private/smtpd.pem
ssl_key = </etc/ssl/private/smtpd.pem

and

/etc/init.d/dovecot restart or service dovecot restart




dovecot starts.


after i will update the first domain into this server, an make all the settings, i will come back with feedback about the functionality for all the processes...

ISPConfig sees all the service online and running.
Reply With Quote
  #10  
Old 27th August 2014, 13:23
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,388
Thanks: 833
Thanked 5,486 Times in 4,318 Posts
 
Default

About which Linux distributionare you talking? I installed ispconfig 3.0.5.4p3 today on Debian for a custmer and all ssl certs were in the right places.

ISPConfig uses a different path for the ssl certs though, ispconfig creates the certs in /etc/postfix/ and configures dovecot to use them from this directory.

Btw. By creating the certs in /etc/ssl/private/ instaed of /etc/postfix, your server will get broken on each update. So I highly recommend to leave the ssl certs in the path that ispconfig configures and in case that they are missing, then create them in the path that ispconfig uses and not in a different path which is incompatible with ispconfig updates.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.

Last edited by till; 27th August 2014 at 13:30.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SMTP offline galdorf Installation/Configuration 8 26th June 2014 22:48
Issues with Mail Setup after "successful" Centos 6_64 Perfect Server (Apache 2) setup elijahb. ISPConfig 3 Priority Support 10 28th August 2013 12:19
Issue with clamd.amavisd in The Perfect Server CentOS 6.4 x86_64 elijahb. HOWTO-Related Questions 3 23rd August 2013 08:52
ISPConfig 3 - MultiServer Setup - With Dedicated Control Panel - How? SuperJC Installation/Configuration 4 16th October 2012 20:03
Can all the installation and configuration be automated (Kickstart) gabby Installation/Configuration 0 30th January 2010 19:47


All times are GMT +2. The time now is 14:05.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.