#1  
Old 16th July 2010, 17:48
007007 007007 is offline
Senior Member
 
Join Date: Jul 2010
Posts: 139
Thanks: 5
Thanked 0 Times in 0 Posts
Default Firewall problem, big problem

Hi,

I spotted a big problem in the firewall ispconfig3, let me explain:

- I installed the server, I installed ispconfig3, I set it up after I enabled the firewall
- I reboot the system, it works
- After I created a client, client's website and FTP
- When I want to connect to FTP client's that does not work, i get this message in flashfxp :

Quote:
SSH-2.0-OpenSSH_5.1p1 Debian-5
QUIT
Protocol mismatch.
(the root shell works)

- I did a reboot, it does not work, the server is down

the server ping internally but not externally. Now the only solution is to restore everything

you know why this problem? any fix for that ?

thx
Reply With Quote
Sponsored Links
  #2  
Old 16th July 2010, 18:17
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,263
Thanks: 216
Thanked 649 Times in 295 Posts
Default

I don't know flashfxp but it seems to be an (s)FTP client. The FTP protocol makes use of port 21, while SSH makes use of port 22.
The error you see probably means that you mix up SSH with FTP.
Please use port 21 for your FTP connections and 22 for SSH.
__________________
Hans

MrHostman | Managed Hosting
Reply With Quote
  #3  
Old 16th July 2010, 18:25
007007 007007 is offline
Senior Member
 
Join Date: Jul 2010
Posts: 139
Thanks: 5
Thanked 0 Times in 0 Posts
Default

ok thx, it's work ^^

but now i have a big problem :

Quote:
- I did a reboot, it does not work, the server is down

the server ping internally but not externally. Now the only solution is to restore everything
any solution for this ? why this problem ?
Reply With Quote
  #4  
Old 16th July 2010, 18:32
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,788
Thanks: 840
Thanked 5,612 Times in 4,423 Posts
Default

How is your server co´nnected to the internet? Do you use a external router?

The ispconfig firewall is for servers that use external routers or are in a datacenter, you can not use the firewall if the server itself uses a software router and is the gateway for other devices on the network as this will cause a conflict in iptables rules.

To fix this if your server is also the network router of your network, simply stop the firewall with its script in /etc/init.d
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 16th July 2010, 19:27
007007 007007 is offline
Senior Member
 
Join Date: Jul 2010
Posts: 139
Thanks: 5
Thanked 0 Times in 0 Posts
 
Default

I do not know, I have a dedicated server at ovh.com ^^

I found that causes the problem, do not select "Network Settings" in server config if the firewall is enabled

Now everything works
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with bastille firewall on OVH RPS servers SupuS Installation/Configuration 12 3rd June 2010 17:20
ISPConfig firewall problem closing Port 21 coen Installation/Configuration 8 4th September 2007 19:25
FTP very slow in LAN, "fast" from WAN-> Firewall problem? Pasco Server Operation 6 7th March 2006 16:17
Firewall problem davidg Installation/Configuration 4 14th August 2005 14:15
Problem opening firewall port weedguy General 15 12th August 2005 02:05


All times are GMT +2. The time now is 02:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.