Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 11th July 2010, 03:55
MrCompTech MrCompTech is offline
Member
 
Join Date: Jul 2010
Posts: 92
Thanks: 1
Thanked 19 Times in 8 Posts
Default ONLY cgi OR fast-cgi works not mod-php or suPHP

I used the Perfect Server F13 - ISPConfig3 to setup this server.

I use phpinfo.php to test the operation of php and the only time it works is when the web site is set to use cgi or fast-cgi and does not work when the web site is set to mod-php or suphp.

When set to mod-php the page returned is entirely blank even if i use view page source there is not any text not even a single html tag.

When I use suPHP I get the error :
===================================
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@rtmdfanc.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
==================================

Any ideas anyone?
Reply With Quote
Sponsored Links
  #2  
Old 11th July 2010, 17:38
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,490
Thanks: 835
Thanked 5,525 Times in 4,346 Posts
Default

1) Post the exact error messages from the error.log of the website.
2) Post the content of the suphp.conf file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 12th July 2010, 18:49
MrCompTech MrCompTech is offline
Member
 
Join Date: Jul 2010
Posts: 92
Thanks: 1
Thanked 19 Times in 8 Posts
Default More Details

When I try to view phpinfo.php while the website is set to "suPHP":

In the log file I get:

[Mon Jul 12 11:19:12 2010] [error] [client 192.168.1.102] SecurityException in Application.php:511: Unknown Interpreter: php
[Mon Jul 12 11:19:12 2010] [error] [client 192.168.1.102] Premature end of script headers: phpinfo.php
[Mon Jul 12 11:19:12 2010] [error] [client 192.168.1.102] File does not exist: /var/www/error/500.html

Removing the check mark from "Own Error-Documents" gets rid of the last error.

And here are my suphp.conf files:
I have two suphp.conf files one in /etc and one in /etc/httpd/conf.d/

/etc/httpd/conf.d/suphp/conf
LoadModule suphp_module modules/mod_suphp.so

/etc/suphp.conf
[global]
;Path to logfile
logfile=/var/log/httpd/suphp.log

;Loglevel
loglevel=info

;User Apache is running as
webserver_user=apache

;Path all scripts have to be in
docroot=/var/www

;Path to chroot() to before executing script
;chroot=/mychroot

; Security options
allow_file_group_writeable=true
allow_file_others_writeable=false
allow_directory_group_writeable=true
allow_directory_others_writeable=false

;Check wheter script is within DOCUMENT_ROOT
docroot=/var/www

;Send minor error messages to browser
errors_to_browser=false

;PATH environment variable
env_path=/bin:/usr/bin

;Umask to set, specify in octal notation
umask=0022

; Minimum UID
min_uid=100

; Minimum GID
min_gid=100

[handlers]
;Handler for php-scripts
x-httpd-suphp=php:/usr/bin/php-cgi

;Handler for CGI-scripts
x-suphp-cgi=execute:!self
Reply With Quote
  #4  
Old 12th July 2010, 18:54
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,490
Thanks: 835
Thanked 5,525 Times in 4,346 Posts
Default

Change the line:

x-httpd-suphp=php:/usr/bin/php-cgi

to:

x-httpd-suphp="php:/usr/bin/php-cgi"

in the suphp.conf file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 12th July 2010, 22:27
MrCompTech MrCompTech is offline
Member
 
Join Date: Jul 2010
Posts: 92
Thanks: 1
Thanked 19 Times in 8 Posts
Default

Excellent Till!

Now it's working!

You are totally awesome!

Do you twitter or have a blog?

I definitely want to be following you!
Reply With Quote
  #6  
Old 13th July 2010, 11:25
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,490
Thanks: 835
Thanked 5,525 Times in 4,346 Posts
 
Default

Quote:
Originally Posted by MrCompTech View Post
Do you twitter or have a blog?
There is a twitter feed for ISPConfig that I manage, but its low traffic a I use it only for release annoncements:

http://twitter.com/ispconfig

Beside that, I run the ISPConfig FAQ on my blog:

http://www.faqforge.com/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with services!! banzaiwebstudio.com Installation/Configuration 7 19th May 2010 22:13
Error when install ISPConfig 2 with components built from source X-admin Installation/Configuration 5 30th April 2010 14:22
ffmpeg Video support for ubuntu 7.10 [suphp-ispconfig] amaurib Installation/Configuration 13 16th February 2010 18:26
Unable to install ISPConfig bdonecker Installation/Configuration 21 26th May 2009 09:20
Apache2 Freezes celtic Server Operation 31 28th May 2007 18:18


All times are GMT +2. The time now is 20:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.