Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 6th June 2006, 19:26
adamluz adamluz is offline
Member
 
Join Date: Aug 2005
Location: Burbank, California
Posts: 76
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to adamluz Send a message via MSN to adamluz
Default

Thank you so much for helping me get the ispconfig control panel back up and running. It also started my httpd which wouldn't start. Thats GREAT! However, I am looking in to the e-mail problem, I followed the guide to a perfect setup but when I attempt to telnet in I run the ehlo localhost command and I get:

500 Error: bad syntax

Any ideas? Also is there a command to make the e-mails process at a faster rate?

Thank you so much for your help
Reply With Quote
Sponsored Links
  #12  
Old 6th June 2006, 19:32
adamluz adamluz is offline
Member
 
Join Date: Aug 2005
Location: Burbank, California
Posts: 76
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to adamluz Send a message via MSN to adamluz
Default

Here's some of mail.cf I think you might need

readme_directory = /usr/share/doc/postfix-2.2.2/README_FILES
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

Does this look open?
Reply With Quote
  #13  
Old 6th June 2006, 20:00
adamluz adamluz is offline
Member
 
Join Date: Aug 2005
Location: Burbank, California
Posts: 76
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to adamluz Send a message via MSN to adamluz
Default

Is there anyone willing to login to my server and see if they can get postfix running correctly? I would appriciate it sooo much.. I don't think I can handle these customers much longer. I see nothing in queue yet mail won't deliver for hours later... when i went in to the directory I see loss of files in the queue folders. and today mail started bouncing again and I think smtp stopped.... ehhh

I reinstalled postfix and still bouncing but I got a ehlo reply thats good

Trying 127.0.0.1...
Connected to localhost (127.0.0.1).
Escape character is '^]'.
220 66-214-254-21.static.lsan.ca.charter.com ESMTP Postfix
ehlo localhost
250-66-214-254-21.static.lsan.ca.charter.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME

All domains are in the domain files, all users are configured in the user files, all mapping looks correct... anyone willing to login?

AIM: litemonkey
MSN: msn@adamluz.com

Thanks
PS. I am extremly deperate right now for any help...

Last edited by adamluz; 6th June 2006 at 21:12.
Reply With Quote
  #14  
Old 6th June 2006, 23:09
adamluz adamluz is offline
Member
 
Join Date: Aug 2005
Location: Burbank, California
Posts: 76
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to adamluz Send a message via MSN to adamluz
Default

pop3 and imap are running fine... here's the bounce message:

Technical details of permanent failure:
PERM_FAILURE: SMTP Error (state 9): 554 <HIDDEN@stricklerins.net>: Relay access denied

when sending from gmail to my server
Reply With Quote
  #15  
Old 6th June 2006, 23:49
adamluz adamluz is offline
Member
 
Join Date: Aug 2005
Location: Burbank, California
Posts: 76
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to adamluz Send a message via MSN to adamluz
Default

Okay here is what my mail log looks like. Something about NOQUEUE

Jun 6 14:41:39 fc4 postfix/smtpd[6179]: NOQUEUE: reject: RCPT from ns1.dipolhosting.com[207.44.130.116]: 554 <hostmaster@absz.com>: Relay access denied; from=<> to=<hostmaster@absz.com> proto=ESMTP helo=<server1.dipolhosting.com>
Jun 6 14:41:39 fc4 postfix/smtpd[6179]: disconnect from ns1.dipolhosting.com[207.44.130.116]
Jun 6 14:41:59 fc4 postfix/smtpd[6092]: connect from mta5b.dm-4.com[64.40.98.33]
Jun 6 14:41:59 fc4 postfix/smtpd[6092]: NOQUEUE: reject: RCPT from mta5b.dm-4.com[64.40.98.33]: 554 <manuel@bgpdesign.com>: Relay access denied; from=<mgm_grand_nightlife@mgmgrand.lasvegas.dm-4.com> to=<manuel@bgpdesign.com> proto=ESMTP helo=<mta5b.dm-4.com>
Jun 6 14:41:59 fc4 postfix/smtpd[6092]: disconnect from mta5b.dm-4.com[64.40.98.33]
Jun 6 14:42:43 fc4 postfix/smtpd[6179]: connect from mail26a.sbc-webhosting.com[216.173.237.164]
Jun 6 14:42:44 fc4 postfix/smtpd[6179]: NOQUEUE: reject: RCPT from mail26a.sbc-webhosting.com[216.173.237.164]: 554 <samantha@stricklerins.net>: Relay access denied; from=<kellyp@monarchexcess.com> to=<samantha@stricklerins.net> proto=SMTP helo=<mail26a.sbc-webhosting.com>
Jun 6 14:42:44 fc4 postfix/smtpd[6179]: disconnect from mail26a.sbc-webhosting.com[216.173.237.164]


Here is the mail.cf one more time:


[root@fc4 ~]# postconf -n
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
broken_sasl_auth_clients = yes
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
debug_peer_level = 2
html_directory = no
inet_interfaces = all
mail_owner = postfix
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man
mydestination = $myhostname, localhost.$mydomain, localhost
newaliases_path = /usr/bin/newaliases.postfix
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/postfix-2.2.2/README_FILES
sample_directory = /usr/share/doc/postfix-2.2.2/samples
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
smtp_tls_note_starttls_offer = yes
smtp_use_tls = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain =
smtpd_sasl_security_options = noanonymous
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_auth_only = no
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
smtpd_use_tls = yes
tls_random_source = dev:/dev/urandom
unknown_local_recipient_reject_code = 550

Last edited by adamluz; 6th June 2006 at 23:53.
Reply With Quote
  #16  
Old 7th June 2006, 00:36
adamluz adamluz is offline
Member
 
Join Date: Aug 2005
Location: Burbank, California
Posts: 76
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to adamluz Send a message via MSN to adamluz
Default

Problem Fixed: After look through this server one other person had the same error as I did but different issue. I was able to look at his config and notied I a missing a lot of things. I added

virtual_maps = hash:/etc/postfix/virtusertable
mydestination = /etc/postfix/local-host-names
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases

To my config which started accepting mail. But I think I am still missing things. I know things are working now but I don't want to get errors in the future. Can someone please look at my config file and let me know what I need to add?

http://www.absz.com/mail_conf.txt

The forum which helped me:
http://www.howtoforge.com/forums/sho...?t=3023&page=2
Reply With Quote
  #17  
Old 7th June 2006, 13:41
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by adamluz
That link is very slow.
What's the output of
Code:
postconf -d|grep mynetworks
and
Code:
postconf -n|grep mynetworks
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #18  
Old 8th June 2006, 18:59
adamluz adamluz is offline
Member
 
Join Date: Aug 2005
Location: Burbank, California
Posts: 76
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to adamluz Send a message via MSN to adamluz
Default

[root@fc4 ~]# postconf -d|grep mynetworks
mynetworks = 127.0.0.0/8 66.214.254.16/29
mynetworks_style = subnet
parent_domain_matches_subdomains = debug_peer_list,fast_flush_domains,mynetworks,perm it_mx_backup_networks,qmqpd_authorized_clients,rel ay_domains,smtpd_access_maps
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks
smtpd_client_event_limit_exceptions = ${smtpd_client_connection_limit_exceptions:$mynetw orks}
smtpd_recipient_restrictions = permit_mynetworks, reject_unauth_destination




[root@fc4 ~]# postconf -n|grep mynetworks
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
Reply With Quote
  #19  
Old 9th June 2006, 12:44
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
 
Default

Quote:
Originally Posted by adamluz
[root@fc4 ~]
mynetworks = 127.0.0.0/8 66.214.254.16/29
This setting allows the 66.214.254.16/29 subnet to send emails without authentication. Most probably your server is abused by spammers from this subnet.
Please run
Code:
postconf -e 'mynetworks = 127.0.0.0/8'
and restart Postfix. Then only localhost can send without authentication.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Not receiving any incoming mail. Jcorrea920 General 11 3rd April 2010 13:08
Filtering emails using Spamassassin and Clamav for Exchange 2000 Server Rocky Server Operation 19 11th March 2008 08:27
Postfix mail is bounced Qrup Server Operation 7 9th May 2006 00:18
Postfix mail is held in queue indefinitely... squallbsr Server Operation 9 15th January 2006 19:13
postfix starts and stops why lhatle Installation/Configuration 2 21st December 2005 15:20


All times are GMT +2. The time now is 18:22.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.