#1  
Old 18th June 2010, 19:25
pluider pluider is offline
Junior Member
 
Join Date: Jun 2010
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default Connection refused 127.0.0.1

I can't send any test emails at all. They just go into limbo. So this is what I've got so far.

Jun 18 11:11:19 hosting2 amavis[20498]: SpamAssassin debug facilities: info
Jun 18 11:11:19 hosting2 amavis[20498]: (!!)TROUBLE in pre_loop_hook: config: no rules were found! Do you need to run 'sa-update'?
Jun 18 11:11:19 hosting2 amavis[20498]: (!)_DIE: Suicide () TROUBLE in pre_loop_hook: config: no rules were found! Do you need to run 'sa-update'?
Jun 18 11:15:01 hosting2 postfix/smtpd[20664]: connect from hosting2.abnet.ca[127.0.0.1]
Jun 18 11:15:01 hosting2 postfix/smtpd[20664]: lost connection after CONNECT from hosting2.abnet.ca[127.0.0.1]
Jun 18 11:15:01 hosting2 postfix/smtpd[20664]: disconnect from hosting2.abnet.ca[127.0.0.1]
Jun 18 11:15:01 hosting2 imapd: Connection, ip=[::ffff:127.0.0.1]
Jun 18 11:15:01 hosting2 imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
Jun 18 11:15:02 hosting2 pop3d: Connection, ip=[::ffff:127.0.0.1]
Jun 18 11:15:02 hosting2 pop3d: Disconnected, ip=[::ffff:127.0.0.1]
Jun 18 11:20:01 hosting2 postfix/smtpd[20870]: connect from hosting2.abnet.ca[127.0.0.1]
Jun 18 11:20:01 hosting2 postfix/smtpd[20870]: lost connection after CONNECT from hosting2.abnet.ca[127.0.0.1]
Jun 18 11:20:01 hosting2 postfix/smtpd[20870]: disconnect from hosting2.abnet.ca[127.0.0.1]
Jun 18 11:20:01 hosting2 pop3d: Connection, ip=[::ffff:127.0.0.1]
Jun 18 11:20:01 hosting2 pop3d: Disconnected, ip=[::ffff:127.0.0.1]
Jun 18 11:20:01 hosting2 imapd: Connection, ip=[::ffff:127.0.0.1]
Jun 18 11:20:01 hosting2 imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
Jun 18 11:20:43 hosting2 postfix/qmgr[16933]: 91A391584F9: from=<apache@hosting2.abnet.ca>, size=716, nrcpt=1 (queue active)
Jun 18 11:20:43 hosting2 postfix/qmgr[16933]: 08D2C158566: from=<test1@abnet.ca>, size=376, nrcpt=1 (queue active)
Jun 18 11:20:43 hosting2 postfix/qmgr[16933]: 55429158432: from=<apache@hosting2.abnet.ca>, size=716, nrcpt=1 (queue active)
Jun 18 11:20:43 hosting2 postfix/qmgr[16933]: 56CBA15857B: from=<test1@abnet.ca>, size=960, nrcpt=2 (queue active)
Jun 18 11:20:43 hosting2 postfix/smtp[20890]: connect to 127.0.0.1[127.0.0.1]: Connection refused (port 10024)
Jun 18 11:20:43 hosting2 postfix/smtp[20891]: connect to 127.0.0.1[127.0.0.1]: Connection refused (port 10024)
Jun 18 17:20:43 hosting2 postfix/smtp[20891]: 08D2C158566: to=<test2@abnet.ca>, relay=none, delay=3230, delays=3230/0.06/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]: Connection refused)
Jun 18 17:20:43 hosting2 postfix/smtp[20890]: 91A391584F9: to=<test2@abnet.ca>, relay=none, delay=3486, delays=3486/0.04/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]: Connection refused)
Jun 18 17:20:43 hosting2 postfix/smtp[20891]: connect to 127.0.0.1[127.0.0.1]: Connection refused (port 10024)
Jun 18 17:20:43 hosting2 postfix/smtp[20891]: 55429158432: to=<test1@abnet.ca>, relay=none, delay=3500, delays=3500/0.12/0.03/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]: Connection refused)
Jun 18 17:20:43 hosting2 postfix/smtp[20890]: connect to 127.0.0.1[127.0.0.1]: Connection refused (port 10024)
Jun 18 17:20:43 hosting2 postfix/smtp[20890]: 56CBA15857B: to=<test1@abnet.ca>, relay=none, delay=3347, delays=3347/0.15/0.01/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]: Connection refused)
Jun 18 17:20:43 hosting2 postfix/smtp[20890]: 56CBA15857B: to=<test2@abnet.ca>, relay=none, delay=3347, delays=3347/0.15/0.01/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]: Connection refused)


I'm thinking that the issue is amavisd.

When I do a status I get

[root@hosting2 log]# /etc/init.d/amavisd status
amavisd dead but subsys locked
amavis-milter is stopped

I can't find what keeps it from running. Any ideas as I'm out of ideas.

I've followed the perfect server for centos 5.4 and I'm running in a 32 bit system.

Thanks for any ideas.
Reply With Quote
Sponsored Links
  #2  
Old 18th June 2010, 19:33
pluider pluider is offline
Junior Member
 
Join Date: Jun 2010
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default update

When I cut and pasted for the forum posting, I noticed a message that said I needed to run sa-update. That ran and it seems amavisd is now running. But I'm still get a connection refused so no mail gets delivered still.
Reply With Quote
  #3  
Old 18th June 2010, 20:56
pluider pluider is offline
Junior Member
 
Join Date: Jun 2010
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Talking Update 2 -- working now

I did the update sa-update and restarted amavis (it still says amavis-milter is stopped) but the error seems to be normal for postfix.

I restarted some of the others like spamassassin and then restarted postfix.

It seems to be delivering mail.

Thanks for listening (reading).
Reply With Quote
  #4  
Old 10th July 2010, 22:27
rashid47010 rashid47010 is offline
Junior Member
 
Join Date: Jul 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

**************************************************
[root@centos mail]# cat -n /etc/hosts
1 # Do not remove the following line, or various programs
2 # that require network functionality will fail.
3 127.0.0.1 mail.saudivalves.com mail centos.saudivalves.com centos localhost.localdomain localhost
4 ::1 localhost6.localdomain6 localhost6
[root@centos mail]#
********************************************
[root@centos ~]# telnet mail.saudivalves.com 25
Trying 127.0.0.1...
Connected to centos.saudivalves.com (127.0.0.1).
Escape character is '^]'.
220 mail.saudivalves.com ESMTP Sendmail 8.13.8/8.13.8; Sat, 10 Jul 2010 22:54:45 +0300
Ehlo localhost
250-mail.saudivalves.com Hello mail.saudivalves.com [127.0.0.1], pleased to meet you
250-ENHANCEDSTATUSCODES
250-PIPELINING
250-8BITMIME
250-SIZE
250-DSN
250-ETRN
250-DELIVERBY
250 HELP
mail from:khalil@saudivalves.com
250 2.1.0 khalil@saudivalves.com... Sender ok
recpt to
500 5.5.1 Command unrecognized: "recpt to"
rcpt to: test@saudivalves.com
250 2.1.5 test@saudivalves.com... Recipient ok
data
354 Enter mail, end with "." on a line by itself
this is the test email from khalil email account to
test eamil account I send this through telnet account

should received by khalil

.
250 2.0.0 o6AJsj5i015630 Message accepted for delivery
quit
221 2.0.0 mail.saudivalves.com closing connection
Connection closed by foreign host.
[root@centos ~]#

[root@centos ~]# tail f /var/maillog

Jul 10 22:55:32 localhost dovecot: imap-login: Login: user=<khalil>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
Jul 10 22:55:32 localhost dovecot: IMAP(khalil): Disconnected: Logged out
Jul 10 22:55:51 localhost sendmail[15630]: o6AJsj5i015630: from=khalil@saudivalves.com, size=135, class=0, nrcpts=1, msgid=<201007101955.o6AJsj5i015630@mail.saudivalve s.com>, proto=ESMTP, daemon=MTA, relay=mail.saudivalves.com [127.0.0.1]
Jul 10 22:55:51 localhost sendmail[15663]: o6AJsj5i015630: to=test@saudivalves.com, ctladdr=khalil@saudivalves.com (501/501), delay=00:00:42, xdelay=00:00:00, mailer=local, pri=30516, dsn=2.0.0, stat=Sent
[root@centos ~]# telnet mail.saudivalves.com pop3
Trying 127.0.0.1...
Connected to centos.saudivalves.com (127.0.0.1).
Escape character is '^]'.
+OK Dovecot ready.
user test
+OK
pass 123456
+OK Logged in.
list
+OK 0 messages:
.


When login to squirrelmail

Jul 10 22:58:04 localhost dovecot: pop3-login: Login: user=<test>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
Jul 10 22:59:14 localhost dovecot: imap-login: Aborted login: user=<test@saudivalves.com>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
Jul 10 22:59:24 localhost dovecot: imap-login: Login: user=<test>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
Jul 10 22:59:24 localhost dovecot: IMAP(test): Disconnected: Logged out
Jul 10 22:59:25 localhost dovecot: imap-login: Login: user=<test>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
Jul 10 22:59:25 localhost dovecot: IMAP(test): Disconnected: Logged out
Jul 10 22:59:25 localhost dovecot: imap-login: Login: user=<test>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
Jul 10 22:59:25 localhost dovecot: IMAP(test): Disconnected: Logged out

************************************************** ************************

I am unable to view the emails of test user through squirrel web interface
and secondly how to configure the client am I am suppose to select the POP or IMAP for receiving email and for outgoing emails am I suppose to select the sendmail or SMTP


regards,
Reply With Quote
  #5  
Old 11th July 2010, 16:47
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,499 Times in 4,328 Posts
 
Default

Login to squirrelmail, the username is the email address. Then send in squirrelmail a email to the email address that you used to login to squirrelmail. Then post the lines that appera in the logfile for this email.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ispconfig 3 cant receive emails lishaw1968 Installation/Configuration 25 19th August 2013 10:37
ISPConfig 3 Send/Receive mail not working. Acidut General 6 4th April 2010 11:24
squirrelmail and postfix witoszek General 12 1st December 2009 18:07
Attacks on MTA dclardy Installation/Configuration 4 29th September 2009 16:50
Mail not working epicuniversal General 5 13th June 2009 08:24


All times are GMT +2. The time now is 03:29.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.