Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th July 2010, 11:01
JamesShijie JamesShijie is offline
Junior Member
 
Join Date: Jul 2010
Posts: 17
Thanks: 1
Thanked 0 Times in 0 Posts
Default Filepaths messed up

Hi there,

I have 2 clients added in my ispconfig 3 -- client1 and client2. Client1 has a website added to it, website1.com. Client2 also has a website added, website2.com. However, no matter WHAT I do, EVERYTHING redirects to client1's /web directory. Even my server address, server.domain.com redirects there. I looked here:

/etc/httpd/conf/sites-enabled

And it has several files, including website1.com and website2.com --However, looking into, say, website2.com.vhost, the filepaths were all correct to go to where they need to go! So what should I do? In my regular httpd.conf file, it has this: Include /etc/httpd/conf/sites-enable - which means that it SHOULD work. Why doesn't it!?

Thanks in advance, everyone has been very helpful here.
Reply With Quote
Sponsored Links
  #2  
Old 7th July 2010, 12:13
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,413
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

Does not look like a problem with file paths. Its more a dns or web settings problem.

Ensure that:

1) Both domains have a dns A-Record for the domain itself and the subdomain www that point to the IP address of the server.
2) That you selected this IP address in the website settings of both websites.
3) that you entered the domain names as domain.com and not www.domain.com in the domain field.
4) That you enabled auto subdomain www.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 7th July 2010, 13:40
JamesShijie JamesShijie is offline
Junior Member
 
Join Date: Jul 2010
Posts: 17
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
2) That you selected this IP address in the website settings of both websites.
Whenever I try to select an IP address, all it has is a '*' instead. Is this ok, or where do I go about changing this to my server IP address?
Reply With Quote
  #4  
Old 8th July 2010, 07:35
JamesShijie JamesShijie is offline
Junior Member
 
Join Date: Jul 2010
Posts: 17
Thanks: 1
Thanked 0 Times in 0 Posts
Default

I've played around with it a bunch, and have deleted all my clients. Now, in the admin tool, with 0 clients, I add 2 websites, with client0 --the default client, as the owner:

site1.com
site2.com

But no matter what I do, everything directs to the first site I created, site1.com --why is that? If you need me to post any vhost entries or anything, let me know.
Reply With Quote
  #5  
Old 8th July 2010, 10:23
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,413
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

Please do what i suggested above and select the ip address and not *. if the ip is not listed there, add it under system > server ip.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 8th July 2010, 10:36
JamesShijie JamesShijie is offline
Junior Member
 
Join Date: Jul 2010
Posts: 17
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Hello,

I needed to add the server IP address. Thank you so much. You guys are really helpful here, and It's much appreciated.
Reply With Quote
  #7  
Old 8th July 2010, 10:43
JamesShijie JamesShijie is offline
Junior Member
 
Join Date: Jul 2010
Posts: 17
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Now it's redirecting all my sites to /var/www/html, and not using their apache directives. Do I need to redo them all, or is there anything I can change? I made sure I had www on the options, and the ip address of the server was selected. The a-records are correct on the DNS side of things.
Reply With Quote
  #8  
Old 8th July 2010, 10:44
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,413
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

you have either to use * for all sites or the ip addressbut do not mix it.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 8th July 2010, 10:51
JamesShijie JamesShijie is offline
Junior Member
 
Join Date: Jul 2010
Posts: 17
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

I have them all using the IP Address, as you suggested. No site is using the "*". And now, all the traffic is going to /var/www/html -- Is there anything else I can check?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I've messed up my dns somehow Confused Installation/Configuration 1 2nd April 2009 10:35
Repositories messed up after F10 upgrade... jkrell HOWTO-Related Questions 2 22nd December 2008 06:41
File Permissions messed up kextra1 General 4 25th October 2008 21:08
Should a messed up DNS setup be reinstalled wxman Server Operation 9 19th October 2007 12:25
Messed up file rights in Debian Lord Odin Installation/Configuration 1 28th July 2006 13:58


All times are GMT +2. The time now is 22:24.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.