#1  
Old 3rd September 2005, 20:52
Zoon Zoon is offline
Member
 
Join Date: Sep 2005
Posts: 30
Thanks: 0
Thanked 1 Time in 1 Post
Default Log file issues

Heya,

Firstly, ISPConfig is excellent, especially for a free product.

Secondly, am having some problems with the log files.

The build is a brand new flat install of redhat FC4 and I followed the howtoforge "perfect setup" guide exactly, EXCEPT I have SELinux enabled and I'm using the firewall which comes with FC4 instead of the firewall built in to ISPConfig

httpd wouldn't start originally with the original CustomLog statement in httpd.conf as follows:

Code:
CustomLog "|/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d" combined_ispconfig
I had to comment it out in order for httpd to start correctly. I removed part of the line and httpd would start - as follows:

Code:
CustomLog "/var/log/httpd/ispconfig_access_log_%Y_%m_%d" combined_ispconfig
... this shows which bit was not working but obviously the CustomLog command does not do the same thing as before.

Once I had gotten past this, I added a vhost, and httpd failed to start again.

Going methodically, I commented out every line in Vhosts_ispconfig.conf and one by one set them active again until I found the command causing httpd to fail starting.

This is the command which caused the issue:

Code:
ErrorLog /home/web4/log/error.log
This is ls -l on the vhost folder

Code:
[root@emily web4]# ls -l
total 48
drwxrwxr-x  2 apache web4 4096 Sep  3 18:10 cgi-bin
drwxr-xr-x  2 apache web4 4096 Sep  3 19:50 log
drwxrwxrwx  2 apache web4 4096 Sep  3 18:10 phptmp
drwxr-xr-x  2 apache web4 4096 Sep  3 18:10 ssl
drwxr-xr-x  2 apache web4 4096 Sep  3 18:10 user
drwxrwxr-x  3 apache web4 4096 Sep  3 18:10 web
Any help on this would be appreciated ... I'm not too fussed about logs myself but chances are I won't be the only one with websites on this server and they may want to look at their logs.

Cheers
Reply With Quote
Sponsored Links
  #2  
Old 3rd September 2005, 21:04
Zoon Zoon is offline
Member
 
Join Date: Sep 2005
Posts: 30
Thanks: 0
Thanked 1 Time in 1 Post
Default

Oh and one other thing differ from the default, I used /home instead of /home/www for the root dir for web account folders.
Reply With Quote
  #3  
Old 4th September 2005, 07:55
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,478
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
Default

Quote:
Originally Posted by Zoon
Heya,

Firstly, ISPConfig is excellent, especially for a free product.

Secondly, am having some problems with the log files.

The build is a brand new flat install of redhat FC4 and I followed the howtoforge "perfect setup" guide exactly, EXCEPT I have SELinux enabled and I'm using the firewall which comes with FC4 instead of the firewall built in to ISPConfig

httpd wouldn't start originally with the original CustomLog statement in httpd.conf as follows:

Code:
CustomLog "|/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d" combined_ispconfig
I had to comment it out in order for httpd to start correctly. I removed part of the line and httpd would start - as follows:

Code:
CustomLog "/var/log/httpd/ispconfig_access_log_%Y_%m_%d" combined_ispconfig
... this shows which bit was not working but obviously the CustomLog command does not do the same thing as before.

Once I had gotten past this, I added a vhost, and httpd failed to start again.

Going methodically, I commented out every line in Vhosts_ispconfig.conf and one by one set them active again until I found the command causing httpd to fail starting.

This is the command which caused the issue:

Code:
ErrorLog /home/web4/log/error.log
This is ls -l on the vhost folder

Code:
[root@emily web4]# ls -l
total 48
drwxrwxr-x  2 apache web4 4096 Sep  3 18:10 cgi-bin
drwxr-xr-x  2 apache web4 4096 Sep  3 19:50 log
drwxrwxrwx  2 apache web4 4096 Sep  3 18:10 phptmp
drwxr-xr-x  2 apache web4 4096 Sep  3 18:10 ssl
drwxr-xr-x  2 apache web4 4096 Sep  3 18:10 user
drwxrwxr-x  3 apache web4 4096 Sep  3 18:10 web
Any help on this would be appreciated ... I'm not too fussed about logs myself but chances are I won't be the only one with websites on this server and they may want to look at their logs.

Cheers
With your modifications the apache Logging in ISPConfig wont work anymore.

SELinux dont like apache directories in the /home directory. You can a) disable SELinux b) reconfigure SELinux that it accepts the home directory and the cronolog logging application (dont know how) or c) find out in which directory SELinux accepts apache vhosts and install ISPConfig with this settings (maybe you have to copy the cronolog binary to another location too).
Reply With Quote
  #4  
Old 4th September 2005, 11:55
Zoon Zoon is offline
Member
 
Join Date: Sep 2005
Posts: 30
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

I just did

vi /etc/sysconfig/selinux

and set

SELINUX=disabled

and its all working ok now. I don't need it on anyway, cheers for the help
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Echo into a file torben Programming/Scripts 5 21st October 2010 09:37
symbol errno, version GLIBC_2.0 not defined in file libc.so.6 with link time referenc mconigliaro Installation/Configuration 11 28th May 2007 16:31
Loading configuration file lance Kernel Questions 2 28th February 2007 20:40
Could not make OpenSSL yontengyatso Installation/Configuration 3 3rd November 2005 10:50
Passwd File latcarf Server Operation 4 30th August 2005 01:18


All times are GMT +2. The time now is 23:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.