Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 17th June 2006, 22:12
domino domino is offline
Senior Member
 
Join Date: Aug 2005
Posts: 364
Thanks: 0
Thanked 10 Times in 9 Posts
Default

Quote:
Originally Posted by falko
@domino: What commands exactly did you run that gave you these errors?

@glennb: The defaulr login after the initial ISPConfig installation is username admin, password admin, as described here: http://www.ispconfig.org/manual_installation.htm
Damn mate. I didn't get a response email about the new reply on this thread. I got those messages from the beginning of the Ubuntu installation. The weard thing is, I gave up on it and left ISPConfig install (the db part) as is and went to bed. The following morning, I typed the password and it accepted it! Damned boogie man Everything is okay now.

A little suggestion, since you have gotten a lot of questions about the initial username and password for ISPC, would it hurt to include the name and password immediately after the ISPConfig installation is finished?

Last edited by domino; 17th June 2006 at 22:14.
Reply With Quote
Sponsored Links
  #12  
Old 18th June 2006, 10:55
donanak donanak is offline
Junior Member
 
Join Date: Apr 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm also getting the same error [root@server0 ~]# mysqladmin -u root password *******
mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: NO)'

when i use webmin interface to login i get this error:
The full MySQL error message was : connect to server at 'localhost' failed error: 'Access denied for user 'root'@'localhost' (using password: YES)'

Following the howto I didn't get any error until finished and tried to log in to mysql. So i decided to uninstall it with this command: yum remove mysql

Then reinstall it again and now it comes with the error above. I'm not using ISPConfig. I've followed stacks of "howto reset password" and still no sunshine.

Please can someone help me get this out of the way, as all my other services i'm going to setup requires mysql login.

Thanks in advace.

Last edited by donanak; 18th June 2006 at 11:04.
Reply With Quote
  #13  
Old 18th June 2006, 14:34
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Quote:
Originally Posted by domino
A little suggestion, since you have gotten a lot of questions about the initial username and password for ISPC, would it hurt to include the name and password immediately after the ISPConfig installation is finished?
Yes, we could include it in the message about the successful installation.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #14  
Old 18th June 2006, 14:36
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Quote:
Originally Posted by donanak
I'm also getting the same error [root@server0 ~]# mysqladmin -u root password *******
mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: NO)'
This means you have already set a password for MySQL. To change it, have a look here: http://www.howtoforge.com/forums/sho...45&postcount=4
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #15  
Old 18th June 2006, 23:26
donanak donanak is offline
Junior Member
 
Join Date: Apr 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up

Thanks Falko,
I could now log on to mysql with my new password using webmin, but for some reason it wouldn't work on the command line.

I could see only one encrypted password for user root on host local host with permission All. Another root with host server0.tld has blank space for encrypted password and permission is ALL.
Then there is 2 anonymous users, for host localhost and server0.tld with blanks for encrypted password and permission NONE.

I don't know if this gives the clear picture of the table, but can anyone help me make things right? I tried to copy and paste the table but it keeps messing up as scrumbled eggs.

Thanks alot.

Last edited by donanak; 19th June 2006 at 00:55. Reason: give clear information
Reply With Quote
  #16  
Old 19th June 2006, 17:44
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
 
Default

Quote:
Originally Posted by donanak
Another root with host server0.tld has blank space for encrypted password and permission is ALL.
This means you must also run
Code:
mysqladmin -h server0.tld -u root password yourrootsqlpassword
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
monit howto Jamesk5 HOWTO-Related Questions 11 5th August 2008 16:10
Apache - Virtual hosts - ISPConfig Hans Server Operation 8 23rd April 2006 17:29
Problems installing NForce4 sound drivers Wraithfire Installation/Configuration 21 16th April 2006 18:30
How to install BFD (Brute Force Detection) domino Tips/Tricks/Mods 9 31st March 2006 23:40
Everything owned by root !!! wwparrish Installation/Configuration 6 7th February 2006 22:25


All times are GMT +2. The time now is 02:20.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.