Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 5th July 2010, 00:44
marmellata marmellata is offline
Junior Member
 
Join Date: Jul 2009
Posts: 29
Thanks: 1
Thanked 0 Times in 0 Posts
Default ispconfig 3 Debian the perfect server

Hello,
I followed the perfect server debian lenny ispconfig 3 howTo and installation was fine. My server is server1.sialpe.com 192.168.0.100. Lets suppose Ip assigned me by isp is 80.66.17.56. By ispconfig I created a new site as you see in web domain and I created dns zone and records. I configured my router to forward port 80 (+ some other ones) as you can see in picture. I then configured so that is my server1 to manage my domain name sialpe.com as you see in the last picture. Now the problem is that from a pc inside my lan I cant see my site www.sialpe.com but when I set 192.168.0.100 to be my dns server I can see the default "it works!" page index.html which is in /var/www not /var/www/sialpe.com folder. Am I doing something wrong?
Attached Images
    

Last edited by marmellata; 6th July 2010 at 07:17.
Reply With Quote
Sponsored Links
  #2  
Old 5th July 2010, 17:27
marmellata marmellata is offline
Junior Member
 
Join Date: Jul 2009
Posts: 29
Thanks: 1
Thanked 0 Times in 0 Posts
Default

I added A record in dns server of my domain registry but still doesnt work
Reply With Quote
  #3  
Old 5th July 2010, 18:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

You are using private IP addresses (192.168.0.100) for your DNS records. You must use public IP addresses, or your web sites cannot be accessed from outside your LAN.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 6th July 2010, 23:51
marmellata marmellata is offline
Junior Member
 
Join Date: Jul 2009
Posts: 29
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Thanks for you answer but I'm totally confused.. you mean I need a public ip address each site I have? or you mean I have to create another A record which point to my public ip address (that is always the same)? isnt it correct I define in my ispconfig dns zone my www or mail server is 192.168.0.100 located? Was looking at this thread http://www.howtoforge.com/forums/sho...spconfig+mydns

Last edited by marmellata; 6th July 2010 at 23:58.
Reply With Quote
  #5  
Old 7th July 2010, 00:04
marmellata marmellata is offline
Junior Member
 
Join Date: Jul 2009
Posts: 29
Thanks: 1
Thanked 0 Times in 0 Posts
Default

My domain registry said it is no possible to use my dns instead of their ones if mine have the same ip address
Reply With Quote
  #6  
Old 7th July 2010, 14:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
 
Default

Quote:
Originally Posted by marmellata View Post
Thanks for you answer but I'm totally confused.. you mean I need a public ip address each site I have?
No, one public IP is fine.

Quote:
Originally Posted by marmellata View Post
or you mean I have to create another A record which point to my public ip address (that is always the same)? isnt it correct I define in my ispconfig dns zone my www or mail server is 192.168.0.100 located? Was looking at this thread http://www.howtoforge.com/forums/sho...spconfig+mydns
You have to change your DNS records so that they point to your public IP instead of your private IP.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail -Ubuntu 8.04 c4rdinal HOWTO-Related Questions 112 23rd August 2011 10:49
Can't Ping over VPN RoMiONeT Server Operation 2 4th July 2010 00:19
The Perfect Server - Debian Lenny (Debian 5.0) [ISPConfig 3] husskii HOWTO-Related Questions 5 8th January 2010 14:44
subdomain and mail relay configuration aranthorn Installation/Configuration 24 3rd September 2007 22:53
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 02:30


All times are GMT +2. The time now is 11:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.