Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 5th July 2010, 08:34
vtapas vtapas is offline
Member
 
Join Date: Apr 2010
Posts: 51
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default proxypassreverse cookie domain

I have 7-8 websites
running on Apache2

Code:
<VirtualHost *:80>

ServerAdmin webmaster@localhost
ServerName mydomain.com
ProxyRequests off
<Proxy *>
Order deny,allow
Allow from all
</Proxy>

ProxyPreserveHost On

ProxyPass /something1 192.168.1.5/something1
ProxyPassReverse /something1 192.168.1.5/something1

ProxyPass /something2 192.168.1.5/something2/www/
ProxyPassReverse /something2 192.168.1.5/something2/www/

ProxyPass /something3 192.168.1.5/something3/
ProxyPassReverse /something3 192.168.1.5/something3/

ProxyPass /something4 192.168.1.5/something4/
ProxyPassReverse /something4 192.168.1.5/something4/

ProxyPass /something5 192.168.1.5/something5
ProxyPassReverse /something5 192.168.1.5/something5

ProxyPass /something6 192.168.1.5:8080/something6
ProxyPassReverse /something6 192.168.1.5:8080/something6

ProxyPass /something7 192.168.1.5:6060/portal
ProxyPassReverse /something7 192.168.1.5:6060/something7

ProxyPass /atutor 192.168.1.5atutor
ProxyPassReverse /atutor 192.168.1.5atutor
ProxyPassReverseCookieDomain internal.domain.com external.domain.com
ProxyPassReverseCookiePath / /atutor







ProxyPass / 192.168.1.5/
ProxyPassReverse / 192.168.1.5/

ErrorLog /var/log/apache2/mydomain_error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel debug

CustomLog /var/log/apache2/mydomain_access.log combined

CustomLog /var/log/apache2/mydomain-resp_log resp
LogFormat "%D %{X-Forwarded-For}i %t" resp

</VirtualHost>
If some one has to login to http://mydomain.com/atutor then his session is not getting maintained can some one point what is the mistake in above configuration?
Reply With Quote
Sponsored Links
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix queue problem? murunix Server Operation 7 2nd May 2011 01:55
ERROR: Connection dropped by IMAP server. [Centos 5.4, courier imap,squirrel, etc] darevil HOWTO-Related Questions 7 9th June 2010 14:49
Sending mail ISPConfig 3 but not receivind catza Installation/Configuration 20 19th May 2010 12:47
email issue for second domain configured ISPConfig3 mscomputing Installation/Configuration 1 10th November 2009 10:09
CentoS doesn't send the emails vaio1 Installation/Configuration 18 5th November 2008 17:51


All times are GMT +2. The time now is 23:07.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.