#1  
Old 4th July 2010, 07:17
heymrdj heymrdj is offline
Member
 
Join Date: Feb 2007
Posts: 58
Thanks: 2
Thanked 4 Times in 4 Posts
Default 2GB FTP resume limit

I'm running the latest build of ISPconfig 3 on a Debian 5 lenny build using the HOW TO guide on the site here. Something I've run into is pureftp's limit on resuming large files, which just about all of the files some of my sites handle are (high res psd's, disc images ect for graphics design). When I am downloading a file via FTP, and I try to resume it, it says this server does not support resuming of files greater than 2GB. They talk about it here: http://www.debian-administration.org...228#comment_20

So in the end is my only resource to recompile pureftp with support? (how would I go about doing that so that ISPConfig is still happy, if anyone knows), or is there another alternative. I can't be the only ISPConfig site to have hit this snag.

Thanks!
Reply With Quote
Sponsored Links
  #2  
Old 5th July 2010, 17:53
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

As far as I know, recompiling is the only option.

Quote:
how would I go about doing that so that ISPConfig is still happy, if anyone knows
http://www.faqforge.com/linux/contro...ities-enabled/

just ensure that it is compiles with the --with-largefile option. But as far as I know, this is already the case on debian. So you might want to try a different FTP client first as it can be a limit of the ftp client as well.

Quote:
I can't be the only ISPConfig site to have hit this snag.
Websites contains mostly files that are just a few kb or mb in size and not > 2 GB. Thats why not many poeple might have encountered this compile limit in pure-ftpd.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
heymrdj (5th July 2010)
  #3  
Old 5th July 2010, 18:10
heymrdj heymrdj is offline
Member
 
Join Date: Feb 2007
Posts: 58
Thanks: 2
Thanked 4 Times in 4 Posts
 
Default

Quote:
Originally Posted by till View Post
As far as I know, recompiling is the only option.



http://www.faqforge.com/linux/contro...ities-enabled/

just ensure that it is compiles with the --with-largefile option. But as far as I know, this is already the case on debian. So you might want to try a different FTP client first as it can be a limit of the ftp client as well.



Websites contains mostly files that are just a few kb or mb in size and not > 2 GB. Thats why not many poeple might have encountered this compile limit in pure-ftpd.
Thanks alot! I'll give these solutions a try. I was using Filezilla, but I'll grab another client just in case it's causing the issue. If that doesn't nix the issue I'll recompile --with-largefile option turned on and see if that remedies it.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Attacks on MTA dclardy Installation/Configuration 4 29th September 2009 17:50
proFTPd passive mode problems bisbell Server Operation 8 6th August 2008 22:12
slow download through webserver problem snewp Technical 14 9th May 2008 06:25
Question about Virtual Hosting With Proftpd And MySQL (Incl. Quota) On Debian Etch ikkem HOWTO-Related Questions 30 26th February 2008 20:38
Website users? ctroyp General 25 6th January 2006 19:02


All times are GMT +2. The time now is 01:52.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.