#1  
Old 4th June 2006, 09:18
galmiche galmiche is offline
Junior Member
 
Join Date: Jun 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy .htaccess never executed

Dear All,

I'm under Suse X64 and I try to enable the .htaccess file
In my /etc/apache2/http.conf I have:

# grant /srv/www access using .ht files
<Directory /srv/www>
Options None
AllowOverride AuthConfig
Order allow,deny
Allow from all
</Directory>
# use .htaccess files for overriding,
AccessFileName .htaccess
# and never show them
<Files ~ "^\.ht">
Order allow,deny
Deny from all
</Files>

my main directory for the web server is /srv/www

so under the sub dir "test" I added the file /srv/www/test/.htaccess

AuthUserFile /srv/www/test/.htpasswd
AuthName "Acces Restreint"
AuthType Basic
<limit GET POST>
order deny,allow
deny from .ipt.aol.com
require valid-user
</limit>

But when I browse the repertory "test" no pop-up window appears asking me for a password, I see clearly the index.htm file as if no .htaccess file was existing.
Why?
What parameters have to be actvated so apache2 takes .htaccess files into account?

Many thanks for help,
Herv
Reply With Quote
Sponsored Links
  #2  
Old 4th June 2006, 11:40
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,778
Thanks: 821
Thanked 5,334 Times in 4,184 Posts
Default

Have you restarted apache after changing the httpd.conf?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 4th June 2006, 21:44
galmiche galmiche is offline
Junior Member
 
Join Date: Jun 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default RE: .htaccess never executed

Hey boy'z,

I found the bug...
As I am using a virtual server system, and even as I wrote in the main httpd.conf file:
<Directory /srv/www>
Options None
AllowOverride AuthConfig
...

thus I have had in the directives inside my virtual .conf menu another line
<Directory /srv/www/my_server>
Options None
AllowOverride None
...

Then this one, specially for the sub-dir my_server, overlapped the previous AllowOverride value !

So, to all of you, thanks for help and double check overlapping values

Sincerelly
Herv

Now..I have to write correctly my .htpasswd file...a good job to do !

Last edited by galmiche; 4th June 2006 at 22:21.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
.htaccess stopped working tgansert Installation/Configuration 2 1st June 2006 16:48
.htaccess question Ovidiu Installation/Configuration 3 13th March 2006 23:30
.htaccess and php_flag register_globals on edge Installation/Configuration 6 9th March 2006 20:05
.htaccess mtamaos Server Operation 1 28th November 2005 11:04
.htaccess PHP - Hobe it make sence. Joe-Montana Server Operation 3 5th November 2005 01:36


All times are GMT +2. The time now is 10:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.