Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th June 2010, 03:26
spanish spanish is offline
Member
 
Join Date: Nov 2009
Posts: 55
Thanks: 12
Thanked 4 Times in 4 Posts
Default Postfix TLS library problem

Hello,

I have installed OpenMeetings in my OpenVZ ISPConfig machine (server1.domain.org, 11.22.33.44). I have configured the SMTP parameters of OpenMeetings with my ISPConfig mail address (mail@domain.org).

When OpenMeetings tries send an email, I get this error of Postfix:
Code:
Jun 30 02:55:59 servidor postfix/smtpd[10397]: connect from server1.domain.org[11.22.33.44]
Jun 30 02:55:59 servidor postfix/smtpd[10397]: SSL_accept error from server1.domain.org[11.22.33.44]: 0
Jun 30 02:55:59 servidor postfix/smtpd[10397]: warning: TLS library problem: 10397:error:14094416:SSL routines:SSL3_READ_BYTES:sslv3 alert certificate unknown:s3_pkt.c:1053:SSL alert number 46:
Jun 30 02:55:59 servidor postfix/smtpd[10397]: lost connection after STARTTLS from server1.domain.org[11.22.33.44]
Jun 30 02:55:59 servidor postfix/smtpd[10397]: disconnect from server1.domain.org[11.22.33.44]
# telnet localhost 25
Code:
Trying 127.0.0.1...
Connected to localhost.localdomain.
Escape character is '^]'.
220 Hello friend
ehlo localhost
Code:
250-server1.domain.org
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
# vi /etc/postfix/main.cf
Code:
...
# TLS parameters
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
...
Any idea?

Thanks,

Manuel
Reply With Quote
Sponsored Links
  #2  
Old 30th June 2010, 15:19
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,736 Times in 2,571 Posts
Default

Did you see any errors when you created the SSL certificate?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 1st July 2010, 05:05
spanish spanish is offline
Member
 
Join Date: Nov 2009
Posts: 55
Thanks: 12
Thanked 4 Times in 4 Posts
Default

No, everything went well.
Reply With Quote
  #4  
Old 2nd July 2010, 00:51
spanish spanish is offline
Member
 
Join Date: Nov 2009
Posts: 55
Thanks: 12
Thanked 4 Times in 4 Posts
Default

I have configured mail@domain.org in Thunderbird with SMTP = TLS and I can send mails without problem.
Reply With Quote
  #5  
Old 2nd July 2010, 09:13
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
Default

Code:
Jun 30 02:55:59 servidor postfix/smtpd[10397]: SSL_accept error from server1.domain.org[11.22.33.44]: 0
tells me you want to create an SSL connection, before even sending STARTTLS, so you configured the wrong secure connection in your mail client.
Reply With Quote
  #6  
Old 2nd July 2010, 13:02
spanish spanish is offline
Member
 
Join Date: Nov 2009
Posts: 55
Thanks: 12
Thanked 4 Times in 4 Posts
 
Default

Thanks, Mark, I will try solve this and inform here. Greetings, Manuel
Reply With Quote
Reply

Bookmarks

Tags
postfix, tls

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Email problem 'Cannot set my user or group id.' (using ISPConfig 3 + OpenSuSE 11.2) urosm Installation/Configuration 5 19th June 2010 22:41
ERROR: Connection dropped by IMAP server. [Centos 5.4, courier imap,squirrel, etc] darevil HOWTO-Related Questions 7 9th June 2010 14:49
Cannot send or receive mail farbrorc Installation/Configuration 6 24th January 2010 11:56
ISPConfig3 Mail Warn Errors reason8 General 3 25th November 2009 13:58
Ubuntu 7 Perfect Install - Postfix With SMTP-AUTH And TLS Problem pyropoptrt HOWTO-Related Questions 2 27th April 2007 04:40


All times are GMT +2. The time now is 11:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.