Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 29th June 2010, 19:23
onastvar onastvar is offline
Senior Member
 
Join Date: Apr 2008
Location: U.S.A.
Posts: 182
Thanks: 57
Thanked 9 Times in 9 Posts
Exclamation ISPConfig & Joomla 1.5

In ISPConfig 3 (CentOS 5.4) all of my sites have PHP set to Mod-PHP, when I am in Joomla Admin > Help > System Info > Directory Permissions are all unwritable.

Joomla Front Page and Joomla Admin are working as expected. The problem I am having is that I am unable to install any modules, components, plugins, etc. This is fresh joomla install from last night. I'm not sure If I need to "chown" anything on ISPConfig 3 for my Joomla installations. I had to do "chown" in ISPConfig 2 for each joomla site?

Anyone knows workaround for this issue?

For example:
administrator/backups/ Unwritable
administrator/components/ Unwritable
administrator/language/ Unwritable
administrator/language/en-GB/ Unwritable
administrator/modules/ Unwritable
administrator/templates/ Unwritable
components/ Unwritable
images/ Unwritable

here's the output of my ls -la web

Code:
total 288
drwx--x--- 19 web25 client0   4096 Jun 28 21:33 .
drwxr-x--x  6 web25 client0   4096 Jun 28 19:59 ..
drwxr-xr-x 11 web25 client0   4096 Jun 28 21:25 administrator
drwxr-xr-x  2 web25 client0   4096 Jun 28 20:11 cache
-rw-r--r--  1 web25 client0 102201 Jun 28 20:11 CHANGELOG.php
drwxr-xr-x 17 web25 client0   4096 Jun 28 20:11 components
-rw-r--r--  1 web25 client0   1750 Jun 28 21:50 configuration.php
-rw-r--r--  1 web25 client0   3411 Jun 28 20:11 configuration.php-dist
-rw-r--r--  1 web25 client0   1172 Jun 28 20:11 COPYRIGHT.php
-rw-r--r--  1 web25 client0  15050 Jun 28 20:11 CREDITS.php
drwxr-xr-x  2 web25 client0   4096 Jun 28 19:59 error
-rw-r--r--  1 web25 client0    894 Jun 28 21:28 favicon.ico
drwxr-xr-x  4 web25 client0   4096 Jun 28 21:27 FILES
-rwxr-xr--  1 web25 client0      0 Jun 28 19:59 htaccess1.txt
-rw-r--r--  1 web25 client0   2773 Jun 28 20:11 htaccess.txt
drwxr-xr-x  7 web25 client0   4096 Jun 28 20:11 images
drwxr-xr-x  8 web25 client0   4096 Jun 28 20:12 includes
-rw-r--r--  1 web25 client0    588 Jun 28 20:11 index2.php
-rwxr-xr--  1 web25 client0   1861 Jun 28 19:59 index.html
-rw-r--r--  1 web25 client0   2049 Jun 28 20:11 index.php
-rw-r--r--  1 web25 client0   4344 Jun 28 20:11 INSTALL.php
drwxr-xr-x  4 web25 client0   4096 Jun 28 20:12 language
drwxr-xr-x 16 web25 client0   4096 Jun 28 20:12 libraries
-rw-r--r--  1 web25 client0  17816 Jun 28 20:11 LICENSE.php
-rw-r--r--  1 web25 client0  27986 Jun 28 20:11 LICENSES.php
drwxr-xr-x  2 web25 client0   4096 Jun 28 20:12 logs
drwxr-xr-x  4 web25 client0   4096 Jun 28 20:12 media
drwxr-xr-x 33 web25 client0   4096 Jun 28 20:12 modules
drwxr-xr-x 11 web25 client0   4096 Jun 28 20:12 plugins
-rwxr-xr--  1 web25 client0    304 Jun 28 20:11 robots.txt
drwxr-xr-x  2 web25 client0   4096 Jun 29 00:30 stats
drwxr-xr-x  7 web25 client0   4096 Jun 28 20:12 templates
drwxr-xr-x  2 web25 client0   4096 Jun 28 20:13 tmp
drwxr-xr-x  4 web25 client0   4096 Jun 28 20:13 xmlrpc
Thanks!
Reply With Quote
Sponsored Links
  #2  
Old 29th June 2010, 19:54
ivomendonca ivomendonca is offline
Banned
 
Join Date: Sep 2009
Posts: 132
Thanks: 10
Thanked 13 Times in 7 Posts
Default

Suexec + fast-cgi
Reply With Quote
  #3  
Old 29th June 2010, 21:40
onastvar onastvar is offline
Senior Member
 
Join Date: Apr 2008
Location: U.S.A.
Posts: 182
Thanks: 57
Thanked 9 Times in 9 Posts
Default

When I switch to SuEXEC + Fast-CGI I get 503 Service Temporarily Unavailable. Any other suggestions?
Reply With Quote
  #4  
Old 30th June 2010, 00:28
ivomendonca ivomendonca is offline
Banned
 
Join Date: Sep 2009
Posts: 132
Thanks: 10
Thanked 13 Times in 7 Posts
Default

Quote:
Originally Posted by onastvar View Post
When I switch to SuEXEC + Fast-CGI I get 503 Service Temporarily Unavailable. Any other suggestions?
Yes, delete the site, and start with that.

If that doenst work, see the worldpress example in the forum, and joomla is the same (only tried worldpress).

Last edited by ivomendonca; 30th June 2010 at 00:30.
Reply With Quote
  #5  
Old 30th June 2010, 21:49
onastvar onastvar is offline
Senior Member
 
Join Date: Apr 2008
Location: U.S.A.
Posts: 182
Thanks: 57
Thanked 9 Times in 9 Posts
 
Default ISPConfig & Joomla 1.5 [Solved]

I've recreated the site in ISPConfig 3, checked SuEXEC + Fast-CGI, I still had problems with joomla install. I had to run

Code:
chmod -R 777 /var/lib/php/session
after that everything was fine. Thanks ivomendonca for your help.
Reply With Quote
The Following User Says Thank You to onastvar For This Useful Post:
falko (1st July 2010)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3.0.0.4 Beta Released till General 54 4th March 2009 09:55
ISPConfig 3.0.0.5 Beta Released till General 77 23rd July 2008 12:14
Joomla + suPHP + ispconfig + Etch causes too many processes! Insane1 HOWTO-Related Questions 4 11th May 2008 17:51
ISPconfig after installation cannot reach www.xyz.de:81 Figth4Linux Installation/Configuration 23 6th March 2008 22:38
SP-Server Setup - Ubuntu 5.10 "Breezy Badger" - Page 6 (changes) LuisC-SM HOWTO-Related Questions 0 21st April 2006 15:16


All times are GMT +2. The time now is 10:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.