Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th June 2010, 21:19
mbaldwin mbaldwin is offline
Junior Member
 
Join Date: Jun 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Pure-ftpd not authorizing users.

Hi,
Because this is my first post, first I want to say hi, and thanks to the developers of ISPConfig 3. I found it fairly easy to install, and get my sites up an running. I do have a few suggestions I might make in the appropriate forums, if they have not been made already.

On to my issue. I have ISPConfig 3.0.2.2 installed on 2 different servers. I had to install pure-ftpd from source, compiling it without capabilities because I am running on a VPS. On server 2, my pure-ftpd works fine, users can log in, upload files etc. On my server 1. i can add ftp users, but they are unable to log in and do anything. All I can find in the logs is user not authorized. i have looked at the /etc/pure-ftpd/db/mysql.conf, and everything looks in order. i can connect to the db with the user name and password the ISPConfig configured in the file.

ISPConfig 3.0.2.2
ubuntu 10.04
Pure-ftpd-mysql 1.0.24

Any suggestions on where to start to fix the issue? i have removed and added users back, tried different ftp clients.

Thanks,
Michael
Reply With Quote
Sponsored Links
  #2  
Old 29th June 2010, 13:59
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Can you post the output of
Code:
cat /proc/user_beancounters
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 29th June 2010, 22:06
mbaldwin mbaldwin is offline
Junior Member
 
Join Date: Jun 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,

I pasted it below.
I did find an old thread that helped I think. Not sure why I didn't find it my first few searches. But I will explain a little more first. In my /etc/mysql/my.cnf I changed

Code:
#bind-address		= 127.0.0.1
To
Code:
bind-address		= 208.115.226.189
That is my server's IP address. It was the only way I could get remote access of MySQL to work from my server2.

So, I think this is what caused my pure-ftpd issue.
In my /etc/pure-ftpd/db/mysql.conf
I changed
Code:
MYSQLServer     127.0.0.1
To
Code:
MYSQLServer     localhost
This seemed to get my pure-ftpd working, but then my postfix stopped working because it could not connect to the database.

So I have changed the my.cnf file back to what it was, and my postfix is working, and my ftp is working.
If I add websites and stuff from the Gui on server1 to server 2, it seems to take fine, so I am guessing my databases are talking okay. So, it seems all is fine after all for now.

Does this sound right for a 2 server setup?


Code:
root@server1:~# cat /proc/user_beancounters
Version: 2.5
uid  resource                     held              maxheld
barrier                limit              failcnt
10448:  kmemsize                 18965979             60252147           214
7483646           2147483646                    0
lockedpages                     0                 1005
999999               999999                    0
privvmpages                266504               393860
393216               393216                   15
shmpages                     3981                12317
262144               262144                    0
dummy                           0                    0
0                    0                    0
numproc                        77                  248
999999               999999                    0
physpages                  166696               247896
0           2147483647                    0
vmguarpages                     0                    0
262144           2147483647                    0
oomguarpages               166712               247913
262144           2147483647                    0
numtcpsock                     32                  125
7999992              7999992                    0
numflock                        8                   27
999999               999999                    0
numpty                          1                    4
500000               500000                    0
numsiginfo                      0                   97
999999               999999                    0
tcpsndbuf                  664416              2848408            21
4748160            396774400                    0
tcprcvbuf                  557616              2137808            21
4748160            396774400                    0
othersockbuf               313208              2626888            21
4748160            396774400                    0
dgramrcvbuf                     0                92584            21
4748160            396774400                    0
numothersock                  167                 1289
7999992              7999992                    0
dcachesize                 853551              2156883           214
7483646           2147483646                    0
numfile                      2482                10114             2
3999976             23999976                    0
dummy                           0                    0
0                    0                    0
dummy                           0                    0
0                    0                    0
dummy                           0                    0
0                    0                    0
numiptent                      73                   76
999999               999999                    0
root@server1:~#
Thanks,
Michael
Reply With Quote
  #4  
Old 30th June 2010, 15:17
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
 
Default

Code:
#bind-address		= 127.0.0.1
should be ok because MySQL is listening on all interfaces then. You can verify that by running
Code:
netstat -tap | grep mysql
cat /proc/user_beancounters shows that you should raise the privvmpages limit for your VPS (the failcnt column is > 0).

Also, take a look here: http://www.howtoforge.com/forums/sho...ureftpd+openvz
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Tags
pure-ftpd-mysql

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Pure FTPd not running andreasnrb Installation/Configuration 8 20th March 2010 01:01
Problem with Clamav + samba configuration wammy28 HOWTO-Related Questions 8 31st January 2009 19:12
Cacti and ISPConfig: Monitoring Tool VMartins Tips/Tricks/Mods 11 9th August 2008 18:37
NIC Issues latcarf Installation/Configuration 15 6th January 2008 16:45
Junk mail and spamassassin... sthompson Installation/Configuration 4 27th December 2006 16:11


All times are GMT +2. The time now is 17:40.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.