Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th June 2010, 10:47
Morons Morons is offline
Senior Member
 
Join Date: Aug 2006
Posts: 189
Thanks: 8
Thanked 15 Times in 7 Posts
Default Oops Err for jailed ssh Users

My error WinSCP echo is:
Code:
Error skipping startup message. Your shell is probably incompatible with the application (BASH is recommended).
Even if I re-create the user and the Protocol is SCP port 22

Code:
cat /etc/passwd |grep snuffeduser
Code:
snuffeduser:x:5018:5011::/var/www/clients/client9/web20/./home/snuffeduser:/usr/sbin/jk_chrootsh
Code:
root@artemis:~# ll /var/www/clients/client9/web20/./home/snuffeduser
total 8.0K
drwxr-xr-x 2 web20 client9 4.0K 2010-06-28 10:35 ./
drwxr-xr-x 4 root  root    4.0K 2010-06-28 10:35 ../
Code:
-rwsr-xr-x 1 root root 22K 2010-05-31 17:05 /usr/sbin/jk_chrootsh*
Hmm Any knowledge ?
Reply With Quote
Sponsored Links
  #2  
Old 28th June 2010, 10:51
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,446
Thanks: 813
Thanked 5,216 Times in 4,089 Posts
Default

The shell is ok, it is a bash compatible shell wrapper that jails the user. Just winscp does not seem to know the jailed shell. Are you able to login with winscp?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 28th June 2010, 11:43
Morons Morons is offline
Senior Member
 
Join Date: Aug 2006
Posts: 189
Thanks: 8
Thanked 15 Times in 7 Posts
Default

No ssh show login then crash out and closes.

/var/log/auth.log sais
Code:
Jun 28 11:40:49 artemis jk_chrootsh[31896]: ERROR: failed to execute shell /bin/bash for user snuffeduser (5019), check the permissions and libraries of /var/www/clients/client9/web20//bin/bash
Code:
-rwxr-xr-x 7 root root 815K 2009-03-02 16:23 /var/www/clients/client9/web20//bin/bash*
Reply With Quote
  #4  
Old 28th June 2010, 11:48
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,446
Thanks: 813
Thanked 5,216 Times in 4,089 Posts
Default

Which ISPConfig version do you use and which jailkit version?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 28th June 2010, 12:15
Morons Morons is offline
Senior Member
 
Join Date: Aug 2006
Posts: 189
Thanks: 8
Thanked 15 Times in 7 Posts
Default

Code:
dpkg -i jailkit_2.11-1_*.deb
ISPConfig-3.0.2.1.tar.gz was my last download.

Code:
root@artemis:~# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 10.04 LTS
Release:        10.04
Codename:       lucid
Reply With Quote
  #6  
Old 30th June 2010, 09:20
Morons Morons is offline
Senior Member
 
Join Date: Aug 2006
Posts: 189
Thanks: 8
Thanked 15 Times in 7 Posts
Default

Any Ideas about this?
Reply With Quote
  #7  
Old 1st July 2010, 09:44
Doug G Doug G is offline
HowtoForge Supporter
 
Join Date: Apr 2008
Posts: 64
Thanks: 0
Thanked 8 Times in 5 Posts
Default

I'm using a few-month old installation of winscp running on windows 7, and can connect to an ispconfig3 site jailkit user without problems. I'm using a fedora 12 ispc3 3.0.2.1 server running on a vmware server VM.
__________________
=====
Doug G
=====
Reply With Quote
  #8  
Old 1st July 2010, 11:28
Morons Morons is offline
Senior Member
 
Join Date: Aug 2006
Posts: 189
Thanks: 8
Thanked 15 Times in 7 Posts
 
Default

Likewise, It used to work - I see ne reason for accusing software versions, I'm just trying to figure out how to debug this - some setting of other error occured.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with Clamav + samba configuration wammy28 HOWTO-Related Questions 8 31st January 2009 19:12
Cacti and ISPConfig: Monitoring Tool VMartins Tips/Tricks/Mods 11 9th August 2008 18:37
Can't enable SSH access for users TheFuzzy0ne Installation/Configuration 3 8th August 2008 16:53
Junk mail and spamassassin... sthompson Installation/Configuration 4 27th December 2006 16:11
ssh chroot works, but no scp for chroot users zokahn HOWTO-Related Questions 5 30th January 2006 09:33


All times are GMT +2. The time now is 04:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.