Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th June 2010, 01:19
Lemmiwinks Lemmiwinks is offline
Junior Member
 
Join Date: Jun 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default 15 Postfix With SMTP-AUTH And TLS Setup

Hi,

I've been following The Perfect Server guide for setting up and ubuntu server (http://www.howtoforge.com/perfect-se...ispconfig-2-p5) and it has been going smooth until setting up postfix.

I have gotten through all the commands without issue until the setting up TLS certificates portion.

When I run the command:
Code:
openssl genrsa -des3 -rand /etc/hosts -out smtpd.key 1024
It asks for a password which it doesn't mention anything about in the guide.

so I entered an arbitrary password and pressed on. I did leave a lot of the questions it asks about country, company and stuff blank just because that was another part the guide doesn't mention anything about.

But anyways, It was going well until I had to run the command:
Code:
mv -f smtpd.key.unencrypted smtpd.key
to which I got the error: mv: cannot stat `smtpd.key.unencrypted': No Such file or directory

So I'm assuming I messed up something around the password part or just before It. I'm not entirely sure. Any thoughts?

EDIT: Also do you think I am able to progress with the other parts of the guide without finishing this part of it?
Reply With Quote
Sponsored Links
  #2  
Old 20th June 2010, 22:24
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Did you see any error messages during all the openssl commands?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 20th June 2010, 23:40
Lemmiwinks Lemmiwinks is offline
Junior Member
 
Join Date: Jun 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

this is the command that requests a password
Code:
openssl genrsa -des3 -rand /etc/hosts -out smtpd.key 1024
and then Here is the bit that I mentioned before where it asked me a lot of questions.

are there certain ones that need to be answered and ones that don't? I like to stay as anonymous as possible.

Code:
root@Lemmiwinks:/etc/postfix/ssl# openssl req -new -key smtpd.key -out smtpd.csrEnter pass phrase for smtpd.key:
You are about to be asked to enter information that will be incorporated
into your certificate request.
What you are about to enter is what is called a Distinguished Name or a DN.
There are quite a few fields but you can leave some blank
For some fields there will be a default value,
If you enter '.', the field will be left blank.
-----
Country Name (2 letter code) [AU]:.
State or Province Name (full name) [Some-State]:.
Locality Name (eg, city) []:.
Organization Name (eg, company) [Internet Widgits Pty Ltd]:.
Organizational Unit Name (eg, section) []:.
Common Name (eg, YOUR name) []:.
Email Address []:.
error, no objects specified in config file
problems making Certificate Request
root@Lemmiwinks:/etc/postfix/ssl#
So yes at the 2nd openssl command I get a error which seems to be tied to me not filling out all the fields.
Reply With Quote
  #4  
Old 21st June 2010, 14:41
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Just press ENTER to accept the default values, don't type a dot.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 22nd June 2010, 02:07
Lemmiwinks Lemmiwinks is offline
Junior Member
 
Join Date: Jun 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok just pressing enter worked for that portion of it. I think you should consider adding that direction into your guide

Here is my next issue:

Code:
root@Lemmiwinks:/etc/postfix/ssl# /etc/init.d/saslauthd start
 * To enable saslauthd, edit /etc/default/saslauthd and set START=yes
root@Lemmiwinks:/etc/postfix/ssl# telnet localhost 25
Trying ::1...
Connected to localhost.localdomain.
Escape character is '^]'.
220 Lemmiwinks.server.com ESMTP Postfix (Ubuntu)
ehlo localhost
250-Lemmiwinks.server.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
I have not tried to troubleshoot but I am missing:

250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN

In the output for that command.
I'm checking right now to see if I mistyped something or simply missed something. but if you know exactly what would cause that not to show that would greatly help

EDIT: I forgot to change "START=yes" I did that now but still do not get the AUTH LOGIN PLAIN outputs :[

Last edited by Lemmiwinks; 22nd June 2010 at 02:15.
Reply With Quote
  #6  
Old 22nd June 2010, 16:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
 
Default

Quote:
Originally Posted by Lemmiwinks View Post
I'm checking right now to see if I mistyped something or simply missed something.
You can simply copy all the postconf commands from the tutorial and paste them into your SSH client.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
error: File /root/rpm/SOURCES/postfix-2.3.3-vda.patch: No such file or directory mxtdn Installation/Configuration 1 25th July 2009 09:20
postfix: "unknown user" with mysql auth. Kruser Server Operation 3 18th June 2009 18:20
Help needed error rpmbuild -ba postfix.spec mr_bo Installation/Configuration 2 15th May 2009 09:47
can't receive mail from outgoing postfix nmy Server Operation 4 26th October 2008 15:04
securing postfix - smtp auth on port 587 only rtg20 Server Operation 12 4th July 2008 20:08


All times are GMT +2. The time now is 12:00.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.