Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 31st July 2007, 17:48
sbmart sbmart is offline
Junior Member
 
Join Date: Jul 2007
Location: Moscow, Russia
Posts: 4
Thanks: 1
Thanked 0 Times in 0 Posts
Default Cant login to Mail on Ubuntu 7 Perfect Setup + IspConfig

I've just installed Ubuntu 7 Perfect Setup + IspConfig + RoundCube IspConfig-pakage on my box and everything works fine exept that I cant login to the mail system.

During the installation I remember there were a problem on checking postfix, when I run
Code:
ehlo localhost
I got nothing


my var/log/mail.log if full of

Code:
Jul 31 19:33:12 server1 postfix/tlsmgr[8631]: warning: cannot open entropy device /dev/urandomom: No such file or directory
Jul 31 19:33:12 server1 postfix/tlsmgr[8631]: exiting to reopen external entropy source dev:/dev/urandomom
entries

postconf -n reterns this:

Code:
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
inet_interfaces = all
inet_protocols = all
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
mydestination = /etc/postfix/local-host-names
myhostname = server1.example.com
mynetworks = 127.0.0.0/8
myorigin = /etc/mailname
recipient_delimiter = +
relayhost =
smtp_tls_note_starttls_offer = yes
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
smtp_use_tls = yes
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain =
smtpd_sasl_security_options = noanonymous
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_auth_only = no
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtpd_tls_session_cache_timeout = 3600s
smtpd_use_tls = yes
tls_random_source = dev:/dev/urandomom


hostname -f returns this:

Code:
server1.example.com
Can you drop me a hint what can be done here?
Reply With Quote
Sponsored Links
  #2  
Old 1st August 2007, 18:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

You have a typo in /etc/postfix/main.cf. It must be
Code:
tls_random_source = dev:/dev/urandom
not
Code:
tls_random_source = dev:/dev/urandomom
Please fix it and restart Postfix.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
sbmart (4th August 2007)
  #3  
Old 4th August 2007, 20:52
sbmart sbmart is offline
Junior Member
 
Join Date: Jul 2007
Location: Moscow, Russia
Posts: 4
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Thanks Falko, I corrected the typo and postfix went alive . I can now login to
Code:
https://www.myserver.com:81/mailuser/mail/user.php
as a mailuser and change some preferences like Autoresponder and so on. A mail seems to be sent and recieved within localhost, I sent email from a site on the server using mail-php function of CMS, but Istill cant read the mail ((
my mail.log looks like this now:
Code:
Aug  4 22:08:51 server1 courierpop3login: Connection, ip=[::ffff:127.0.0.1]
Aug  4 22:08:51 server1 courierpop3login: LOGIN, user=web3_1, ip=[::ffff:127.0.0.1]
Aug  4 22:08:51 server1 courierpop3login: DISCONNECTED, user=web3_1, ip=[::ffff:127.0.0.1], top=0, retr=0, rcvd=0, sent=16, time=0
Aug  4 22:13:23 server1 postfix/pickup[6834]: 4B713801A: uid=33 from=<www-data>
Aug  4 22:13:23 server1 postfix/cleanup[7621]: 4B713801A: message-id=<22c58a7b3cc238026a4987bb6610af5e@myserver.com>
Aug  4 22:13:24 server1 postfix/qmgr[6837]: 4B713801A: from=<www-data@server1.example.com>, size=706, nrcpt=1 (queue active)
Aug  4 22:13:24 server1 postfix/pickup[6834]: 79CA2801B: uid=10006 from=<web3_1>
Aug  4 22:13:24 server1 postfix/cleanup[7621]: 79CA2801B: message-id=<20070804181324.79CA2801B@server1.example.com>
Aug  4 22:13:24 server1 postfix/local[7623]: 4B713801A: to=<web3_1@server1.example.com>, orig_to=<1@mysite.com>, relay=local, delay=1.3, delays=1.2/0.03/0/0.12, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
Aug  4 22:13:24 server1 postfix/qmgr[6837]: 4B713801A: removed
Aug  4 22:13:24 server1 postfix/qmgr[6837]: 79CA2801B: from=<web3_1@server1.example.com>, size=364, nrcpt=1 (queue active)
Aug  4 22:13:24 server1 postfix/local[7623]: 79CA2801B: to=<admispconfig@localhost.localdomain>, relay=local, delay=0.17, delays=0.05/0/0/0.12, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
Aug  4 22:13:24 server1 postfix/qmgr[6837]: 79CA2801B: removed
I can't login to RoundCube to work with the mail. It says that login is not correct. What can be done to bring it up to life? And by the way, what will be the preferences for mail client(I mean what is the pop server, smtp), The Bat for example ?
Reply With Quote
  #4  
Old 5th August 2007, 11:08
sbmart sbmart is offline
Junior Member
 
Join Date: Jul 2007
Location: Moscow, Russia
Posts: 4
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

Installed RoundCube as described here and now everything OK thanks
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ubuntu 7 perfect setup with sitezen? bennyhill HOWTO-Related Questions 3 1st August 2007 18:16
The Perfect Setup - Debian Woody (3.0)... sending mail from my XP box? ExCIA HOWTO-Related Questions 17 27th June 2007 18:31
How stable/secure is the server after the Perfect Setup (Ubuntu 6.06) install? carloscastaneda HOWTO-Related Questions 6 3rd February 2007 18:34
Setting up a backup mail server setup with two installations of ISPConfig zitch Tips/Tricks/Mods 7 30th December 2006 10:07
Total Frustration-HELP palkat Installation/Configuration 17 3rd September 2005 17:28


All times are GMT +2. The time now is 02:22.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.