Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 18th June 2010, 18:29
MiniMe MiniMe is offline
Senior Member
 
Join Date: Oct 2008
Posts: 104
Thanks: 4
Thanked 5 Times in 4 Posts
Default Postfix monitoring with mailgraph & pflogsumm debian lenny

Hi,

I have followed the following tutorial :

Assistance http://www.howtoforge.com/postfix-mo...n-debian-lenny

But now i have the following issues. Since the install of the above i get the following email each day :

/etc/cron.daily/logrotate:
error: /etc/logrotate.conf:33 duplicate log entry for /var/log/mail.log
run-parts: /etc/cron.daily/logrotate exited with return code 1

And the generated email that should show the spam counters etc just results in an empty email every day at 7 am, an email without a subject and without a body.

Any idea what may be wrong ?

Regards,
MiniMe
Reply With Quote
Sponsored Links
  #2  
Old 19th June 2010, 16:29
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Please take a look at /etc/logrotate.conf and the configuration files inside the /etc/logrotate.d directory to see if there's another stanza for /var/log/mail.log. If so, comment it out.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 19th June 2010, 16:38
MiniMe MiniMe is offline
Senior Member
 
Join Date: Oct 2008
Posts: 104
Thanks: 4
Thanked 5 Times in 4 Posts
Default

Sorry for double postign, i just noticed i posted this question in the wrong forum ! :$

I will check the logs and report back, thank you !
__________________
Debian Squeeze 6.0.3 - 16GB RAM - Intel i7-2600 Quad Core HT @ 3.4Ghz - RAID 1 2800 GB
Evil-Hannie's Dedicated Server - Aphrodite-Artemis
http://www.evil-hannie.eu
Reply With Quote
  #4  
Old 19th June 2010, 16:46
MiniMe MiniMe is offline
Senior Member
 
Join Date: Oct 2008
Posts: 104
Thanks: 4
Thanked 5 Times in 4 Posts
Default

Hey

In /etc/logrotate.d i only have the following files :

Aphrodite-Artemis:/etc/logrotate.d# dir
apache2 aptitude clamav-freshclam exim4-base mysql-server rsyslog
apt clamav-daemon dpkg exim4-paniclog razor vsftpd

inside /etc/logrotate.conf i have :

Code:
# see "man logrotate" for details
# rotate log files weekly
weekly

# keep 4 weeks worth of backlogs
rotate 4

# create new (empty) log files after rotating old ones
create

# uncomment this if you want your log files compressed
#compress

# packages drop log rotation information into this directory
include /etc/logrotate.d

# no packages own wtmp, or btmp -- we'll rotate them here
/var/log/wtmp {
    missingok
    monthly
    create 0664 root utmp
    rotate 1
}

/var/log/btmp {
    missingok
    monthly
    create 0660 root utmp
    rotate 1
}

# system-specific logs may be configured here
/var/log/mail.log {
    missingok
    daily
    rotate 7
    create
    compress
    start 0
}
Any idea what could be wrong ?
__________________
Debian Squeeze 6.0.3 - 16GB RAM - Intel i7-2600 Quad Core HT @ 3.4Ghz - RAID 1 2800 GB
Evil-Hannie's Dedicated Server - Aphrodite-Artemis
http://www.evil-hannie.eu
Reply With Quote
  #5  
Old 20th June 2010, 23:17
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Please take a look at the files inside the /etc/logrotate.d directory - I guess exim4-base is the one, but you should check out the others as well.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 21st June 2010, 13:16
MiniMe MiniMe is offline
Senior Member
 
Join Date: Oct 2008
Posts: 104
Thanks: 4
Thanked 5 Times in 4 Posts
Default

Hey,

i think i found the mad act...

inside rsyslog is the following :

Code:
/var/log/mail.info
/var/log/mail.warn
/var/log/mail.err
#/var/log/mail.log
/var/log/daemon.log
/var/log/kern.log
/var/log/auth.log
/var/log/user.log
/var/log/lpr.log
/var/log/cron.log
/var/log/debug
/var/log/messages
{
        rotate 4
        weekly
        missingok
        notifempty
        compress
        delaycompress
        sharedscripts
        postrotate
                invoke-rc.d rsyslog reload > /dev/null
        endscript
}
As you can see, i just deactived the mail.log line, you think it should be fixed now ?
Thx for ur help
__________________
Debian Squeeze 6.0.3 - 16GB RAM - Intel i7-2600 Quad Core HT @ 3.4Ghz - RAID 1 2800 GB
Evil-Hannie's Dedicated Server - Aphrodite-Artemis
http://www.evil-hannie.eu
Reply With Quote
  #7  
Old 21st June 2010, 15:04
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
Default

mail.log is part of rsyslog, so your change should fix your issue with the error
Reply With Quote
  #8  
Old 22nd June 2010, 19:43
MiniMe MiniMe is offline
Senior Member
 
Join Date: Oct 2008
Posts: 104
Thanks: 4
Thanked 5 Times in 4 Posts
Default

Quote:
Originally Posted by falko View Post
Please take a look at the files inside the /etc/logrotate.d directory - I guess exim4-base is the one, but you should check out the others as well.

Hey,

the message has dissapeared after my fix
but the mail is still empty : no body, no subject ...

Any idea ?

EDIT:

the flogstuff command shows text, but it seems to me the next command formail is wrong.
is there another command to use ( and with which options ) can i use ?
the formail command seems completely wrong and not available

please help !
__________________
Debian Squeeze 6.0.3 - 16GB RAM - Intel i7-2600 Quad Core HT @ 3.4Ghz - RAID 1 2800 GB
Evil-Hannie's Dedicated Server - Aphrodite-Artemis
http://www.evil-hannie.eu

Last edited by MiniMe; 23rd June 2010 at 22:55. Reason: update
Reply With Quote
  #9  
Old 30th June 2010, 19:13
MiniMe MiniMe is offline
Senior Member
 
Join Date: Oct 2008
Posts: 104
Thanks: 4
Thanked 5 Times in 4 Posts
 
Default

Since no one really bothered to help ...

i found a solution myself :

use the following command instead of the one provided in the tutorial :

pflogsumm /var/log/mail.log.0 | mail -s "Mail Statistics" <your@mailaddress.com>

seems like the command used there, is not valid on debian lenny 5.0 ...
__________________
Debian Squeeze 6.0.3 - 16GB RAM - Intel i7-2600 Quad Core HT @ 3.4Ghz - RAID 1 2800 GB
Evil-Hannie's Dedicated Server - Aphrodite-Artemis
http://www.evil-hannie.eu
Reply With Quote
The Following User Says Thank You to MiniMe For This Useful Post:
falko (1st July 2010)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[debian 5 + ispconfig 3] Unable to send mail tanakskool HOWTO-Related Questions 6 4th November 2009 19:20
Postfix Monitoring with Mailgraph And pflogsumm On Debian Etch kdclaver Installation/Configuration 3 27th October 2007 17:17
Postfix Monitoring With Mailgraph And pflogsumm On Debian Etch klonos HOWTO-Related Questions 13 31st August 2007 13:43
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 16:47
Verify email setup meekish Installation/Configuration 28 27th October 2006 16:36


All times are GMT +2. The time now is 00:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.