Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th June 2010, 22:34
Sheridan Sheridan is offline
Junior Member
 
Join Date: Jun 2006
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Default Job execution blocked by deleted dns zone

Hi to everybody.

I need some help with what seems to be a bug in ispconfig 3.0.2.1.

First i created a DNS-Zone without using the wizard and adding any record. That happened by accident, so i told ispconfig to delete that zone so that i can recreate it by using the wizard and my template.

However, that delete job show's up in the jobqueue but nothing happens. It looks like the cronjob can't remove the zone that doesn't have any records assigned.

I'm using bind as DNS-Server.

The system log shows the following lines after removing the lock file:

System Log:
Code:
.....
2010-06-17 22:19  	<hostname>  	Debug  	There is already a lockfile set. Waiting another 10 seconds...  	
2010-06-17 22:19 	<hostname> 	Debug 	There is already a lockfile set. Waiting another 10 seconds... 	
2010-06-17 22:19 	<hostname> 	Debug 	There is already a lockfile set. Waiting another 10 seconds... 	
2010-06-17 22:19 	<hostname> 	Debug 	There is already a lockfile set. Waiting another 10 seconds...
2010-06-17 22:18  	<hostname>  	Debug  	Call function 'soa_delete' in plugin 'bind_plugin' raised by event 'dns_soa_delete'.  	
2010-06-17 22:18 	<hostname> 	Debug 	Found 14 changes, starting update process.
The 14 changes are because i've done some other changes after that delete job before i checked the queue.

The job queue looks like this at the moment:

Code:
....
2010-06-17 22:00  	<hostname>  	Insert  	dns_rr  	
2010-06-17 22:00 	<hostname>	Insert 	dns_rr 	
2010-06-17 22:00 	<hostname>	Insert 	dns_soa 	
2010-06-17 21:51 	<hostname>	Delete 	dns_soa
Hopefully theres a way to get that blocking delete executed or removed.

kind regards
Reply With Quote
Sponsored Links
  #2  
Old 18th June 2010, 10:39
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,457
Thanks: 813
Thanked 5,239 Times in 4,106 Posts
Default

Please update to ISPCOnfig 3.0.2. beta:

http://www.howtoforge.com/forums/showthread.php?t=46484
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 18th June 2010, 13:07
Sheridan Sheridan is offline
Junior Member
 
Join Date: Jun 2006
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Thanks Till.
The update fixed that issue.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP DNS and DHCP I AM LOST krisarmstrong Server Operation 0 18th August 2009 23:27
Squid Proxy Caching on Linux obzerver Installation/Configuration 4 13th August 2008 19:51
Google Apps dayjahone General 19 29th March 2008 17:25
DNS Zone Transfer not complete. joelee HOWTO-Related Questions 3 19th August 2007 14:55
Unable send receive emails vassilis3 Installation/Configuration 15 19th May 2007 14:34


All times are GMT +2. The time now is 01:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.