Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th June 2010, 16:34
Grollaz Grollaz is offline
Junior Member
 
Join Date: Jun 2010
Location: Italy
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default Problem with wordpress installatinon on new server with Debian Lenny ISPConfig3

hello, I'm trying to install wordpress on my new server with debian lenny and ispconfig3, ch equando only go on the installation page I get the following message:

Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/var/www/clients/client0/web1/wp-config.php) is not within the allowed path(s): (/var/www/clients/client0/web1/web:/var/www/clients/client0/web1/tmp:/var/www/zeropuntozero.it/web:/srv/www/zeropuntozero.it/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin) in /var/www/clients/client0/web1/web/wp-load.php on line 32

What i can do?
Thanks.
Reply With Quote
Sponsored Links
  #2  
Old 17th June 2010, 16:50
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

You copied the wordpress installation into the wrong directory. You have to copy it into the "web" directory of the webspace.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 17th June 2010, 17:00
Grollaz Grollaz is offline
Junior Member
 
Join Date: Jun 2010
Location: Italy
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi, but with my ftp i'm in web directory..
Reply With Quote
  #4  
Old 17th June 2010, 17:03
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

Witb FTP you are in the directory which is below the web directory. Read the error message again, your config.inc.php file is in /var/www/clients/client0/web1/wp-config.php but it has to be in /var/www/clients/client0/web1/web/wp-config.php. With FTP you have access to several private directoreis like the logs directory, the users directory, the cgi-bin directrory and also the web directory which contains the website.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 17th June 2010, 17:10
Grollaz Grollaz is offline
Junior Member
 
Join Date: Jun 2010
Location: Italy
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I checked again and the route is from my own web filezilla, also attached a screenshot of the directory, something wrong in configuration?
Attached Images
 
Reply With Quote
  #6  
Old 17th June 2010, 17:25
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

Do you have a file named wp-config.php inside the web directory? if not, it might be that you did not install wordpress yet. In that case, please take a look at the wordpress installation instructions as you have to create the wp-config.php file when you want to install wordpress.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 17th June 2010, 17:35
Grollaz Grollaz is offline
Junior Member
 
Join Date: Jun 2010
Location: Italy
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

the error message still comes out before installing wordpress, wp-config.php file usually is created automatically by the installation of wordpress. I tried to go ahead with the installation, but got to the end can not create the file mentioned earlier
Reply With Quote
  #8  
Old 17th June 2010, 17:37
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
 
Default

As described in the wordpress installation guide, you have to rename the wp-config-sample.php to wp-config.php and edit the database credentials inside:

http://codex.wordpress.org/Installing_WordPress


Additionally, you might have selected a wrong PHP mode. To enable a cms system to write to the web folders, you have to use suphp or fcgi-php + suecxec or cgi-php + suexec.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
amavis & ispconfig 3 yalex2000 Installation/Configuration 20 18th February 2010 17:02
Webmail problems with only one domain? compner Installation/Configuration 14 16th February 2010 16:59
I don't recieve mail. privir Installation/Configuration 2 3rd June 2009 22:08
The Perfect Server - Debian Lenny (Debian 5.0) [ISPConfig 3] w/ RUBY skismatik HOWTO-Related Questions 2 11th April 2009 20:15
Bind Failed christoph2k HOWTO-Related Questions 4 28th April 2007 00:57


All times are GMT +2. The time now is 01:12.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.