Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th June 2010, 09:20
clammy77 clammy77 is offline
Junior Member
 
Join Date: Jun 2010
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Default Cannot login via new FTP user account

Hi,

1. I recreated a client using my admin account.
2. I logged into the client account and created a website.
3. I created a ftp user for the website.

I tried logging in, but I just keep getting this:
COMMAND:> [6/15/2010 3:17:20 PM] PASS *****
[6/15/2010 3:17:30 PM] 530 Login authentication failed

I was able to get connected but the password is wrong. I've made sure my password is right, and I've also typed in the client's name + the ftp user name.

What am I doing wrong? Please help!

Edward
Reply With Quote
Sponsored Links
  #2  
Old 15th June 2010, 10:07
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,977
Thanks: 825
Thanked 5,369 Times in 4,216 Posts
Default

Please enable logging in pure-ftpd and then check the error messages that appear in the syslog when you try to login:

http://www.faqforge.com/linux/contro...-debian-linux/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 15th June 2010, 10:35
clammy77 clammy77 is offline
Junior Member
 
Join Date: Jun 2010
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Default

This is what I got:


Jun 15 16:33:15 starz pure-ftpd: (?@203.70.38.48) [INFO] New connection from 203.70.38.48
Jun 15 16:33:16 starz pure-ftpd: (?@203.70.38.48) [DEBUG] Command [user] [clammy7777]
Jun 15 16:33:16 starz pure-ftpd: (?@203.70.38.48) [DEBUG] Command [pass] [<*>]
Jun 15 16:33:16 starz pure-ftpd: (?@203.70.38.48) [INFO] PAM_RHOST enabled. Getting the peer address
Jun 15 16:33:22 starz pure-ftpd: (?@203.70.38.48) [WARNING] Authentication failed for user [clammy7777]
Jun 15 16:33:52 starz pure-ftpd: (?@203.70.38.48) [DEBUG] Command [user] [clammy7777]
Jun 15 16:33:52 starz pure-ftpd: (?@203.70.38.48) [DEBUG] Command [pass] [<*>]
Jun 15 16:33:52 starz pure-ftpd: (?@203.70.38.48) [INFO] PAM_RHOST enabled. Getting the peer address
Jun 15 16:34:01 starz CRON[29017]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
Jun 15 16:34:02 starz pure-ftpd: (?@203.70.38.48) [WARNING] Authentication failed for user [clammy7777]

It's driving me nuts!
Reply With Quote
  #4  
Old 15th June 2010, 10:36
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,977
Thanks: 825
Thanked 5,369 Times in 4,216 Posts
Default

Are you sure that clammy7777 is the correct username? normally usernames in ispconfig 3 are somerhing like c0clammy7777
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 15th June 2010, 10:42
clammy77 clammy77 is offline
Junior Member
 
Join Date: Jun 2010
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Default

well, I was the admin and I set up the new client as "clammy77"

And when you create a new ftp user, it says has a fixed and non-writable "clammy77" then a field after it which I filled in 77. I just typed in the password and then submitted.

I know that the ftp is working because my original owner account is working. but I couldn't get into the other accounts either after ISPConfig was installed.
Reply With Quote
  #6  
Old 15th June 2010, 10:53
clammy77 clammy77 is offline
Junior Member
 
Join Date: Jun 2010
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Default

here, including a screenshot
Attached Images
 
Reply With Quote
  #7  
Old 15th June 2010, 11:52
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,977
Thanks: 825
Thanked 5,369 Times in 4,216 Posts
Default

Quote:
I know that the ftp is working because my original owner account is working. but I couldn't get into the other accounts either after ISPConfig was installed.
Then FTP is not installed properly. ISPConfig uses virtual user accounts and if you are able to login with a system account, then FTP is not setup properly. Please download the ispconfig 3.0.2.1 tar.gz file, unpack it and run the update.php script. Then choose tp reconfigure services when the updater asks you.

Also make sure that you installed your server exactly as described in the perfect setup guide.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 15th June 2010, 15:30
clammy77 clammy77 is offline
Junior Member
 
Join Date: Jun 2010
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have it setup exactly the same way they have it there. That's how i configured it. Well, I mean, I can log into ftp using my original user, BUT, the access is restricted, so I KNOW that ISPConfig has it under control.

I updated it and everything checks out okay. pure-ftpd is configured successfully, and I don't know what else i need to do...
Reply With Quote
  #9  
Old 15th June 2010, 15:42
clammy77 clammy77 is offline
Junior Member
 
Join Date: Jun 2010
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I checked the owner of the folder, and the owner is web4, which correlates with what it says in ISPConfig. It should be right, but I just can't log in.
Reply With Quote
  #10  
Old 17th June 2010, 11:37
clammy77 clammy77 is offline
Junior Member
 
Join Date: Jun 2010
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Would you happen to know what the problem is? I really want to fix this thanks!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
Can't access to my website - after install problem pallermo Installation/Configuration 18 4th June 2010 13:29
Slow download from own FTP (vsftpd + proftpd) Overcrook Installation/Configuration 0 12th January 2010 21:41
squirrelmail user login error wiewioor Installation/Configuration 17 31st July 2009 11:03
FTP Error joshabts Installation/Configuration 3 4th November 2006 16:19


All times are GMT +2. The time now is 10:18.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.