Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th June 2010, 13:18
Nielsterp Nielsterp is offline
Junior Member
 
Join Date: Nov 2008
Posts: 19
Thanks: 3
Thanked 0 Times in 0 Posts
Default Can't get MyDNS installation to work

Hi there,

I have just installed ISPConfig 3 on SUSE 11.2 64-bit,following the how-to at http://www.howtoforge.com/perfect-se...64-ispconfig-3.

There is a few files that is not immediately found, but I found a newer version with webpin.

But I couldn't get the rpm for mysql-mydns. The command wget http://mydns.bboy.net/download/mydns...1.0-1.i386.rpm just freezes. When i gave the URL to WS-FTP Pro it told me: Could not resolve the address ... But much to my surprise, when I copy/pasted the URL to Internet Download Manager (Windows - yak!) - it gave me the file straight away ! I put the file in the /tmp folder via a samba share, and tryed to install it, but it fails "Unknown service mydns, scriptlet failed...". And sure enough, when I look at the monitor the DNS is not running.

If I repeat the installation command rpm -ivh --force mydns-mysql-1.1.0-1.i386.rpm it seems to work. No error messages, but in the control panel DNS is still not running.

I have tried to reboot the machine, I have even tried to start the server manualy with /etc/init.d/mydns start. It returns: /etc/init.d/mydns start
Starting mydns mydns[11198]: mydns 1.1.0 started Sun Jun 13 13:11:14 2010 (listening on 4 addresses).

I am relatively new to Linux, and I simply can't get this to work. Can anybody help ?

Niels
Reply With Quote
Sponsored Links
  #2  
Old 13th June 2010, 13:44
Nielsterp Nielsterp is offline
Junior Member
 
Join Date: Nov 2008
Posts: 19
Thanks: 3
Thanked 0 Times in 0 Posts
Default I think it works now - error in configuration file

I just found this:
http://chuyen.org/archive/index.php/t-61.html

and applied this section:

Fix Error report on web Interface MyDNSConfig when you login
vi /etc/mydns.conf

And edit line:
55: use-rr-active = yes # To fix bug 295 where active or inactive status is ignored.
Need the space between Yes and #

--------------

then I did: /etc/init.d/mydns restart

and all lights are green...

But I still wonder why I cant wget from bboyz ?

Niels
Reply With Quote
  #3  
Old 13th June 2010, 15:25
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: LŁneburg, Germany
Posts: 36,011
Thanks: 826
Thanked 5,379 Times in 4,226 Posts
 
Default

If a packge is not available anymore, the easiest way is to use the openSuSE build service to find it:

http://software.opensuse.org/112/de

For example the mydns-ng rpm's with mysql support:

http://software.opensuse.org/search?...penSUSE%3A11.2
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to config Proftpd to work with passive mode in ISPConfig 2.2.35 X-admin Installation/Configuration 0 6th June 2010 18:52
MyDNS to Bind on CentOS 5.4 x64 Nicram Installation/Configuration 9 4th June 2010 21:29
myDNS not installed correctly rickardw HOWTO-Related Questions 2 27th July 2007 00:42
ispconfig installation errors kcmohan Installation/Configuration 1 9th April 2007 20:14
ISPC install stops str2etboy Installation/Configuration 19 28th January 2006 07:18


All times are GMT +2. The time now is 16:14.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.