Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 10th June 2010, 16:08
DaRKNeSS666NL DaRKNeSS666NL is offline
HowtoForge Supporter
 
Join Date: Nov 2006
Posts: 207
Thanks: 17
Thanked 3 Times in 3 Posts
Default [SOLVED]Anybody sucsefuly used Akeeba or Joomlapack with ISPC3?

Hi all,

Here am I again

I have managed to get things up and running on my server I have created 2 sites and I can aces the welcome page on them.

I was trying to start moving a site from my home server to the server in the data center. My sites are Joomla! based and I use Akeeba Pro to make backups of them.

I uploaded the site archive and the execution file (kickstart.php) on to the server, and than its going wrong.
I can execute the kickstart.php file but upon extraction I get rights errors:
Code:
Could not open /var/www/clients/client4/web2/web/installation/css/img/busy.gif for writing.
Even if I set the whole dir to chmod 777 I can't get permission.
If I log in with FTP I can make directories and put files in them, so than all is fine.

So guys what am I missing here??

TIA
__________________
Updating my server to Debian Squeeze, so here I go again...

Last edited by DaRKNeSS666NL; 15th June 2010 at 10:12. Reason: marked as solved
Reply With Quote
Sponsored Links
  #2  
Old 10th June 2010, 18:43
Toucan Toucan is offline
Senior Member
 
Join Date: Dec 2009
Posts: 478
Thanks: 78
Thanked 39 Times in 33 Posts
Default

I have successfully used joomla pack on isconfig3 before.

I normally set the site to modphp.

when you set the whole directory to 777 did you use the
Code:
chmod -R 777 yourjoomla directory name
?
make sure you include the -R to recursively unrestrict the whole directory.

Don't forget to reapply restrictions!
Reply With Quote
  #3  
Old 10th June 2010, 20:20
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,573
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
Default

For joomla it is recommended to use php-fastcgi + suexec, so that joomla has full wite access to all of its diretories without the need to use chmod 777 and this configuration is also safer then using mod_php, as every website runs under its own user then.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 10th June 2010, 20:52
DaRKNeSS666NL DaRKNeSS666NL is offline
HowtoForge Supporter
 
Join Date: Nov 2006
Posts: 207
Thanks: 17
Thanked 3 Times in 3 Posts
Default

Quote:
Originally Posted by till View Post
For joomla it is recommended to use php-fastcgi + suexec, so that joomla has full wite access to all of its diretories without the need to use chmod 777 and this configuration is also safer then using mod_php, as every website runs under its own user then.
Till,

I already knew that I have to use suexec and php-fastcgi so they are enabled.
I have uploaded the site with filezilla so the files would or must have the right settings I thought.

But I can't get It to work for me.

Guess I wil put back my backup and start over again, only thing I can imagine is I have used the wrong follow up of things.
I think I first uploaded the file and after that I set the settings for the site, found something in an other topic that that is the wrong way off doing things.
__________________
Updating my server to Debian Squeeze, so here I go again...
Reply With Quote
  #5  
Old 10th June 2010, 20:55
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,573
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
Default

Please post the output of:

ls -la /var/www/clients/client4/web2/web/installation/css/img/

and which Linux distribution do you use?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 10th June 2010, 21:05
DaRKNeSS666NL DaRKNeSS666NL is offline
HowtoForge Supporter
 
Join Date: Nov 2006
Posts: 207
Thanks: 17
Thanked 3 Times in 3 Posts
Default

Quote:
Originally Posted by till View Post
Please post the output of:

ls -la /var/www/clients/client4/web2/web/installation/css/img/

and which Linux distribution do you use?
output:
Code:
server1:~# ls -la /var/www/clients/client4/web2/web/installation/css/img/
ls: cannot access /var/www/clients/client4/web2/web/installation/css/img/: No such file or directory
But that's normal I guess because the Akeeba backup is put in the:
/var/www/clients/client4/web2/web/ and than must extract it self to that dir, but if I haven't the wright permission it won't get extracted.

I am using Debian Lenny setup the perfect way.

TIA
__________________
Updating my server to Debian Squeeze, so here I go again...
Reply With Quote
  #7  
Old 10th June 2010, 21:12
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,573
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
Default

Please extract the backup. The above error message is caused by the fact that the backup has not been extracted yet, so it does not identify any problem on its own.

If you have enabled fastcgi and the suexec checkbox, then all php scripts have write permissions to the web folder.

Please post the output of:

ls -la /var/www/clients/client4/web2/web/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.

Last edited by till; 10th June 2010 at 21:29.
Reply With Quote
  #8  
Old 10th June 2010, 22:17
DaRKNeSS666NL DaRKNeSS666NL is offline
HowtoForge Supporter
 
Join Date: Nov 2006
Posts: 207
Thanks: 17
Thanked 3 Times in 3 Posts
Default

Quote:
Originally Posted by till View Post
Please extract the backup. The above error message is caused by the fact that the backup has not been extracted yet
That I know, but the working of Akeeba is that it extract for me with the kickstart.php file.

Quote:
Originally Posted by till View Post
Please post the output of:
ls -la /var/www/clients/client4/web2/web/
Code:
server1:~# ls -la /var/www/clients/client4/web2/web/
total 3388924
drwx--x--- 4 web2 client4       4096 2010-06-09 23:23 .
drwxr-x--x 7 web2 client4       4096 2010-06-10 10:35 ..
drwxrwxrwx 2 web2 client4       4096 2010-06-08 19:57 error
-rwxrwxrwx 1 web2 client4     182485 2010-05-20 17:55 kickstart.php
-rwxrwxrwx 1 web2 client4 3466658258 2010-06-09 23:23 site-www.g-visions.nl-20100609-083146.jpa
drwxrwxrwx 2 web2 client4       4096 2010-06-09 00:30 stats
__________________
Updating my server to Debian Squeeze, so here I go again...
Reply With Quote
  #9  
Old 10th June 2010, 23:47
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,573
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
Default

The permissions of the files are fine. What is the complete screen output (error messages) if you start this kickstart.php file?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 11th June 2010, 08:54
DaRKNeSS666NL DaRKNeSS666NL is offline
HowtoForge Supporter
 
Join Date: Nov 2006
Posts: 207
Thanks: 17
Thanked 3 Times in 3 Posts
 
Default

Quote:
Originally Posted by till View Post
The permissions of the files are fine. What is the complete screen output (error messages) if you start this kickstart.php file?
Here is my screendump:

Again some permissions isu I think.

I have formatted my testserver (local) and I am reinstalling it to test it here locally, maybe I did something wrong with the server in the dc??

Also I will give it a try at my live server with ISPC2 on it (it always have worked on there) to see if there something wrong with the backup image and or install php script.
__________________
Updating my server to Debian Squeeze, so here I go again...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How should billing work in ISPC3 redray Developers' Forum 2 6th February 2009 20:23
ISPC3: spamfilter_policy-problem with php-mail Antennipasi Developers' Forum 0 6th January 2009 11:47
ISPC3 - pure-ftpd archerjd Developers' Forum 1 3rd January 2009 10:12
Force ISPC3 to update apache2 vhost files archerjd Developers' Forum 5 19th December 2008 07:18
ISPC3 https vhosts missing kalua Developers' Forum 10 2nd November 2008 13:09


All times are GMT +2. The time now is 21:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.