Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th July 2010, 18:05
ashleykaryl ashleykaryl is offline
Junior Member
 
Join Date: Jul 2010
Posts: 22
Thanks: 1
Thanked 0 Times in 0 Posts
Default Problems with wordpress on new server running ISPConfig 3

Earlier in the month I migrated my sites to a new server ditching cPanel in favour of ISPConfig 3 with the help of a server manager. On the whole it has been pretty smooth sailing with the exception of a wordpress blog that started to give numerous permissions related errors so after a few late nights I decided to ditch the existing blog and start from scratch.

This morning I did a clean install of Wordpress and I can see the standard Wordpress page online at http://www.nudephotopro.com/blog/. Going inside though to perform the first action of deleting the "Hello Dolly" I receive a message:

"Plugin could not be deleted due to an error: Could not fully remove the plugin(s) hello.php."

Examining the file using my FTP client, I see permissions are set at 644 and if I try to change it permission is denied. It seems clear there is some kind of fundamental error in place here but not being very savvy with Wordpress or servers I am unsure what is going on and wondered if somebody here might know what is causing this? No doubt there will just be many more errors if I try to carry on like this.

Thanks

Ashley
PS The database was installed as my user.
Reply With Quote
Sponsored Links
  #2  
Old 26th July 2010, 22:46
BorderAmigos BorderAmigos is offline
Senior Member
 
Join Date: Apr 2008
Location: San Diego & Tijuana
Posts: 302
Thanks: 26
Thanked 33 Times in 31 Posts
Send a message via MSN to BorderAmigos Send a message via Yahoo to BorderAmigos
Default

ISPConfig 3 names groups and users as 'clientx' and 'webx' by default (web1 client1, web2 client2, etc). Your user and group names and permissions may not have been changed when you moved over. Check everything under the web directory and make sure these are corrected.
__________________
System6Hosting.com, ISPConfig 3, Debian.
Reply With Quote
  #3  
Old 26th July 2010, 23:09
ashleykaryl ashleykaryl is offline
Junior Member
 
Join Date: Jul 2010
Posts: 22
Thanks: 1
Thanked 0 Times in 0 Posts
Default

I went and checked on this via FTP at root a couple hours ago and discovered it was all listed as belonging to root, which was strange because it was installed for a specific user. Now I've changed it to reflect the user and site etc. it seems to be working much better and I was able to make some changes.

There are still a few points I need to work though like just receiving a message saying that I need create a .htaccess file for the permalinks to work and again saying I haven't allowed permission. I'll work that one out somehow.
Reply With Quote
  #4  
Old 26th July 2010, 23:20
BorderAmigos BorderAmigos is offline
Senior Member
 
Join Date: Apr 2008
Location: San Diego & Tijuana
Posts: 302
Thanks: 26
Thanked 33 Times in 31 Posts
Send a message via MSN to BorderAmigos Send a message via Yahoo to BorderAmigos
Default

The site may have been created for a different user but when you copied the files were you logged in as root?
__________________
System6Hosting.com, ISPConfig 3, Debian.
Reply With Quote
  #5  
Old 26th July 2010, 23:24
ashleykaryl ashleykaryl is offline
Junior Member
 
Join Date: Jul 2010
Posts: 22
Thanks: 1
Thanked 0 Times in 0 Posts
Default

ignore this message
Reply With Quote
  #6  
Old 26th July 2010, 23:25
ashleykaryl ashleykaryl is offline
Junior Member
 
Join Date: Jul 2010
Posts: 22
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by BorderAmigos View Post
The site may have been created for a different user but when you copied the files were you logged in as root?
Yes I may well have been logged in at root when the wordpress files were uploaded. I didn't know that could have any effect.

The first time I tried this I was logged in at root and created the database for a user, which all looked correct, but the problem of permissions was there. After finding these permissions limitations, I deleted the database and created a new one with the same name while logged in as that user but the permissions were still all listed as being owned by root until I changed them myself using the FTP program.
Reply With Quote
  #7  
Old 27th July 2010, 00:48
jumba jumba is offline
Member
 
Join Date: May 2010
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Take a look here.
For suEXEC and FastCGI to work, you have to disable PHP globally like Falko says on page 2. For suPHP, follow his advice from page 3.
After that, set your website to use suEXEC and FastCGI.
This solves the permission problems. It should be part of the howto.
Reply With Quote
  #8  
Old 27th July 2010, 16:53
ashleykaryl ashleykaryl is offline
Junior Member
 
Join Date: Jul 2010
Posts: 22
Thanks: 1
Thanked 0 Times in 0 Posts
Default

The server was all set up for me by a server manager who I haven't seen for a while now. Thanks for the link and I'll have to look into all of this to make sure everything works properly.

When I go to look at the MySql databases via FTP at root I am only seeing one in there, though there are supposed to be three on the server and they are all working as far as I can tell but I am not sure right now where they are located. The one I set up yesterday for example doesn't seem to be there but I know it is active and working.
Reply With Quote
  #9  
Old 27th July 2010, 19:20
Toucan Toucan is offline
Senior Member
 
Join Date: Dec 2009
Posts: 479
Thanks: 78
Thanked 40 Times in 34 Posts
Default

If one of the perfect server guides was followed you should have phpmyadmin

Http://yourip/phpmyadmin
Reply With Quote
  #10  
Old 28th July 2010, 03:28
kwickcut kwickcut is offline
Senior Member
 
Join Date: Nov 2005
Location: nj usa
Posts: 223
Thanks: 14
Thanked 11 Times in 10 Posts
 
Default

www.urip.com:8080/phpmyadmin

but check out this post

http://wordpress.org/support/topic/p...-pagebut-in-db
Reply With Quote
Reply

Bookmarks

Tags
error, install, permissions, wordpress

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't Ping over VPN RoMiONeT Server Operation 2 4th July 2010 01:19
amavis & ispconfig 3 yalex2000 Installation/Configuration 20 18th February 2010 18:02
Ftp problems timeout reny2000 General 6 23rd December 2009 12:09
I don't recieve mail. privir Installation/Configuration 2 3rd June 2009 23:08
ISPConfig running on default web server (port 80) geek.de.nz Installation/Configuration 3 31st March 2008 11:32


All times are GMT +2. The time now is 17:43.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.