Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 4th June 2010, 21:49
pluider pluider is offline
Junior Member
 
Join Date: Jun 2010
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default New install in vm having issue with setting phpmyadmin password

I get

mysqladmin -h hosting.xyzt.ca -u root password abcdef
mysqladmin: connect to server at 'hosting.xyzt.ca' failed
error: 'Host 'hosting.xyzt.ca' is not allowed to connect to this MySQL server'

if I telnet localhost 3306 I get a connect

[root@trinity compileuser]# telnet localhost 3306
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
4
5.0.7hBOI^~"(,APO{?e_,^tNfConnection closed by foreign host.
[root@trinity compileuser]#



Also a few steps later the phpmyadmin.conf doesn't exist.

Any help is appreciated..







I've been following the centos 5.4 perfect server guide for the ispconfig 3 install pretty much to the letter I believe. NOTE: This is running on a 32 bit system.

Last edited by pluider; 4th June 2010 at 22:04. Reason: Additional info
Reply With Quote
Sponsored Links
  #2  
Old 4th June 2010, 22:06
pluider pluider is offline
Junior Member
 
Join Date: Jun 2010
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Some additional info.

I tried the setting of the mysqladmin password again incase I messed something up and get the following.

mysqladmin -u root password abcdefg
mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: NO)'
Reply With Quote
  #3  
Old 5th June 2010, 00:36
maced0n maced0n is offline
Junior Member
 
Join Date: Dec 2009
Posts: 25
Thanks: 1
Thanked 3 Times in 3 Posts
Default

To log in , type:

mysql -uroot -p

and enter password when prompted



Quote:
Originally Posted by pluider View Post
Some additional info.

I tried the setting of the mysqladmin password again incase I messed something up and get the following.

mysqladmin -u root password abcdefg
mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: NO)'
Reply With Quote
  #4  
Old 7th June 2010, 19:30
pluider pluider is offline
Junior Member
 
Join Date: Jun 2010
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default phpmyadmin missing

If i connect to the mysql it works. So it seems the password got set. The next step is to edit the phpmyadmin but the conf file is no where on the system. Going back to the earlier install of all the packages it looks like its not there.

yum install phpmyadin returns.

[root@hosting conf.d]# !310
yum install ntp httpd mysql-server php php-mysql php-mbstring php-mcrypt phpmyadmin
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* addons: mirror.raystedman.net
* base: mirror.rackspace.com
* extras: centos.omnispring.com
* updates: mirror.trouble-free.net
Setting up Install Process
Package ntp-4.2.2p1-9.el5.centos.2.1.i386 already installed and latest version
Package httpd-2.2.3-43.el5.centos.i386 already installed and latest version
Package mysql-server-5.0.77-4.el5_5.3.i386 already installed and latest version
Package php-5.1.6-27.el5.i386 already installed and latest version
Package php-mysql-5.1.6-27.el5.i386 already installed and latest version
Package php-mbstring-5.1.6-27.el5.i386 already installed and latest version
Package php-mcrypt-5.1.6-15.el5.centos.1.i386 already installed and latest version
No package phpmyadmin available.
Nothing to do


So where do I get it? and Install it.
Reply With Quote
  #5  
Old 8th June 2010, 16:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

Did you enable the RPMforge repository, as shown in chapter 9 on http://www.howtoforge.com/perfect-se...ispconfig-3-p3 ? Please make sure you use the i386 rpm package instead of the one for x86_64.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 10th June 2010, 17:18
pluider pluider is offline
Junior Member
 
Join Date: Jun 2010
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default Update on issue

That seems to be a normal error after you set the password. I thought I mucked up my install badly so I installed a new centos 5.4 and re-did everything in the perfect server how to to the letter. It seemed to work much better.

Just a suggestion but if there are normal errors like that maybe include them in the tutorial. There were a couple of other places that the specfied file was empty and I thought I'd messed up cause there was nothing the file or it was created new when I entered the vi command. Someplaces it does that but not all.

Thanks for your helpful hints and such.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to install phpMyAdmin on v3.0.2? jwlinux Installation/Configuration 1 28th March 2010 22:32
Phpmyadmin issue (Virtual Users And Domains With Postfix, Courier And MySQL ) tonkyman HOWTO-Related Questions 2 21st October 2008 15:27
pdo_mysql install issue digen Server Operation 3 7th January 2008 14:16
during install, mistyped sql password. mwebb Installation/Configuration 2 15th December 2005 20:21
MySQL issue during install of ISPConfig ricbax Installation/Configuration 4 16th September 2005 09:41


All times are GMT +2. The time now is 15:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.