Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 24th February 2010, 20:15
Been Told Been Told is offline
HowtoForge Supporter
 
Join Date: Nov 2008
Posts: 123
Thanks: 29
Thanked 7 Times in 4 Posts
Default Spam Assassin problem during sa-update

My Spam Assassin was throwing false errors because of the date bug described here:
http://www.faqforge.com/linux/how-to...ast_20xx-rule/

So I ran "/home/admispconfig/ispconfig/tools/spamassassin/usr/bin/sa-update" as described in the tutorial. But that gave me this output:
Quote:
Can't locate LWP/UserAgent.pm in @INC (@INC contains: /home/admispconfig/ispconfig/tools/spamassassin/usr/share/perl/5.10.0 /etc/perl /usr/local/lib/perl/5.10.0 /usr/local/share/perl/5.10.0 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl) at /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/sa-update line 79.
BEGIN failed--compilation aborted at /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/sa-update line 79.
Any ideas anyone? The server is running on Debian Lenny, ISPConfig 2.

Also, sometimes when I write to someone and they reply to me, there's a "-->" just before my e-mail. This also happens when I send e-mail to myself. So it must be something on my server.
__________________
My stats:
  • RootServer running ISPconfig 2 on Debian Lenny
  • vServer running PLESK 8.4 on openSUSE 10.3
  • vServer running PLESK 9 on Ubuntu

Last edited by Been Told; 24th February 2010 at 20:18.
Reply With Quote
Sponsored Links
  #2  
Old 25th February 2010, 17:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,711
Thanks: 1,900
Thanked 2,702 Times in 2,545 Posts
Default

Can you try this?
Code:
aptitude install liblwpx-paranoidagent-perl
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
Been Told (25th February 2010)
  #3  
Old 25th February 2010, 18:02
Been Told Been Told is offline
HowtoForge Supporter
 
Join Date: Nov 2008
Posts: 123
Thanks: 29
Thanked 7 Times in 4 Posts
Default

Looks like that did it! I ran the sa-update line again and now it finished without errors. Danke Falko
__________________
My stats:
  • RootServer running ISPconfig 2 on Debian Lenny
  • vServer running PLESK 8.4 on openSUSE 10.3
  • vServer running PLESK 9 on Ubuntu
Reply With Quote
  #4  
Old 9th June 2010, 15:25
Mikymike Mikymike is offline
Junior Member
 
Join Date: Nov 2006
Posts: 3
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

I've done a brand new install of ISPConfig 2.2.36 after following completly the perfect setup for my debian 5 lenny distro and had the same problem.

Code:
aptitude install liblwpx-paranoidagent-perl
or
Code:
apt-get install liblwpx-paranoidagent-perl
Should be missing or in the installation script or in the perfect setup

Then I've done:
Code:
/home/admispconfig/ispconfig/tools/spamassassin/usr/bin/sa-update
After doing those commands my spamassassin is filtering now correctly.

Thank you for everything and for your very good work on ISPConfig

Michael

Last edited by Mikymike; 9th June 2010 at 15:27.
Reply With Quote
The Following User Says Thank You to Mikymike For This Useful Post:
falko (10th June 2010)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Spamfilter policy - question about spam actions prisfeo Installation/Configuration 4 2nd February 2010 16:17
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
firewall problem after update to 2.2.23 - probably a bug?! blocker General 3 18th August 2008 15:17
Update Problem bixa Installation/Configuration 7 21st April 2008 12:10
Email problem - all outgoing mail end up as spam haaglin General 8 16th October 2007 17:35


All times are GMT +2. The time now is 22:21.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.