Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 9th June 2006, 14:47
Kolossos Kolossos is offline
Junior Member
 
Join Date: Jun 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Postfix installation problem

Hi!
I get this when I try step 11 (http://www.howtoforge.com/perfect_setup_ubuntu_6.06_p5) in the The Perfect Setup - Ubuntu 6.06 LTS Server (Dapper Drake) howto.


Code:
root@kolossos:/home/admin# apt-get install postfix postfix-tls libsasl2 sasl2-bin libsasl2-modules libdb3-util procmail
Reading package lists... Done
Building dependency tree... Done
Package postfix-tls is a virtual package provided by:
  postfix 2.2.10-1ubuntu0.1
You should explicitly select one to install.
E: Package postfix-tls has no installation candidate
I am a nooblet so I dont have a clue what it mean or what I should do
Reply With Quote
Sponsored Links
  #2  
Old 9th June 2006, 23:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Please make sure your /etc/apt/sources.list looks exactly like the one from the tutorial. Run
Code:
apt-get update
after your changes and then try to install Postfix again.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 10th June 2006, 01:04
Kolossos Kolossos is offline
Junior Member
 
Join Date: Jun 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
Please make sure your /etc/apt/sources.list looks exactly like the one from the tutorial. Run
Code:
apt-get update
after your changes and then try to install Postfix again.
Checked the sources.list and it's correct and nothing new from update.

The good news is that I installed postfix without the postfix-tls package and now it seems to work. According to http://doc.ubuntu.com/ubuntu/serverg...-services.html the transport layer security should be installed with postfix as standard, I think .
Now everything seems to work, I have just installed ispconfig, do you think I will have any problems from leaving the packege out?

Thanks for your fast answer and thanks for a very good howto!
Reply With Quote
  #4  
Old 10th June 2006, 21:16
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by Kolossos
Now everything seems to work, I have just installed ispconfig, do you think I will have any problems from leaving the packege out?
No, you won't have problems. Do you see TLS in the output of
Code:
telnet localhost 25
, as described in the tutorial?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 12th June 2006, 00:33
pinz0 pinz0 is offline
Member
 
Join Date: Jun 2006
Location: Vienna, Austria
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to pinz0 Send a message via AIM to pinz0 Send a message via Skype™ to pinz0
Default i had the same troubles..

i checked my apt sources-list --> OK, but couldn't install postfix-tls. so i just installed postfix (without TLS). i finished this howto except installing ISPconfig.i really want to fix this postfix-problem first before i start with the ISPconfig-setup.

if i type "telnet localhost 25" in to my shell then it just says this:
Code:
root@lemmi:/home/admin# telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.localdomain.
Escape characters is '^]'.
Connection closed by foreign host.
root@lemmi:/home/admin#
so, i can't see TLS in the ouptut..
what is wrong?

would be great to get some support,
many thanks in advance!
robert

Last edited by pinz0; 12th June 2006 at 01:16.
Reply With Quote
  #6  
Old 12th June 2006, 10:14
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

Please post the output of the command:

apt-get update
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 12th June 2006, 10:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

What's in /etc/postfix/main.cf (please strip out the comments)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 12th June 2006, 15:17
pinz0 pinz0 is offline
Member
 
Join Date: Jun 2006
Location: Vienna, Austria
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to pinz0 Send a message via AIM to pinz0 Send a message via Skype™ to pinz0
Default

Quote:
Originally Posted by till
Please post the output of the command:

apt-get update
OK, this is the output:
Code:
root@lemmi:/home/admin# apt-get update
Hole:1 http://de.archive.ubuntu.com dapper Release.gpg [189B]
Hole:2 http://de.archive.ubuntu.com dapper-updates Release.gpg [189B]          
OK   http://de.archive.ubuntu.com dapper Release                               
OK   http://de.archive.ubuntu.com dapper-updates Release                       
Hole:3 http://security.ubuntu.com dapper-security Release.gpg [189B]           
OK   http://de.archive.ubuntu.com dapper/main Packages             
OK   http://de.archive.ubuntu.com dapper/restricted Packages       
OK   http://de.archive.ubuntu.com dapper/main Sources              
OK   http://de.archive.ubuntu.com dapper/restricted Sources        
OK   http://de.archive.ubuntu.com dapper/universe Packages         
OK   http://de.archive.ubuntu.com dapper/universe Sources          
OK   http://de.archive.ubuntu.com dapper-updates/main Packages     
OK   http://de.archive.ubuntu.com dapper-updates/restricted Packages
OK   http://de.archive.ubuntu.com dapper-updates/main Sources      
OK   http://de.archive.ubuntu.com dapper-updates/restricted Sources
OK   http://security.ubuntu.com dapper-security Release            
OK   http://security.ubuntu.com dapper-security/main Packages
OK   http://security.ubuntu.com dapper-security/restricted Packages
OK   http://security.ubuntu.com dapper-security/main Sources
OK   http://security.ubuntu.com dapper-security/restricted Sources
OK   http://security.ubuntu.com dapper-security/universe Packages
OK   http://security.ubuntu.com dapper-security/universe Sources
Es wurden 3B in 0s geholt (4B/s)   
Paketlisten werden gelesen... Fertig
hope this will help somehow..
thanks!
__________________
___________________
pinz0 - working on ubuntu 6.06 + ispconfig
Reply With Quote
  #9  
Old 12th June 2006, 15:21
pinz0 pinz0 is offline
Member
 
Join Date: Jun 2006
Location: Vienna, Austria
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to pinz0 Send a message via AIM to pinz0 Send a message via Skype™ to pinz0
Default

Quote:
Originally Posted by falko
What's in /etc/postfix/main.cf (please strip out the comments)?
Code:
root@lemmi:/home/admin# vim /etc/postfix/main.cf

# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = lemmi.allocat.net
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = lemmi.allocat.net, localhost.allocat.net, localhost
relayhost =
mynetworks = 192.168.1.2/8
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smptd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smptd_tls_loglevel = 1
smptd_tls_received_header = yes
smptd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
do i have to make some changes here?
thanks!
__________________
___________________
pinz0 - working on ubuntu 6.06 + ispconfig
Reply With Quote
  #10  
Old 12th June 2006, 16:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
 
Default

Please run
Code:
postconf -e 'mynetworks = 127.0.0.0/8 192.168.1.2/8'
and restart Postfix.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 17:58
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
postfix ISPconfig problem matehortua Installation/Configuration 8 3rd September 2006 17:03
postfix problem flourishing General 1 7th December 2005 17:39
Installation problem xma Installation/Configuration 15 26th September 2005 13:22


All times are GMT +2. The time now is 10:39.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.