Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th May 2010, 11:52
artifact66 artifact66 is offline
Junior Member
 
Join Date: May 2010
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation Message to sender when user over quota

Hello,

Installed ISPconfig 3 using

http://www.howtoforge.com/perfect-se...nx-ispconfig-3

For testing reasons i set (ISPconfig 3 control panel):

Code:
Client: Limits: Mailbox quota = 5
Mailbox: Quota = 5

Server config: Mail: Mailbox Size Limit = 5
Server config: Mail: Message Size Limit = 5
Now if im sending email bigger 5mb, i get back email from Mail Delivery System that:

Code:
<aaa@bbb.org>: message size 6146320 exceeds size limit 5242880 of
    server bbb.org[111.222.333.444]
But, if i am sending by pieces 1mb, then 5 emails ok, but 6 is not delivered:

Code:
D3004214F7 1393067 Sun May 30 12:27:43 sender@bbb.org
(temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied maildrop: maildir over quota.)
for@bbb.org
And there is no notification about quota limit reachet or similar.

How to solve this?
Reply With Quote
Sponsored Links
  #2  
Old 30th May 2010, 12:05
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,420 Times in 4,262 Posts
Default

Quote:
And there is no notification about quota limit reachet or similar.
Thats because this is no quota limit. What you reached here is the message size limit in postfix and not a limit in ispconfig. You can set the message_size_limit limit to 20 MB by adding:

message_size_limit = 20480000

at the end of postfix main.cf file and then restart postfix.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 1st June 2010, 10:38
artifact66 artifact66 is offline
Junior Member
 
Join Date: May 2010
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Tnx for answer, but seems like not solved.

message_size_limit = 20480000 is in main.cf when value saved in ISPconfig.

System:Server Config:Mail:

Mailbox Size Limit = 100 MB
Message Size Limit = 20 MB

Still no answer from server, and it is waiting in queue until mailbox get more free space.
Reply With Quote
  #4  
Old 2nd June 2010, 17:54
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

What's the output of
Code:
postconf -n
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 5th June 2010, 09:35
artifact66 artifact66 is offline
Junior Member
 
Join Date: May 2010
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Code:
root@server:/# postconf -n
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
body_checks = regexp:/etc/postfix/body_checks
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
content_filter = amavis:[127.0.0.1]:10024
header_checks = regexp:/etc/postfix/header_checks
html_directory = /usr/share/doc/postfix/html
inet_interfaces = all
mailbox_size_limit = 104857600
message_size_limit = 26214400
mime_header_checks = regexp:/etc/postfix/mime_header_checks
mydestination = xxxxxx.com, localhost, localhost.localdomain
myhostname = xxxxxx.com
mynetworks = 127.0.0.0/8 [::1]/128
myorigin = /etc/mailname
nested_header_checks = regexp:/etc/postfix/nested_header_checks
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
readme_directory = /usr/share/doc/postfix
receive_override_options = no_address_mappings
recipient_delimiter = +
relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
relay_recipient_maps = mysql:/etc/postfix/mysql-virtual_relayrecipientmaps.cf
relayhost = 
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_authenticated_header = yes
smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_tls_security_level = may
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
virtual_alias_domains = 
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
virtual_gid_maps = static:5000
virtual_mailbox_base = /var/vmail
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_transport = maildrop
virtual_uid_maps = static:5000
After 5 or 6 days timeout message come back to sender:

Undelivered Mail Returned to Sender

<xxx@xxx.xx>: temporary failure. Command output: ERR: authdaemon:
s_connect() failed: Permission denied maildrop: maildir over quota.

Maybe somewhere is this timeout setting?

Last edited by artifact66; 5th June 2010 at 13:10.
Reply With Quote
  #6  
Old 6th June 2010, 11:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Are the 100MB of that mail account full?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 6th June 2010, 21:39
artifact66 artifact66 is offline
Junior Member
 
Join Date: May 2010
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

No, every single mailbox now set to 5mb. But i set every other value bigger than email, to see if there is enough space. I send 5 times by 1mb then next 1mb file is in queue for 5 or 6 days, then sender receive notification, that user over quota. I want to get that work immediately.

Strange thing is, that in main.cf is written:

Code:
virtual_maildir_extended = yes
virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
virtual_mailbox_limit_override = yes
virtual_maildir_limit_message = "The user you are trying to reach is over quota."
virtual_overquota_bounce = yes

but in postconf -n it isn't. Why so?

Last edited by artifact66; 6th June 2010 at 21:42.
Reply With Quote
  #8  
Old 7th June 2010, 13:19
warlock warlock is offline
Member
 
Join Date: Nov 2008
Posts: 93
Thanks: 1
Thanked 6 Times in 4 Posts
Default

If the users mailbox is over quota, postfix will keep trying to deliver the mail for 5 days (default) at growing intervals, at which point it will then respond back to the send saying mail can't be delivered.
Reply With Quote
  #9  
Old 7th June 2010, 13:24
warlock warlock is offline
Member
 
Join Date: Nov 2008
Posts: 93
Thanks: 1
Thanked 6 Times in 4 Posts
Default

Sorry I needed to add, this is because ISPC use disk quota's and not quota's at postfix level.

hence when you reach 5mb, postfix or maildrop can write the mail into the users mailbox as he has run out of space and after 5 days if will return and NDR.

if you were to change the
mailbox_size_limit = 104857600
to
mailbox_size_limit = 5242880

this will then have the effect you are looking for, but this will then do teh same to all mailboxes on your server
Reply With Quote
  #10  
Old 7th June 2010, 15:37
artifact66 artifact66 is offline
Junior Member
 
Join Date: May 2010
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Found that if i change in postfix

bounce_queue_lifetime = 5d
maximal_queue_lifetime = 5d

to

bounce_queue_lifetime = 0
maximal_queue_lifetime = 0

Now problem solved, only dont know other problems this can cause.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
freebsd 7, samba 3, domain controller alexdimarco Suggest HOWTO 6 5th November 2010 16:54
Exim Gateway with mailwatch (Unable to receive emails) siul0_0 HOWTO-Related Questions 10 8th May 2009 23:00
The system is currently updating the configuration files. warlock General 8 21st February 2009 18:15
Undelivered Mail Returned to Sender - Disk quota problems Mole Installation/Configuration 1 14th January 2009 18:00
Set quota for every user of a site zeeman Installation/Configuration 3 19th April 2007 14:11


All times are GMT +2. The time now is 02:26.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.