Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 3rd June 2010, 14:01
Andreas0815 Andreas0815 is offline
Junior Member
 
Join Date: Jun 2010
Posts: 27
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Hi!

I've got the same problem. I installed ISPConfig using the "Perfect Server" Howto (BTW: Great Howto!). I started with page 3 because the system is pre-installed (using a JiffyBox - virtual cloudserver on demand - www.jiffybox.de).

OS is Ubuntu 10.04 LTS x64. Kernel 2.6.33.2-x86_64-jb1. The system is, as I wrote above, a virtual server using Xen.

PHP is always running as mod_php, no matter if I select "FastCGI" or "CGI" or anything else. phpinfo() always tells "Apache 2.0 Handler"

The vhost file seems to be ok for me:
Code:
      DocumentRoot /var/www/blog.***.de/web
  
    ServerName blog.***.de
    ServerAdmin webmaster@blog.***.de

    ErrorLog /var/log/ispconfig/httpd/blog.***.de/error.log

    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 503 /error/503.html
	
    <Directory /var/www/blog.***.de/web>
        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
        
        # ssi enabled
        AddType text/html .shtml
        AddOutputFilter INCLUDES .shtml
        Options +Includes
    </Directory>
    <Directory /var/www/clients/client1/web1/web>
        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
        
        # ssi enabled
        AddType text/html .shtml
        AddOutputFilter INCLUDES .shtml
        Options +Includes
    </Directory>

    # cgi enabled
	<Directory /var/www/clients/client1/web1/cgi-bin>
      Order allow,deny
      Allow from all
    </Directory>
    ScriptAlias  /cgi-bin/ /var/www/clients/client1/web1/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    # suexec enabled
    SuexecUserGroup web1 client1
    # php as fast-cgi enabled
    <IfModule mod_fcgid.c>
      # SocketPath /tmp/fcgid_sock/
      IdleTimeout 3600
      ProcessLifeTime 7200
      # MaxProcessCount 1000
      DefaultMinClassProcessCount 3
      DefaultMaxClassProcessCount 100
      IPCConnectTimeout 8
      IPCCommTimeout 360
      BusyTimeout 300
    </IfModule>
    <Directory /var/www/blog.***.de/web>
        AddHandler fcgid-script .php .php3 .php4 .php5
        FCGIWrapper /var/www/php-fcgi-scripts/web1/.php-fcgi-starter .php
        Options +ExecCGI
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
	<Directory /var/www/clients/client1/web1/web>
        AddHandler fcgid-script .php .php3 .php4 .php5
        FCGIWrapper /var/www/php-fcgi-scripts/web1/.php-fcgi-starter .php
        Options +ExecCGI
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>

    # add support for apache mpm_itk
    <IfModule mpm_itk_module>
      AssignUserId web1 client1
    </IfModule>
Can you please help me solving this?

Thank you!
Andreas
Reply With Quote
Sponsored Links
  #12  
Old 4th June 2010, 12:11
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

How do you access your phpinfo(); page? Do you use blog.***.de, an IP address or another address?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #13  
Old 4th June 2010, 13:13
Andreas0815 Andreas0815 is offline
Junior Member
 
Join Date: Jun 2010
Posts: 27
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Hi Falko!

I access the phpinfo() via blog.***.de.
Reply With Quote
  #14  
Old 5th June 2010, 12:45
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Is there an .htaccess file in /var/www/clients/client1/web1/web? If so, what's in it?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #15  
Old 5th June 2010, 18:09
Andreas0815 Andreas0815 is offline
Junior Member
 
Join Date: Jun 2010
Posts: 27
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Hi Falko,

there is a .htaccess, but this is only the default Wordpress SEO RewriteRule.
Reply With Quote
  #16  
Old 5th June 2010, 18:19
jumba jumba is offline
Member
 
Join Date: May 2010
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Andreas0815 View Post
PHP is always running as mod_php, no matter if I select "FastCGI" or "CGI" or anything else. phpinfo() always tells "Apache 2.0 Handler"
That's my problem also. Even if I create a client and only allow him to select FastCGI for the websites, phpinfo tells that it uses Apache 2.0 Handler.

@falko
an empty .htaccess is created by default in each site. I always deleted it and of course, it makes no difference.
I installed ISPConfig 3.0.2.1 for the third time, same problem.

What files do we need to edit to fix this?

Last edited by jumba; 5th June 2010 at 18:36.
Reply With Quote
  #17  
Old 6th June 2010, 13:11
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Can you try to disable PHP globally, as shown in chapter 17.1 on http://www.howtoforge.com/perfect-se...ispconfig-2-p6 ?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #18  
Old 6th June 2010, 14:35
Andreas0815 Andreas0815 is offline
Junior Member
 
Join Date: Jun 2010
Posts: 27
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Hi Falko,

disabling PHP globally works, thank you!
Now I can switch between the PHP modes in ISPConfig

Maybe you can add this tip to the ISPC3 Howto?
Reply With Quote
  #19  
Old 6th June 2010, 19:00
jumba jumba is offline
Member
 
Join Date: May 2010
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thank you Falko, it worked.
Reply With Quote
  #20  
Old 8th June 2010, 18:13
brafreider brafreider is offline
Junior Member
 
Join Date: Jun 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default globally disabling php does not do it for me for suphp

Hello,
ubuntu 10.04, ispconfig 3 multiserver installation...

I have two other ispconfig servers running on ubuntu 9.10 without problems.
PHP is configured via suPHP, but on the 10.04 it is running with mod_php.

I have tried to disable php globally in mime.types and php5.conf like described in the howto for ispconfig 2, Chapter 17.1.

the vhost config looks like this:
Code:
...
 <Directory /var/www/clients/client3/web31/web>
        suPHP_Engine on
        # suPHP_UserGroup web31 client3
        AddHandler x-httpd-suphp .php .php3 .php4 .php5
        suPHP_AddHandler x-httpd-suphp
</Directory>
...
all I get is an error 500:
SecurityException in Application.cpp:511: Unknown Interpreter: php
Premature end of script headers: index.php

Edit: fastcgi+suexec is working, suPHP is not!

any Idea?
Thanks,
Björn

Last edited by brafreider; 9th June 2010 at 11:42. Reason: fastcgi test
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Security - mod_php with FTP vs SuPHP or SuExec ethanlifka Installation/Configuration 1 22nd February 2010 10:18


All times are GMT +2. The time now is 02:01.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.