Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 12th June 2010, 20:40
hakimus hakimus is offline
Junior Member
 
Join Date: Jun 2010
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Mail and DNS troubles with ISPconfig 3 in Ubuntu 10.04

Hi All,

Sorry by opening this thread, but I have been looking for related questions in the las few days without success (and thats why I´m opening this post :-P)

I have a server with DNS, Web and mail services.
The goal with ISPconfig was to facilitate my work, specially creating e-mail accounts in virtual domains.

Ok, I followed the the "how to". "Perfect Server: Ubuntu 10.04".
After that, the ISPCofig page is running ok, it says that ALL the services are running ok.

But, is not so true.
Problems:
1. MAIL:
I can log in in the squireel webmail, using a system account, but not with the new ones that I´ve created.
Even so, when I try to access some mailbox via POP3/IMAP, or I try to send a e-mail from squirell, I see the following error in the system log:

--------------
Code:
Jun 12 15:17:03 wig postfix/smtpd[9391]: warning: SASL: Connect to private/auth failed: No such file or directory
Jun 12 15:17:03 wig postfix/smtpd[9391]: fatal: no SASL authentication mechanisms
2. DNS :

Ok, trying to figure out what that h. is going on, what I did worng, i try to send a e-mail to one of the virtuak mailbox. I got this answer:

Code:
Delivery to the following recipient failed permanently:

    mailname@virtual_domain

Technical details of permanent failure:
DNS Error: DNS server returned answer with no data

So, I take a look to the /etc/bin/named.conf and the virtual domain zone conf file.
I saw that ISPConfig did it own configurations, but after that, when I run a
dig virtualdomain, it doesnt get a correct answer.

Thinking on a solution, I go to the DNS page on ISPConfig and add a MX DNS record. When I restart the bind daemon, I got the error:

Code:
Jun 12 15:27:48 server named[9703]: zone virtualdomain/IN: has no NS records
Jun 12 15:27:48 server named[9703]: zone virtualdomain/IN: not loaded due to errors.
Could please somebody help me? I´m starting to become crazy......
Reply With Quote
Sponsored Links
  #2  
Old 13th June 2010, 18:38
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Did you use the "Perfect Server" tutorial for ISPConfig 3 or ISPConfig 2?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 13th June 2010, 21:32
hakimus hakimus is offline
Junior Member
 
Join Date: Jun 2010
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ISPConfig 3 "Perfect Server" tutorial for Ubuntu 10.0.4 :-)
Reply With Quote
  #4  
Old 14th June 2010, 14:42
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

What's in /etc/postfix/sasl/smtpd.conf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 14th June 2010, 14:52
hakimus hakimus is offline
Junior Member
 
Join Date: Jun 2010
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Code:
 more /etc/postfix/sasl/smtpd.conf
pwcheck_method: saslauthd
mech_list: plain login
allow_plaintext: true
auxprop_plugin: mysql
sql_hostnames: 127.0.0.1
sql_user: ispconfig
sql_passwd: 833cab2b5ab1dc8016cf76d25dda20df
sql_database: dbispconfig
sql_select: select password from mail_user where email = '%u'
The mail_user tables exists in the dbispconfig database, and effectively, it has the user info.
Reply With Quote
  #6  
Old 14th June 2010, 21:31
hakimus hakimus is offline
Junior Member
 
Join Date: Jun 2010
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Dovecot or Courier?

Well, I understand that i nthe Perfect serve ;how To we have been using Postfix and Courier.
But I found some references to dovecot, I´m not sure if this is correct, and dint understand why or how this references from where this references came from.

In the /etc/postfix/main.cf I got:
Code:
#---------------------------------
# Virtual Mailbox Domain Settings

virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_limit = 51200000
virtual_minimum_uid = 5000
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
virtual_mailbox_base = /var/vmail
virtual_transport = dovecot
Some idea?
Reply With Quote
  #7  
Old 15th June 2010, 00:21
hakimus hakimus is offline
Junior Member
 
Join Date: Jun 2010
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello again.

I´m trying to debug the process and guessing where the problem is.
I tryed a telnet to POP and Imap ports without sucess.
I got a message on the /var/log telling thta the user was not found on the password file.

Ok, I check the postfix files and found that something that seems strange.
The virtual_domain and virtaul_mailoxes points to the ISPconfig database.
But the mysql_virtual_mailbox_maps.cf point to a postfix database.

Is this correct????



hakimus@wig:~$ sudo more /etc/postfix/mysql-virtual_domains.cf
Code:
user = ispconfig
password = 833cab2b5ab1a2drfg16cf76d25dda20df
dbname = dbispconfig
table = mail_domain
select_field = domain
where_field = domain
additional_conditions = and active = 'y' and server_id = 1
hosts = 127.0.0.1
hakimus@wig:~$ sudo more /etc/postfix/mysql-virtual_mailboxes.cf
Code:
user = ispconfig
password = 833cab2b5ab1a2drfg16cf76d25dda20df
dbname = dbispconfig
table = mail_user
select_field = CONCAT(SUBSTRING_INDEX(email,'@',-1),'/',SUBSTRING_INDEX(email,'@',1
),'/')
where_field = email
additional_conditions = and postfix = 'y' and server_id = 1
hosts = 127.0.0.1
hakimus@wig:~$ sudo more /etc/postfix/mysql_virtual_mailbox_maps.cf
Code:
user = postfix
password = pass_no_encrypted
hosts = 127.0.0.1
dbname = postfix
table = mailbox
select_field = maildir
where_field = username
#additional_conditions = and active = '1'
Reply With Quote
  #8  
Old 15th June 2010, 14:44
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Can you post the output of
Code:
netstat -tap
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 15th June 2010, 14:52
hakimus hakimus is offline
Junior Member
 
Join Date: Jun 2010
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks in advance Falko!!
I have been cheking configuration for Postfix, PAM, Courier Authdaemon, and so on, but I kind of a newbie in this subject, I dont know what I did wrong ... when ..... and where .... :-(

Follows the netstat -tap output:
Code:
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 localhost:10024         *:*                     LISTEN      970/amavisd (master
tcp        0      0 localhost:10025         *:*                     LISTEN      1692/master
tcp        0      0 localhost:mysql         *:*                     LISTEN      671/mysqld
tcp        0      0 localhost:spamd         *:*                     LISTEN      977/spamd.pid
tcp        0      0 *:www                   *:*                     LISTEN      1786/apache2
tcp        0      0 *:tproxy                *:*                     LISTEN      1786/apache2
tcp        0      0 *:ftp                   *:*                     LISTEN      1708/pure-ftpd (SER
tcp        0      0 172.32.3.2:domain       *:*                     LISTEN      811/named
tcp        0      0 wig.domain.com:domain *:*                     LISTEN      811/named
tcp        0      0 localhost:domain        *:*                     LISTEN      811/named
tcp        0      0 *:ssh                   *:*                     LISTEN      655/sshd
tcp        0      0 *:smtp                  *:*                     LISTEN      1692/master
tcp        0      0 localhost:953           *:*                     LISTEN      811/named
tcp        0      0 *:https                 *:*                     LISTEN      1786/apache2
tcp        0      0 *:9090                  *:*                     LISTEN      1786/apache2
tcp        0      0 localhost:39156         localhost:mysql         TIME_WAIT   -
tcp        0      0 localhost:mysql         localhost:56885         ESTABLISHED 671/mysqld
tcp        0      0 localhost:47317         localhost:mysql         ESTABLISHED 18901/amavisd (ch8-
tcp        0      0 localhost:mysql         localhost:56886         ESTABLISHED 671/mysqld
tcp        0      0 localhost:56885         localhost:mysql         ESTABLISHED 18886/proxymap
tcp        0      0 localhost:39158         localhost:mysql         TIME_WAIT   -
tcp        0      0 localhost:mysql         localhost:56884         ESTABLISHED 671/mysqld
tcp        0      0 localhost:40040         localhost:13002         ESTABLISHED 1585/wapbox
tcp        0      0 localhost:mysql         localhost:60048         ESTABLISHED 671/mysqld
tcp        0      0 localhost:56886         localhost:mysql         ESTABLISHED 18886/proxymap
tcp        0      0 localhost:mysql         localhost:47317         ESTABLISHED 671/mysqldtcp        0      0 localhost:39155         localhost:mysql         TIME_WAIT   -
tcp        0      0 localhost:10025         localhost:37432         TIME_WAIT   -
tcp        0      0 localhost:39157         localhost:mysql         TIME_WAIT   -
tcp        0      0 localhost:mysql         localhost:56883         ESTABLISHED 671/mysqld
tcp        0      0 localhost:60048         localhost:mysql         ESTABLISHED 18814/amavisd (ch11
tcp        0      0 localhost:56883         localhost:mysql         ESTABLISHED 18886/proxymap
tcp        0      0 localhost:56884         localhost:mysql         ESTABLISHED 17965/cleanup
tcp6       0      0 [::]:pop3               [::]:*                  LISTEN      1479/couriertcpd
tcp6       0      0 [::]:imap2              [::]:*                  LISTEN      1445/couriertcpd
tcp6       0      0 [::]:ftp                [::]:*                  LISTEN      1708/pure-ftpd (SER
tcp6       0      0 [::]:domain             [::]:*                  LISTEN      811/named
tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      655/sshd
tcp6       0      0 [::]:smtp               [::]:*                  LISTEN      1692/master
tcp6       0      0 ip6-localhost:953       [::]:*                  LISTEN      811/named
tcp6       0      0 [::]:imaps              [::]:*                  LISTEN      1465/couriertcpd
tcp6       0      0 [::]:pop3s              [::]:*                  LISTEN      1499/couriertcpd
Reply With Quote
  #10  
Old 16th June 2010, 14:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
 
Default

Ok, Courier is running. But is it possible that Dovecot is installed at the same time? What's the output of
Code:
ls -l /etc/init.d/
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Tags
ispconfig 3 bind9, postfix squirrelmail, sasl error

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix Timeout after DATA from some emails treeman Server Operation 13 25th September 2013 12:51
ERROR: Connection dropped by IMAP server. [Centos 5.4, courier imap,squirrel, etc] darevil HOWTO-Related Questions 7 9th June 2010 14:49
Postfix problem and few questions Gimly Installation/Configuration 12 7th July 2009 16:27
Postfix + postfixadmin = SMTP errors... Rashef Server Operation 4 25th June 2009 16:12
Core 4: Error Messages on Fresh Install re CTX/SSL jjw Installation/Configuration 30 6th September 2006 12:16


All times are GMT +2. The time now is 21:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.