Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 31st May 2006, 20:21
tgansert tgansert is offline
Member
 
Join Date: May 2006
Posts: 72
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation Mail not being delivered properly

My users are reporting that they are not receiving expected emails. I have verified this, although it seems to be intermittent.

Ok, so here are the details of one single email transaction. Something looks weird to me, but I'm not familiar enough with mail systems. Let me know what you think..

Code:
May 31 12:39:57 actualhost postfix/smtpd[13666]: connect from web50607.mail.yahoo.com[206.190.38.94]
May 31 12:39:57 actualhost postfix/smtpd[13666]: 67139BB55A: client=web50607.mail.yahoo.com[206.190.38.94]
May 31 12:39:57 actualhost postfix/cleanup[13669]: 67139BB55A: message-id=<20060531170855.31593.qmail@web50607.mail.yahoo.com>
May 31 12:39:57 actualhost postfix/qmgr[13625]: 67139BB55A: from=<porkorama@yahoo.com>, size=1241, nrcpt=1 (queue active)
May 31 12:39:57 actualhost postfix/trivial-rewrite[13668]: warning: do not list domain actualhost.actualdomain.tld in BOTH mydestination and virtual_alias_domains
May 31 12:39:57 actualhost postfix/smtpd[13666]: disconnect from web50607.mail.yahoo.com[206.190.38.94]
May 31 12:39:59 actualhost procmail[13671]: Error while writing to "/dev/null"
May 31 12:39:59 actualhost postfix/pickup[13624]: E2963BB68B: uid=10023 from=<user1>
May 31 12:39:59 actualhost postfix/cleanup[13669]: E2963BB68B: message-id=<20060531163959.E2963BB68B@actualhost.actualdomain.tld>
May 31 12:40:00 actualhost postfix/qmgr[13625]: E2963BB68B: from=<user1@actualhost.actualdomain.tld>, size=387, nrcpt=1 (queue active)
May 31 12:40:03 actualhost postfix/local[13670]: 67139BB55A: to=<user1@actualhost.actualdomain.tld>, orig_to=<user1@virtualdomain.tld>, relay=local, delay=6, status=sent (delivered to command: /usr/bin/procmail -f-)
May 31 12:40:03 actualhost postfix/qmgr[13625]: 67139BB55A: removed
May 31 12:40:04 actualhost postfix/local[13699]: E2963BB68B: to=<admispconfig@localhost>, relay=local, delay=5, status=sent (delivered to command: /usr/bin/procmail -f-)
May 31 12:40:04 actualhost postfix/qmgr[13625]: E2963BB68B: removed
Reply With Quote
Sponsored Links
  #2  
Old 31st May 2006, 20:28
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,794
Thanks: 840
Thanked 5,612 Times in 4,423 Posts
Default

Does this email account has spam filtering with automatic spam deletion enabled?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 31st May 2006, 20:38
MateKrisz MateKrisz is offline
Junior Member
 
Join Date: May 2006
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to MateKrisz Send a message via Skype™ to MateKrisz
Default E-mail problem

Hi all,

My website's users cat received e-mail 2 days ago. The auth ok, the mails not delivered they mailbox.

What report need for you ?

Krisz
Reply With Quote
  #4  
Old 31st May 2006, 20:42
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,794
Thanks: 840
Thanked 5,612 Times in 4,423 Posts
Default

Quote:
Originally Posted by MateKrisz
My website's users cat received e-mail 2 days ago. The auth ok, the mails not delivered they mailbox.

What report need for you ?
Please post an excerpt of your mail log, but to a new forum thraed and not in this thread.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 31st May 2006, 21:01
tgansert tgansert is offline
Member
 
Join Date: May 2006
Posts: 72
Thanks: 0
Thanked 0 Times in 0 Posts
Default

From what I can tell, it is only directed to prepend the subject with ***SPAM***, but I may not have looked in the right places. Direct me where to go and I will get back to you ASAP.
Reply With Quote
  #6  
Old 31st May 2006, 23:00
tgansert tgansert is offline
Member
 
Join Date: May 2006
Posts: 72
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Here's something interesting in /root/ispconfig/isp/conf/spamassassin.rc.master

Code:
# SpamAssassin sample procmailrc
#
# Pipe the mail through spamassassin (replace 'spamassassin' with 'spamc'
# if you use the spamc/spamd combination)
# The condition line ensures that only messages smaller than 250 kB
# (250 * 1024 = 256000 bytes) are processed by SpamAssassin. Most spam
# isn't bigger than a few k and working with big messages can bring
# SpamAssassin to its knees.
:0fw
* < 256000
| /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin --prefs-file={PREFS_FILE}

# Mails with a score of 15 or higher are almost certainly spam (with 0.05%
# false positives according to rules/STATISTICS.txt). Let's put them in a
# different mbox. (This one is optional.)
#:0:
#* ^X-Spam-Level: \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*
#/dev/null

# All mail tagged as spam (eg. with a score higher than the set threshold)
# is moved to "/dev/null".
{SPAM_COMMENT}:0:
{SPAM_COMMENT}* ^X-Spam-Status: Yes
{SPAM_COMMENT}/dev/null

# Work around procmail bug: any output on stderr will cause the "F" in "From"
# to be dropped.  This will re-add it.
:0
* ^^rom[ ]
{
  LOG="*** Dropped F off From_ header! Fixing up. "

  :0 fhw
  | sed -e '1s/^/F/'
}
Looks ominously like spam is sent to devnull don't pass go, dont' collect $200.

Everything else in the world tells it to prepend as ***SPAM*** is there something in here I need to change to induce this behaviour?

Keep in mind, emails that are most definitely not spam may not be getting through... This is not the ONLY problem, if it is a problem at all.. Till, I PM'ed you a literal log..

Last edited by tgansert; 31st May 2006 at 23:04.
Reply With Quote
  #7  
Old 1st June 2006, 00:59
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by tgansert
Looks ominously like spam is sent to devnull don't pass go, dont' collect $200.

Everything else in the world tells it to prepend as ***SPAM*** is there something in here I need to change to induce this behaviour?
You can specify in ISPConfig what happens to spam. Just go to the Antivirus/antispam tab in the user settings.

Quote:
May 31 12:39:57 actualhost postfix/trivial-rewrite[13668]: warning: do not list domain actualhost.actualdomain.tld in BOTH mydestination and virtual_alias_domains
Why do you have virtual_alias_domains in /etc/postfix/main.cf? It shouldn't be there.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 1st June 2006, 15:29
tgansert tgansert is offline
Member
 
Join Date: May 2006
Posts: 72
Thanks: 0
Thanked 0 Times in 0 Posts
Default

There is nowhere in the interface that I can find that specifies whether or not to delete spam.

falko & till, I PM'ed you a link to my /etc/postfix directory in a .tar.gz file.

If you have the time, I would be in your debt if you could take a look at my config and tell me where I'm going askew.

Thank you so much for your help guys, it is sincerely appreciated.

Last edited by tgansert; 1st June 2006 at 15:32.
Reply With Quote
  #9  
Old 1st June 2006, 18:00
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by tgansert
There is nowhere in the interface that I can find that specifies whether or not to delete spam.
http://www.ispconfig.org/downloads/m..._src.htm#4_2_2 , chapter 2.2.5.

Quote:
Originally Posted by tgansert
falko & till, I PM'ed you a link to my /etc/postfix directory in a .tar.gz file.
First you have to mydestination lines in your main.cf. Comment out this one:

Code:
mydestination = cpoc.sjcourierpost.com, localhost.sjcourierpost.com, courierpostonline.com, theimpulseonline.com, , localhost
Also comment out this line:
Code:
home_mailbox = mail
Then restart Postfix.
What's the output of
Code:
postconf -n | grep virtual_alias_domains
and
Code:
postconf -d | grep virtual_alias_domains
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 1st June 2006, 19:21
tgansert tgansert is offline
Member
 
Join Date: May 2006
Posts: 72
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Code:
[root@cpoc /home/abuse]$ postconf -n | grep virtual_alias_domains

[root@cpoc /home/abuse]$ postconf -d | grep virtual_alias_domains
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks
virtual_alias_domains = $virtual_alias_maps

[root@cpoc /home/abuse]
There was no response to postconf -n | grep virtual_alias_domains
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Not receiving any incoming mail. Jcorrea920 General 11 3rd April 2010 14:08
Filtering emails using Spamassassin and Clamav for Exchange 2000 Server Rocky Server Operation 19 11th March 2008 09:27
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs mholownych HOWTO-Related Questions 10 29th May 2006 04:39
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs ebbay Installation/Configuration 9 4th March 2006 12:47
Mail being delivered to maildir, pop mail app doesn't see nitefox Installation/Configuration 5 2nd February 2006 11:47


All times are GMT +2. The time now is 16:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.