Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #21  
Old 28th May 2010, 19:42
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

If you like to run a mailserver, then you better use a server or virtual server in a datacenter with fixed IP and dont run the server at home. Running a mailserver reliably on a dynamic IP is not possible.

The only alternative that you may have is that you use the mailserver of your ISP as relay server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Sponsored Links
  #22  
Old 28th May 2010, 21:14
zogthegreat zogthegreat is offline
Member
 
Join Date: Jul 2008
Posts: 50
Thanks: 4
Thanked 1 Time in 1 Post
Default

Hi till,

Just checked with My ISP. The out going mailserver for them is: smtphm.sympatico.ca or mailhost.sk.sympatico.ca, (depends on who you are talking to over there!).

Can you point me to a how to for relaying through my ISP mailserver?

Thanks

zog
Reply With Quote
  #23  
Old 28th May 2010, 21:19
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

In ISPConfig go to system > server config, then click on the server, go to the mail tab. Then enter the mailserver name of your isp in the relayhost field and the username and password for the realy server in the relay user and relay password field.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #24  
Old 28th May 2010, 21:34
zogthegreat zogthegreat is offline
Member
 
Join Date: Jul 2008
Posts: 50
Thanks: 4
Thanked 1 Time in 1 Post
Default

Hi till,

Did as you suggested, this is what I got;

tail -f /var/log/maillog
May 28 15:32:12 server1 postfix/qmgr[20610]: AFC86803E6: from=<bill@XXX.com>, size=1620, nrcpt=1 (queue active)
May 28 15:32:13 server1 postfix/smtp[20618]: AFC86803E6: to=<william.YYY@gmail.com>, relay=smtphm.sympatico.ca[65.55.172.251]:25, delay=15, delays=15/0.21/0.09/0.02, dsn=5.7.0, status=bounced (host smtphm.sympatico.ca[65.55.172.251] said: 530 5.7.0 Must issue a STARTTLS command first (in reply to MAIL FROM command))
May 28 15:32:13 server1 postfix/cleanup[20620]: 13A3D803ED: message-id=<20100528193213.13A3D803ED@server1.example.com>
May 28 15:32:13 server1 postfix/qmgr[20610]: 13A3D803ED: from=<>, size=3625, nrcpt=1 (queue active)
May 28 15:32:13 server1 postfix/bounce[20619]: AFC86803E6: sender non-delivery notification: 13A3D803ED
May 28 15:32:13 server1 postfix/qmgr[20610]: AFC86803E6: removed
May 28 15:32:13 server1 postfix/pipe[20623]: 13A3D803ED: to=<bill@XXX.com>, relay=maildrop, delay=0.21, delays=0.05/0.04/0/0.12, dsn=2.0.0, status=sent (delivered via maildrop service)
May 28 15:32:13 server1 postfix/qmgr[20610]: 13A3D803ED: removed

Any suggestions?

thanks

zog
Reply With Quote
  #25  
Old 28th May 2010, 22:31
zogthegreat zogthegreat is offline
Member
 
Join Date: Jul 2008
Posts: 50
Thanks: 4
Thanked 1 Time in 1 Post
Default

Found theis thread: http://www.howtoforge.com/postfix_re...her_mailserver. Just tried this:

postconf -e 'relayhost = smtphm.sympatico.ca'
postconf -e 'smtp_sasl_auth_enable = yes'
postconf -e 'smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd'
postconf -e 'smtp_sasl_security_options ='

echo "smtphm.sympatico.ca userasswd" > /etc/postfix/sasl_passwd

chown root:root /etc/postfix/sasl_passwd
chmod 600 /etc/postfix/sasl_passwd

postmap /etc/postfix/sasl_passwd

/etc/init.d/postfix restart

and got this output:

May 28 16:26:39 server1 sendmail[23456]: STARTTLS=client, relay=[127.0.0.1], version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
May 28 16:26:39 server1 postfix/smtpd[23457]: B3F0C803DB: client=localhost.localdomain[127.0.0.1]
May 28 16:26:39 server1 postfix/cleanup[23468]: B3F0C803DB: message-id=<54218.192.168.0.1.1275078399.squirrel@XXX.com>
May 28 16:26:39 server1 postfix/qmgr[23450]: B3F0C803DB: from=<bill@XXX.com>, size=1167, nrcpt=1 (queue active)
May 28 16:26:39 server1 sendmail[23456]: o4SKQd01023456: to="William YYY" <william.YYY@gmail.com>, ctladdr=bill@XXX.com (48/48), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30711, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as B3F0C803DB)
May 28 16:26:39 server1 postfix/smtpd[23457]: disconnect from localhost.localdomain[127.0.0.1]
May 28 16:26:39 server1 imapd: Connection, ip=[::ffff:127.0.0.1]
May 28 16:26:39 server1 imapd: LOGIN, user=bill@XXX.com, ip=[::ffff:127.0.0.1], port=[41919], protocol=IMAP
May 28 16:26:39 server1 postfix/smtp[23469]: B3F0C803DB: to=<william.YYY@gmail.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.16, delays=0.09/0.06/0.01/0, dsn=4.7.4, status=deferred (TLS is required, but was not offered by host 127.0.0.1[127.0.0.1])
May 28 16:26:39 server1 imapd: LOGOUT, user=bill@XXX.com, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=890, sent=555, time=0
May 28 16:26:40 server1 imapd: Connection, ip=[::ffff:127.0.0.1]
May 28 16:26:40 server1 imapd: LOGIN, user=bill@XXX.com, ip=[::ffff:127.0.0.1], port=[41922], protocol=IMAP
May 28 16:26:40 server1 imapd: LOGOUT, user=bill@XXX.com, ip=[::ffff:127.0.0.1], headers=3672, body=0, rcvd=322, sent=8035, time=0
May 28 16:26:41 server1 imapd: Connection, ip=[::ffff:127.0.0.1]
M
Reply With Quote
  #26  
Old 28th May 2010, 23:29
zogthegreat zogthegreat is offline
Member
 
Join Date: Jul 2008
Posts: 50
Thanks: 4
Thanked 1 Time in 1 Post
Default

Just notice that there is a problem with my telnet output:

[root@server1]# telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
220 server1.example.com ESMTP Postfix
421 4.4.2 server1.example.com Error: timeout exceeded
Connection closed by foreign host.

When I go over to another machine and do:

[bill@phoenix]# telnet XXX.com 25
Trying 70.53.152.148...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
220 server1.example.com ESMTP Postfix
421 4.4.2 server1.example.com Error: timeout exceeded
Connection closed by foreign host.

Any suggestions?

thanks

zog
Reply With Quote
  #27  
Old 29th May 2010, 18:38
zogthegreat zogthegreat is offline
Member
 
Join Date: Jul 2008
Posts: 50
Thanks: 4
Thanked 1 Time in 1 Post
Default

I just downloaded and tried The Perfect Server - CentOS 5.5 x86_64 [ISPConfig 3] vmware image for here: http://www.howtoforge.com/download.php?id=5374_0 .

When I try to: telnet localhost 25, I get this;

root@192.168.0.100's password:
Last login: Sat May 29 20:09:10 2010
[root@server1 ~]# telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
220 server1.example.com ESMTP Postfix
421 4.4.2 server1.example.com Error: timeout exceeded
Connection closed by foreign host.


I have no clue what I am doing wrong here, any suggestions?

Thanks

zog
Reply With Quote
  #28  
Old 29th May 2010, 18:39
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

Which message gets logged in the maillog?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #29  
Old 29th May 2010, 18:51
zogthegreat zogthegreat is offline
Member
 
Join Date: Jul 2008
Posts: 50
Thanks: 4
Thanked 1 Time in 1 Post
Default

Hi till,

[root@server1 ~]# telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
220 server1.example.com ESMTP Postfix
421 4.4.2 server1.example.com Error: timeout exceeded
Connection closed by foreign host.

[root@server1 ~]# tail -f /var/log/maillog (started before telnet)
May 29 20:19:55 server1 amavis[2248]: Internal decoder for .tnef
May 29 20:19:55 server1 amavis[2248]: Found decoder for .exe at /usr/bin/unrar; /usr/bin/lha; /usr/bin/arj
May 29 20:19:55 server1 amavis[2248]: Using primary internal av scanner code for ClamAV-clamd
May 29 20:19:55 server1 sendmail[2259]: alias database /etc/aliases rebuilt by root
May 29 20:19:55 server1 sendmail[2259]: /etc/aliases: 77 aliases, longest 10 bytes, 779 bytes total
May 29 20:19:55 server1 amavis[2248]: Found secondary av scanner ClamAV-clamscan at /usr/bin/clamscan
May 29 20:19:55 server1 amavis[2248]: Creating db in /var/spool/amavisd/db/; BerkeleyDB 0.41, libdb 4.3
May 29 20:19:57 server1 postfix/postfix-script: starting the Postfix mail system
May 29 20:19:58 server1 postfix/master[2305]: daemon started -- version 2.3.3, configuration /etc/postfix
May 29 20:19:58 server1 amavis[2248]: DKIM signature verification disabled, corresponding features not available. If not intentional, consider enabling it by setting: $enable_dkim_verification to 1, or explicitly disable it by setting it to 0 to quench down this warning.
May 29 20:21:12 server1 postfix/smtpd[2655]: connect from localhost.localdomain[127.0.0.1]
May 29 20:25:02 server1 postfix/smtpd[2805]: connect from localhost.localdomain[127.0.0.1]
May 29 20:25:02 server1 postfix/smtpd[2805]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
May 29 20:25:02 server1 postfix/smtpd[2805]: disconnect from localhost.localdomain[127.0.0.1]
May 29 20:25:02 server1 dovecot: pop3-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
May 29 20:25:02 server1 dovecot: imap-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
May 29 20:26:12 server1 postfix/smtpd[2655]: timeout after CONNECT from localhost.localdomain[127.0.0.1]
May 29 20:26:12 server1 postfix/smtpd[2655]: disconnect from localhost.localdomain[127.0.0.1]

zog
Reply With Quote
  #30  
Old 31st May 2010, 00:08
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,727 Times in 2,565 Posts
 
Default

What's the output of
Code:
netstat -tap
? What's in /etc/hosts?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix Timeout after DATA from some emails treeman Server Operation 13 25th September 2013 12:51
421 Unexpected failure Lizard King Installation/Configuration 20 7th July 2009 20:43
Postfix & mail forwarding loop varnik Server Operation 21 9th December 2008 15:13
Mail System Error - Returned Mail tristanlee85 General 16 16th March 2008 09:40
External mail server with gmail MX service adrenalinic Installation/Configuration 20 24th April 2007 14:49


All times are GMT +2. The time now is 18:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.