Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 21st May 2010, 13:03
voltron81 voltron81 is offline
Senior Member
 
Join Date: Sep 2009
Posts: 292
Thanks: 1
Thanked 4 Times in 3 Posts
Default Redirect a domain. ISPConfig is adding a / at the end of the path...

Hi to everybody.
I'm running a server with ISPConfig 3.0.1.6

I'm setting up a website www.domain.com that will be redirect to www.another.com
The redirect is working (I'm using the "no flag" option).
The problem that I've is that the redirect is adding a / at the end of the path... and my path is not working with that /

How to avoid this problem?


Thanks a lot
Michele

Last edited by voltron81; 21st May 2010 at 13:15.
Reply With Quote
Sponsored Links
  #2  
Old 22nd May 2010, 14:24
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Why does it not work with the /?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 24th May 2010, 10:15
voltron81 voltron81 is offline
Senior Member
 
Join Date: Sep 2009
Posts: 292
Thanks: 1
Thanked 4 Times in 3 Posts
Default

The destination address is a asp page, a kind of:
Code:
www.domain.com/p.asp?pref=15
and adding / at the end is not working anymore...
Reply With Quote
  #4  
Old 24th May 2010, 14:51
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

The redirect code is only made for directory redirects of domains. If you need some other kind of redirects, you can add them in the apache directives field of a website or in a .htaccess file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 24th May 2010, 15:20
voltron81 voltron81 is offline
Senior Member
 
Join Date: Sep 2009
Posts: 292
Thanks: 1
Thanked 4 Times in 3 Posts
 
Default

Hi Till,
thanks for your reply.

I was hoping that I was able to manage the redirect with ISPConfig (I really don't know why it's adding this / at the end)

Anyway if there is no way to avoid this problem, I'll edit apache file manually... in this case, could I know which command do I need for?

Thanks
Michele
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Host and Domain problems in ISPConfig Installation script atjensen11 Installation/Configuration 1 31st January 2009 00:57
ISPConfig 2.3.2-dev released till General 9 4th June 2007 10:46
Creating image with Systemimager cuongtim HOWTO-Related Questions 3 18th November 2006 13:55
SP-Server Setup - Ubuntu 5.10 "Breezy Badger" - Page 6 (changes) LuisC-SM HOWTO-Related Questions 0 21st April 2006 15:16
host site at same domain as ISPConfig server? amoswright Installation/Configuration 2 13th January 2006 22:43


All times are GMT +2. The time now is 06:34.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.