#1  
Old 2nd September 2005, 16:52
fuban fuban is offline
Junior Member
 
Join Date: Sep 2005
Posts: 19
Thanks: 0
Thanked 2 Times in 2 Posts
Angry 403 on webs

hi,

i got rid of confixx and installed ispconfig 2.08 on a brand new suse 9.3 setup - guided by the wonderful howto.

but i compiled php 4.40 and apage 2 myself to have the newest version.

well i install ispconfig, all went fine.
here is my problem:
i added a customer and a web - but when i type in the url of this web i get an 403 - forbidden.

another thing i haven't figured out yet:
when i add a web, how can i access this web via ftp?
it must be supereasy... but i dont get the point.

thanks, fabian
Reply With Quote
Sponsored Links
  #2  
Old 2nd September 2005, 17:01
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,814
Thanks: 821
Thanked 5,339 Times in 4,188 Posts
Default

Quote:
Originally Posted by fuban
here is my problem:
i added a customer and a web - but when i type in the url of this web i get an 403 - forbidden.
Has ISPConfig created the vhost file correctly? The vhosts are in the file
Vhost_ispconfig.conf. It is in the directory /etc/apache/vhosts or a similar directory under the config directory of your apache webserver. If you are unshure if the vhost is correct, post the content here.

Is the vhost configuration file included at the end of your httpd.conf?

What are the permissions of the directory of your website?


Quote:
Originally Posted by fuban
another thing i haven't figured out yet:
when i add a web, how can i access this web via ftp?
it must be supereasy... but i dont get the point.
Create a new user and check the "Administrator" Checkbox. This user will be able to upload files via FTP to your website.
Reply With Quote
  #3  
Old 2nd September 2005, 17:09
fuban fuban is offline
Junior Member
 
Join Date: Sep 2005
Posts: 19
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by till
Has ISPConfig created the vhost file correctly? The vhosts are in the file
Vhost_ispconfig.conf. It is in the directory /etc/apache/vhosts or a similar directory under the config directory of your apache webserver. If you are unshure if the vhost is correct, post the content here.

Is the vhost configuration file included at the end of your httpd.conf?


What are the permissions of the directory of your website?
yes, the vhost setup is correct:
DocumentRoot /srv/www/web1/web

permissions:
linux:/srv/www/web1 # ls -lisa
total 0
106184 0 drwxr-xr-x 8 nobody web1 192 Sep 1 17:30 .
652 0 drwxr-xr-x 3 root root 112 Sep 2 17:05 ..
106190 0 drwxrwxr-x 2 nobody web1 80 Sep 1 17:30 cgi-bin
106188 0 drwxr-xr-x 2 nobody web1 112 Sep 1 17:44 log
106194 0 drwxrwxrwx 2 nobody web1 80 Sep 1 17:30 phptmp
106192 0 drwxr-xr-x 2 nobody web1 80 Sep 1 17:30 ssl
106186 0 drwxr-xr-x 3 nobody web1 112 Sep 1 17:31 user
106185 0 drwxrwxr-x 3 nobody web1 104 Sep 1 17:30 web
linux:/srv/www/web1 #




Quote:
Originally Posted by till
Create a new user and check the "Administrator" Checkbox. This user will be able to upload files via FTP to your website.
ah ok, thanks i'll give it a try.
i assume that i can enable an administrator for every single web

thanks
Reply With Quote
  #4  
Old 2nd September 2005, 17:25
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,814
Thanks: 821
Thanked 5,339 Times in 4,188 Posts
Default

Quote:
Originally Posted by fuban
yes, the vhost setup is correct:
DocumentRoot /srv/www/web1/web

permissions:
linux:/srv/www/web1 # ls -lisa
total 0
106184 0 drwxr-xr-x 8 nobody web1 192 Sep 1 17:30 .
652 0 drwxr-xr-x 3 root root 112 Sep 2 17:05 ..
106190 0 drwxrwxr-x 2 nobody web1 80 Sep 1 17:30 cgi-bin
106188 0 drwxr-xr-x 2 nobody web1 112 Sep 1 17:44 log
106194 0 drwxrwxrwx 2 nobody web1 80 Sep 1 17:30 phptmp
106192 0 drwxr-xr-x 2 nobody web1 80 Sep 1 17:30 ssl
106186 0 drwxr-xr-x 3 nobody web1 112 Sep 1 17:31 user
106185 0 drwxrwxr-x 3 nobody web1 104 Sep 1 17:30 web
linux:/srv/www/web1 #
is the file /srv/www/web1/web/index.html there?
Did you get an forbidden error even if you call www.yourdomain.com/index.html?
Is the IP in the vhost configuration correct and does the domain point to your server?
Reply With Quote
  #5  
Old 2nd September 2005, 17:33
fuban fuban is offline
Junior Member
 
Join Date: Sep 2005
Posts: 19
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by till
is the file /srv/www/web1/web/index.html there?
Did you get an forbidden error even if you call www.yourdomain.com/index.html?
Is the IP in the vhost configuration correct and does the domain point to your server?
yes, the file is there.
but i get an 404 then...
here is my vhost, seems like there is something wrong - but it looks good, maybe you find something:

<VirtualHost 192.168.0.226:80>
SuexecUserGroup nobody web1
ServerName www.xxxxxx.de:80
ServerAdmin webmaster@xxxxxx.de
DocumentRoot /srv/www/web1/web
ServerAlias xxxxxx.de
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ErrorLog /srv/www/web1/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
<Files *.php>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php3>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php4>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php5>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
php_admin_flag safe_mode Off
Alias /error/ "/srv/www/web1/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /srv/www/web1/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /srv/www/web1/user/$1/web/$3
</VirtualHost>
Reply With Quote
  #6  
Old 2nd September 2005, 18:20
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,814
Thanks: 821
Thanked 5,339 Times in 4,188 Posts
Default

Quote:
Originally Posted by fuban
yes, the file is there.
but i get an 404 then...
here is my vhost, seems like there is something wrong - but it looks good, maybe you find something:

<VirtualHost 192.168.0.226:80>
SuexecUserGroup nobody web1
ServerName www.xxxxxx.de:80
ServerAdmin webmaster@xxxxxx.de
DocumentRoot /srv/www/web1/web
ServerAlias xxxxxx.de
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ErrorLog /srv/www/web1/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
<Files *.php>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php3>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php4>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php5>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
php_admin_flag safe_mode Off
Alias /error/ "/srv/www/web1/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /srv/www/web1/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /srv/www/web1/user/$1/web/$3
</VirtualHost>

As it is a private network address, are you shure you configured DNS correctly for the domain?
Reply With Quote
  #7  
Old 2nd September 2005, 18:24
fuban fuban is offline
Junior Member
 
Join Date: Sep 2005
Posts: 19
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by till
As it is a private network address, are you shure you configured DNS correctly for the domain?
well i'm setting the system up in my lan before i let it go public.
i have my hosts file updated to the local ip adress, so this should be fine

another thing, i just uninstalled ispconfig to start the installtion again - and i still get the 403 page (even if i clear cache) - so it looks like there is something with my httpd.conf ?

Last edited by fuban; 2nd September 2005 at 18:33.
Reply With Quote
  #8  
Old 2nd September 2005, 20:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Can you post your httpd.conf here? and also the output of
Code:
httpd -V
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 5th September 2005, 07:15
fuban fuban is offline
Junior Member
 
Join Date: Sep 2005
Posts: 19
Thanks: 0
Thanked 2 Times in 2 Posts
Default

thanks for your help - but i ended up installing a debian 3.1 - and i'm much more happier with debian than with suse.
Reply With Quote
  #10  
Old 6th September 2005, 20:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
 
Default

Quote:
Originally Posted by fuban
but i ended up installing a debian 3.1 - and i'm much more happier with debian than with suse.
Just like me...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 21:16.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.