Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 18th May 2010, 20:45
Niels Niels is offline
Member
 
Join Date: Oct 2009
Posts: 52
Thanks: 5
Thanked 2 Times in 2 Posts
Default Is dns right?

I have the domain jule-indsamling.dk but it seems that my nameserver (latest version of ispconfig) dont work as it should...

my nameserver is ns1.netopcom.dk

How can I see whats wrong with it?
Reply With Quote
Sponsored Links
  #2  
Old 19th May 2010, 15:54
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,672
Thanks: 819
Thanked 5,317 Times in 4,170 Posts
Default

To test the nameserver, you can use this command on the shell:

dig @ns1.netopcom.dk jule-indsamling.dk
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 19th May 2010, 17:34
Niels Niels is offline
Member
 
Join Date: Oct 2009
Posts: 52
Thanks: 5
Thanked 2 Times in 2 Posts
Default

It returns this (its running on Debian 5)


; <<>> DiG 9.5.1-P3 <<>> @ns1.netopcom.dk jule-indsamling.dk
; (1 server found)
;; global options: printcmd
;; connection timed out; no servers could be reached

Im lost here
Reply With Quote
  #4  
Old 19th May 2010, 18:36
mhpcomputerservices mhpcomputerservices is offline
HowtoForge Supporter
 
Join Date: Dec 2006
Location: Walsall, England
Posts: 37
Thanks: 5
Thanked 2 Times in 2 Posts
Send a message via MSN to mhpcomputerservices Send a message via Skype™ to mhpcomputerservices
Default

Quote:
Originally Posted by Niels View Post
It returns this (its running on Debian 5)


; <<>> DiG 9.5.1-P3 <<>> @ns1.netopcom.dk jule-indsamling.dk
; (1 server found)
;; global options: printcmd
;; connection timed out; no servers could be reached

Im lost here
It would appear that the DNS server is not running on your server.

DNS server ns5.gratisdns.dk[85.17.221.46] is alive and authoritative for domain jule-indsamling.dk
DNS server ns3.gratisdns.dk[194.0.2.6] is alive and authoritative for domain jule-indsamling.dk
Error fetching SOA from ns1.netopcom.dk [86.58.173.14], request timed out. Probably DNS server is offline.
DNS server ns4.gratisdns.dk[208.43.238.42] is alive and authoritative for domain jule-indsamling.dk
DNS server ns2.netopcom.dk[86.58.173.15] is alive and authoritative for domain jule-indsamling.dk

What package are you using for DNS?
Have you got any errors in the Control Panel monitor tab?
__________________
Regards
Marcus

*Computer Cables
*Running on Multiserver Setup (5 Servers) Debian 6.0 & ISPConfig 3.0.5.2
Reply With Quote
  #5  
Old 19th May 2010, 18:49
Niels Niels is offline
Member
 
Join Date: Oct 2009
Posts: 52
Thanks: 5
Thanked 2 Times in 2 Posts
Default

Im running latest ispconfig and myDNS on Ubuntu 9.10

In Monitor it shows that myDNS is running.
Reply With Quote
  #6  
Old 19th May 2010, 19:17
mhpcomputerservices mhpcomputerservices is offline
HowtoForge Supporter
 
Join Date: Dec 2006
Location: Walsall, England
Posts: 37
Thanks: 5
Thanked 2 Times in 2 Posts
Send a message via MSN to mhpcomputerservices Send a message via Skype™ to mhpcomputerservices
Default

Quote:
Originally Posted by Niels View Post
Im running latest ispconfig and myDNS on Ubuntu 9.10

In Monitor it shows that myDNS is running.
On the console.
Code:
netstat -tap
What is the output?
__________________
Regards
Marcus

*Computer Cables
*Running on Multiserver Setup (5 Servers) Debian 6.0 & ISPConfig 3.0.5.2
Reply With Quote
  #7  
Old 19th May 2010, 19:28
Niels Niels is offline
Member
 
Join Date: Oct 2009
Posts: 52
Thanks: 5
Thanked 2 Times in 2 Posts
Default

Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:smtp *:* LISTEN 6132/master
tcp 0 0 *:https *:* LISTEN 27290/apache2
tcp 0 0 localhost:10024 *:* LISTEN 6405/amavisd (maste
tcp 0 0 localhost:10025 *:* LISTEN 6132/master
tcp 0 0 *:mysql *:* LISTEN 5977/mysqld
tcp 0 0 localhost:spamd *:* LISTEN 1081/spamd.pid
tcp 0 0 *:http-alt *:* LISTEN 27290/apache2
tcp 0 0 *:www *:* LISTEN 27290/apache2
tcp 0 0 *:tproxy *:* LISTEN 27290/apache2
tcp 0 0 86.58.173.15:domain *:* LISTEN 29207/mydns
tcp 0 0 localhost:domain *:* LISTEN 29207/mydns
tcp 0 0 *:ftp *:* LISTEN 7928/pure-ftpd (SER
tcp 0 0 *:ssh *:* LISTEN 842/sshd
tcp 0 0 localhost:56838 localhost:mysql ESTABLISHED 25499/amavisd (ch15
tcp 0 0 localhost:mysql localhost:56838 ESTABLISHED 5977/mysqld
tcp 0 0 localhost:56834 localhost:mysql ESTABLISHED 25489/amavisd (ch16
tcp 0 52 86.58.173.15:ssh s83-179-9-205.cus:63714 ESTABLISHED 29103/sshd: adminis
tcp 0 0 localhost:mysql localhost:56834 ESTABLISHED 5977/mysqld
tcp6 0 0 [::]:imaps [::]:* LISTEN 7496/couriertcpd
tcp6 0 0 [::]op3s [::]:* LISTEN 7553/couriertcpd
tcp6 0 0 [::]op3 [::]:* LISTEN 7524/couriertcpd
tcp6 0 0 [::]:imap2 [::]:* LISTEN 7466/couriertcpd
tcp6 0 0 localhost:domain [::]:* LISTEN 29207/mydns
tcp6 0 0 [::]:ftp [::]:* LISTEN 7928/pure-ftpd (SER
tcp6 0 0 [::]:ssh [::]:* LISTEN 842/sshd
tcp6 0 0 86.58.173.15%32191op3 h55eb1828.dkkovbr:57352 TIME_WAIT -
tcp6 0 0 86.58.173.15%32191op3 h55eb1828.dkkovbr:57351 TIME_WAIT -
Reply With Quote
  #8  
Old 19th May 2010, 21:30
mhpcomputerservices mhpcomputerservices is offline
HowtoForge Supporter
 
Join Date: Dec 2006
Location: Walsall, England
Posts: 37
Thanks: 5
Thanked 2 Times in 2 Posts
Send a message via MSN to mhpcomputerservices Send a message via Skype™ to mhpcomputerservices
Default

Quote:
tcp 0 0 86.58.173.15:domain *:* LISTEN 29207/mydns
I don't have anything like the above which is making me wonder if there is a configuration issue or possibly just a DNS record problem.

Try the following and see if you get any errors
Code:
/etc/init.d/mydns stop
/etc/init.d/mydns start
Is the server hostname set correctly
Code:
hostname
hostname -f
Can you post screenshots of your DNS configuration?

How did you setup the server? Was it using the howtoforge guide?
__________________
Regards
Marcus

*Computer Cables
*Running on Multiserver Setup (5 Servers) Debian 6.0 & ISPConfig 3.0.5.2
Reply With Quote
  #9  
Old 19th May 2010, 22:42
BorderAmigos BorderAmigos is offline
Senior Member
 
Join Date: Apr 2008
Location: San Diego & Tijuana
Posts: 302
Thanks: 26
Thanked 33 Times in 31 Posts
Send a message via MSN to BorderAmigos Send a message via Yahoo to BorderAmigos
Default

Is "ns1.netopcom.dk" on your computer or at your domain registrar? If at the registrar do you have A records there pointing to the IP of "jule-indsamling.dk"?
__________________
System6Hosting.com, ISPConfig 3, Debian.
Reply With Quote
  #10  
Old 20th May 2010, 07:03
Niels Niels is offline
Member
 
Join Date: Oct 2009
Posts: 52
Thanks: 5
Thanked 2 Times in 2 Posts
 
Default

It working now

Thank for your help. I dont know what I did but I stopped the dns and started it again...

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Squid Proxy Caching on Linux obzerver Installation/Configuration 4 13th August 2008 19:51
Google Apps dayjahone General 19 29th March 2008 17:25
DNS Configuration Problems VMartins Installation/Configuration 10 24th July 2007 14:40
Unable send receive emails vassilis3 Installation/Configuration 15 19th May 2007 14:34
No SPF record. beryl Installation/Configuration 6 17th May 2007 19:52


All times are GMT +2. The time now is 19:13.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.