Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th May 2010, 14:55
muucest muucest is offline
Junior Member
 
Join Date: Jul 2009
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default Ubuntu 10.04 - client denied by server configuration

I just installed Ubuntu 10.04 by the perfect server tutorial but the system cannot access virtual host directories made by ISPConfig.

The error I see in apache2 error.log is "client denied by server configuration" - it seems to go for the virtual host directories and also /var/www/clients/, /var/www/php-fcgi-scripts/ - for me (trying to access it from outside) and even the server itself (127.0.0.1).

I can access files directly in /var/www/ though (by typing ip/filename to browser).

--

OK, I figured out that by changing first "Deny all" to "Allow all" in /etc/apache2/sites-enabled/sitename.com.vhost it starts working:

<Directory /var/www/sitename.com>
AllowOverride None
Order Deny,Allow
Allow from all
</Directory>

- is this an OK solution and can I make it so I wouldn't have to change it manually every time I add a vhost?

Last edited by muucest; 17th May 2010 at 15:38.
Reply With Quote
Sponsored Links
  #2  
Old 12th July 2010, 09:36
rajchd rajchd is offline
Junior Member
 
Join Date: Jul 2010
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default Thanks

Thanks for posting the solution, it helped me.
Reply With Quote
  #3  
Old 12th July 2010, 12:02
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,733
Thanks: 840
Thanked 5,596 Times in 4,407 Posts
Default

Quote:
is this an OK solution and can I make it so I wouldn't have to change it manually every time I add a vhost?
Thats not the solution as you opened up your system for hackers by opening up private directories which contain password files etc. The source of your problem is that you uploaded the files into the wrong directory. All php and html files have to be uploaded to /var/www/sitename.com/web/ and not /var/www/sitename.com/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 3rd September 2014, 00:35
maileh maileh is offline
Member
 
Join Date: Dec 2013
Posts: 79
Thanks: 6
Thanked 2 Times in 2 Posts
 
Question upload files

Till
With what you said above, i have transfer all my files to the /var/www/domain/web but still got the same error. Maybe i need to set it somewhere ...please can you shed some light on it.
Regards
Maile
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Freeradius and Mysql uvstudios HOWTO-Related Questions 4 19th February 2014 13:11
Problem with services!! banzaiwebstudio.com Installation/Configuration 7 19th May 2010 22:13
The system is currently updating the configuration files. warlock General 8 21st February 2009 19:15
Problem with keeping Apache alive bobeq Server Operation 3 29th November 2007 17:11
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 03:30


All times are GMT +2. The time now is 14:24.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.