#1  
Old 28th May 2010, 19:13
misterm misterm is offline
Senior Member
 
Join Date: Aug 2005
Posts: 558
Thanks: 20
Thanked 8 Times in 7 Posts
Angry Error install 2.2.36

Hello to all

Quote:
make[2]: quittant le répertoire « /root/install_ispconfig/compile_aps/apache_1.3.41/src »
make[1]: quittant le répertoire « /root/install_ispconfig/compile_aps/apache_1.3.41 »
make[1]: entrant dans le répertoire « /root/install_ispconfig/compile_aps/apache_1.3.41 »
===> src/support
make[2]: entrant dans le répertoire « /root/install_ispconfig/compile_aps/apache_1.3.41/src/support »
gcc -c -I../os/unix -I../include -DLINUX=22 -DHAVE_SET_DUMPABLE -DMOD_SSL=208131 -DUSE_HSREGEX -DEAPI `../apaci` htpasswd.c
htpasswd.c:101: error: conflicting types for 'getline'
/usr/include/stdio.h:651: error: previous declaration of 'getline' was here
make[2]: *** [htpasswd.o] Erreur 1
make[2]: quittant le répertoire « /root/install_ispconfig/compile_aps/apache_1.3.41/src/support »
make[1]: *** [build-support] Erreur 1
make[1]: quittant le répertoire « /root/install_ispconfig/compile_aps/apache_1.3.41 »
make: *** [build] Erreur 2
ERROR: Could not make Apache
Falko, my friend, problems with your update, the above, you find an error during installation, you give me an explanation, because the Belgian community server is down with your update.

MM
__________________
ISPConfig, the panel fantastic , http://www.ispconfig.be/forums/
http://www.ispconfig.be/
Sponsored Links
  #2  
Old 28th May 2010, 20:43
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,483
Thanks: 835
Thanked 5,524 Times in 4,345 Posts
Default

Which Linux distribution and version?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
  #3  
Old 28th May 2010, 20:56
misterm misterm is offline
Senior Member
 
Join Date: Aug 2005
Posts: 558
Thanks: 20
Thanked 8 Times in 7 Posts
Default distribution used , Debian 5.0

Hello Till

distribution used , Debian 5.0

MM
__________________
ISPConfig, the panel fantastic , http://www.ispconfig.be/forums/
http://www.ispconfig.be/
  #4  
Old 28th May 2010, 21:22
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,483
Thanks: 835
Thanked 5,524 Times in 4,345 Posts
Default

I guess you either updated to debian 6 or use debian testing as this error can occur only with libraries that are used in debian 6 / testing or ubuntu. Nevertehless, the solution is described in the ubuntu tutorial in step 22:

http://www.howtoforge.com/perfect-se...ispconfig-2-p7

and dont forget to run:

mkdir /root/ispconfig

before you try the update again.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
  #5  
Old 28th May 2010, 23:55
oriongr oriongr is offline
Member
 
Join Date: Nov 2007
Posts: 38
Thanks: 28
Thanked 3 Times in 3 Posts
Default

Hi,
I run into problems as well.. Debian 4
installed the new Perl modules as described in the mail

but
Code:
REQUIRED module out of date: NetAddr::IP
optional module missing: Mail::SPF
optional module missing: IP::Country
optional module missing: Razor2
optional module missing: Net::Ident
optional module missing: IO::Socket::INET6
optional module missing: IO::Socket::SSL
optional module missing: Mail::DKIM
optional module missing: Encode::Detect

warning: some functionality may not be available,
please read the above report before continuing!

make: *** No targets specified and no makefile found.  Stop.
ERROR: Could not make SpamAssassin
Code:
***************************************************************************
ERROR: the required NetAddr::IP module is installed (3.14),
but is below the minimum required version 4.000,
some functionality will not be available.
Any ideas?
  #6  
Old 29th May 2010, 00:32
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,483
Thanks: 835
Thanked 5,524 Times in 4,345 Posts
 
Default

Thats already answered here:

http://www.howtoforge.com/forums/showthread.php?t=46184
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
The Following User Says Thank You to till For This Useful Post:
oriongr (29th May 2010)
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 2.2.36 released till General 35 10th August 2010 14:12


All times are GMT +2. The time now is 16:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.