Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 10th May 2010, 09:48
Blinkiz Blinkiz is offline
Junior Member
 
Join Date: Sep 2009
Posts: 17
Thanks: 1
Thanked 0 Times in 0 Posts
Exclamation [BUG] Spam profile normal - All mails marked as spam

Hi
I do believe I have found a bug in 3.0.2.1. Possible other versions too.

When using spam profile "normal" on a account, all scores between 1 and 4.5 is marked as spam.
Problem comes from database dbispconfig and table spamfilter_policy. On id 5, "normal", spam_subject_tag has varchar value ***SPAM***.
I do believe this is wrong and this value should be in spam_subject_tag2.

I do not know how to report bugs, so am creating this thread in the forum.
Reply With Quote
Sponsored Links
  #2  
Old 10th May 2010, 10:03
mike_p mike_p is offline
Senior Member
 
Join Date: Mar 2010
Location: Surrey, England
Posts: 140
Thanks: 9
Thanked 28 Times in 17 Posts
Default

It seems my settings don't match yours.

For the normal setting, if an email achieves a score of ...
3 it is tagged with '-- potential spam --' (ie spam_subject_tag)
5 it is tagged with '***SPAM***' (ie spam_subject_tag2)
or if it reaches 50 it is dispatched to the darkest corners of hades.

AFAIK those are the settings that ISPCOnfig creates on installation. If your values differ, then they have been changed.

In my opinion, this does not constitute a 'BUG'.
Reply With Quote
  #3  
Old 10th May 2010, 11:10
Blinkiz Blinkiz is offline
Junior Member
 
Join Date: Sep 2009
Posts: 17
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Hi there Mike. Thanks for the comment.
I also have a new installation of 3.0.2.1 on Ubuntu 9.10.

The line, -- potential spam --, I do not have.
Reply With Quote
  #4  
Old 10th May 2010, 13:58
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,567
Thanks: 791
Thanked 4,979 Times in 3,900 Posts
Default

Quote:
Problem comes from database dbispconfig and table spamfilter_policy. On id 5, "normal", spam_subject_tag has varchar value ***SPAM***.
I do believe this is wrong and this value should be in spam_subject_tag2.
Thats a known bug in 3.0.2 and has been corrected in SVN already. Just empty the value for spam_subject_tag and add it in spam_subject_tag2.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.

Last edited by till; 10th May 2010 at 14:03.
Reply With Quote
  #5  
Old 10th May 2010, 14:02
mike_p mike_p is offline
Senior Member
 
Join Date: Mar 2010
Location: Surrey, England
Posts: 140
Thanks: 9
Thanked 28 Times in 17 Posts
Default

Thats odd! In my installation (using standard 3.0.2.1) it was applied correctly!

My apologies to Blinkiz for suggesting it wasn't a bug!
Reply With Quote
  #6  
Old 10th May 2010, 14:04
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,567
Thanks: 791
Thanked 4,979 Times in 3,900 Posts
 
Default

I was not absolutely correct, it must have been a bug in 3.0.2 which was fixed in 3.0.2.1.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Tags
bug, normal, spam. ***spam***, spamfilter

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Spamfilter policy - question about spam actions prisfeo Installation/Configuration 4 2nd February 2010 16:17
Ubuntu 8.04 Spamsnake - all SA scores 0.00 Thomas_Powers HOWTO-Related Questions 23 24th June 2008 17:37
postqueue -p show lots of spam mails sent to system users tom Installation/Configuration 6 29th April 2008 13:18
add web site serr57 Installation/Configuration 18 13th April 2008 11:40
All mails from my server go to spam evicon General 3 6th December 2006 19:46


All times are GMT +2. The time now is 12:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.