Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th April 2010, 19:48
korbynn korbynn is offline
Member
 
Join Date: May 2009
Posts: 81
Thanks: 2
Thanked 4 Times in 4 Posts
Default smtp refusing localhost connection

Does anyone know why the mail server is now rejecting all connects from localhost.

My website extensively use the php mail() function.

Mail is being rejected since I updated.

Any thoughts please?

line from the mail error log:

Apr 27 17:40:41 ns0 postfix/smtp[16452]: 246F27349EB: to=, relay=none, delay=0.07, delays=0.06/0/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]: Connection refused)
Reply With Quote
Sponsored Links
  #2  
Old 28th April 2010, 14:17
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

What's the output of
Code:
netstat -tap
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 28th April 2010, 19:08
korbynn korbynn is offline
Member
 
Join Date: May 2009
Posts: 81
Thanks: 2
Thanked 4 Times in 4 Posts
Default

Yes, you are right amavisd is not running.

Followed solution as per http://www.howtoforge.com/forums/sho...t=34455&page=3

Needed to run sa-update to fix error in maillog.

/etc/init.d/amavisd restart has an error on stop, instead of OK I get Failed.

Last edited by korbynn; 30th April 2010 at 07:19.
Reply With Quote
  #4  
Old 30th April 2010, 04:36
korbynn korbynn is offline
Member
 
Join Date: May 2009
Posts: 81
Thanks: 2
Thanked 4 Times in 4 Posts
Angry

found possible fix

Last edited by korbynn; 30th April 2010 at 07:15. Reason: found possible fix
Reply With Quote
  #5  
Old 30th April 2010, 07:23
korbynn korbynn is offline
Member
 
Join Date: May 2009
Posts: 81
Thanks: 2
Thanked 4 Times in 4 Posts
Default

I am now getting:

amavis[11808]: (11808-01-12) (!!)WARN: all primary virus scanners failed, considering backups

Any thoughts?
Reply With Quote
  #6  
Old 30th April 2010, 10:11
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,381
Thanks: 833
Thanked 5,482 Times in 4,316 Posts
Default

Clamav daemon is not running. Please start clamd.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 30th April 2010, 20:09
korbynn korbynn is offline
Member
 
Join Date: May 2009
Posts: 81
Thanks: 2
Thanked 4 Times in 4 Posts
Default mail() does not work to localhost

Quote:
Originally Posted by till View Post
Clamav daemon is not running. Please start clamd.
Fixing the error with postfix and amavisd allowed clamd to properly start.

Mail is now coming in and the backlog of mail is being processed.

Now mail() does not work to localhost.
Reply With Quote
  #8  
Old 30th April 2010, 20:16
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,381
Thanks: 833
Thanked 5,482 Times in 4,316 Posts
Default

What exactly did you change in postfix?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 1st May 2010, 08:51
korbynn korbynn is offline
Member
 
Join Date: May 2009
Posts: 81
Thanks: 2
Thanked 4 Times in 4 Posts
 
Default

Quote:
Originally Posted by till View Post
What exactly did you change in postfix?
if you look at this link:
http://www.howtoforge.com/forums/sho...t=34455&page=3
and go to post 22,
I changed in main.cf of postfix:
maildrop unix - n n - - pipe
flags=R user=vmail argv=/usr/bin/maildrop -d ${recipient} ${extension} ${recipient} ${user} ${nexthop} ${sender}
to:
maildrop unix - n n - - pipe
flags=R user=vmail argv=/usr/bin/maildrop -d vmail ${extension} ${recipient} ${user} ${nexthop} ${sender}

Also I ran as-update (an error in /var/log/maillog postfix startup suggested that I run it)

Once run then the error disappeared and the server started processing the back logged mail.

This is good but I cannot seem to mail() to localhost. This is the next problem that I need to resolve.

This appears to be the message that is sitting in the /var/spool/mail for the domain. Does anyone know why this is messed up?

From MAILER-DAEMON Fri Apr 30 23:22:07 2010
Return-Path: <>
X-Original-To: web1@ns0.korbynn.net
Delivered-To: web1@ns0.korbynn.net
Received: by ns0.korbynn.net (Postfix)
id B474D734153; Fri, 30 Apr 2010 23:22:07 -0700 (PDT)
Date: Fri, 30 Apr 2010 23:22:07 -0700 (PDT)
From: MAILER-DAEMON@ns0.korbynn.net (Mail Delivery System)
Subject: Undelivered Mail Returned to Sender
To: web1@ns0.korbynn.net
Auto-Submitted: auto-replied
MIME-Version: 1.0
Content-Type: multipart/report; report-type=delivery-status;
boundary="9BAFC734150.1272694927/ns0.korbynn.net"
Content-Transfer-Encoding: 7bit
Message-Id: <20100501062207.B474D734153@ns0.korbynn.net>

This is a MIME-encapsulated message.

--9BAFC734150.1272694927/ns0.korbynn.net
Content-Description: Notification
Content-Type: text/plain; charset=us-ascii

I can mail() to external emails but not on localhost.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ispconfig 3 cant receive emails lishaw1968 Installation/Configuration 25 19th August 2013 10:37
ISPConfig 3 Send/Receive mail not working. Acidut General 6 4th April 2010 11:24
squirrelmail and postfix witoszek General 12 1st December 2009 18:07
Mail not working epicuniversal General 5 13th June 2009 08:24
Question about Virtual Hosting With Proftpd And MySQL (Incl. Quota) On Debian Etch ikkem HOWTO-Related Questions 30 26th February 2008 19:38


All times are GMT +2. The time now is 20:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.