Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th April 2010, 01:33
reverendo reverendo is offline
Junior Member
 
Join Date: Apr 2010
Posts: 2
Thanks: 1
Thanked 0 Times in 0 Posts
Default Mysql in remote server: problems

Hi I just installed the last stable release of ISPConfig.

i've got 2 server, one for apache, php and ISPConfig and one for mysql.

I've got standard installation, I gave install app the internal IP of mysql server and it looks like it was working ok.

But when I try to create a database in ISPC, it appeas at db list but it's not created at mysql server

I go to Monitor and at system registers I found this: Unable to connect to the database, but everything else works.

Any ideas what's wrong?

Thanks in advance.
Reply With Quote
Sponsored Links
  #2  
Old 30th April 2010, 11:07
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,022
Thanks: 840
Thanked 5,653 Times in 4,462 Posts
Default

Looks as if you changed the mysql root password after the installation on the slave. You have to set the new root password in the file /usr/local/ispconfig/server/lib/mysql_clientdb.conf file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
reverendo (30th April 2010)
  #3  
Old 30th April 2010, 11:28
reverendo reverendo is offline
Junior Member
 
Join Date: Apr 2010
Posts: 2
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default Thanks!

Hi for the answer.

The problem wasn't a password change, in /usr/local/ispconfig/server/lib/mysql_clientdb.conf the user & pass are correct.

But the $clientdb_host was set to "localhost" instead the IP I gave to the installation process.

After change it, I try to create a new db and it works fine.

Thanks a lot.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with mail server and subdomains MyKE General 7 26th February 2010 11:18
Remote MySQL connection problems The General Installation/Configuration 4 7th November 2009 16:20
Adding a new server (multiserver) OscarMas Installation/Configuration 9 14th October 2009 14:56
mail delivered in mbox patfee Installation/Configuration 8 11th December 2007 14:58
MySql on Ubuntu 6.06 LTS Server Bubo Server Operation 7 5th January 2007 17:23


All times are GMT +2. The time now is 18:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.