Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th April 2010, 18:41
tomg tomg is offline
Junior Member
 
Join Date: Apr 2010
Posts: 4
Thanks: 0
Thanked 1 Time in 1 Post
Default DNS Zone files not updateing.

Hi,

I'm running ISPConfig 2.2.35 on Centos 5.4. It has been working fine. Yesterday things looked to be working fine. But now today the zone files for DNS are not getting updated.

If I go in to say DNS Manager and add an "A" record the zone file is not updated. However the record does show in the ISPConfig view. (Even if I log out and log in again).
So from ISPconfig things looks correct but the zone file is missing the "A" record.

If I add a new site with a new domain and I have the "Create DNS" ticked the site is created but no zone file is created.

If I add a new site and an existing domain and "Create DNS" is checked again the site is created but the zone file is not updated.

I have checked the permissions of the directory containing the Zone files and the zone files them selves and they look good to me.

I can't see anything in the ispconfig.log to show what the problem is.

Are there other places I can look to identify the problem.


Tom.
Reply With Quote
Sponsored Links
  #2  
Old 29th April 2010, 02:27
createch createch is offline
Senior Member
 
Join Date: Aug 2007
Posts: 118
Thanks: 24
Thanked 16 Times in 13 Posts
Default

Please go to Management > Server Settings > DNS to check whether the following default values are still in effect:

named.conf:
/var/named/chroot/etc/named.conf

Zonefiles Dir.:
/var/named/chroot/var/named
Reply With Quote
  #3  
Old 29th April 2010, 08:53
tomg tomg is offline
Junior Member
 
Join Date: Apr 2010
Posts: 4
Thanks: 0
Thanked 1 Time in 1 Post
Default

Well the settings are /etc/named.conf and /etc/bind but there are symbolic links the end up in the corrrect place.

It looks like the problem is intermittent. I need to do more research in to when it updates the zone files. It looks to me like delteing a site does not remove the entry from the DNS.

Tom.
Reply With Quote
  #4  
Old 30th April 2010, 10:30
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,486
Thanks: 813
Thanked 5,256 Times in 4,121 Posts
Default

Any errors in the file /home/admispconfig/ispconfig/ispconfig.log?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 30th April 2010, 14:28
tomg tomg is offline
Junior Member
 
Join Date: Apr 2010
Posts: 4
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by till View Post
Any errors in the file /home/admispconfig/ispconfig/ispconfig.log?
No no errors or clues in there. Things seem to be working again now however I have found that if I create a new site the DNS Zone file is updated. However, If I then delete the site it is not removed from the DNS Zone file. (Even after I empty the recyle bin)

t.
Reply With Quote
The Following User Says Thank You to tomg For This Useful Post:
adamassasda291 (26th June 2013)
  #6  
Old 1st May 2010, 14:52
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
 
Default

Quote:
Originally Posted by tomg View Post
However, If I then delete the site it is not removed from the DNS Zone file. (Even after I empty the recyle bin)
That's how it's supposed to be - deleting a site doesn't necessarily mean you also want to delete the zone. If you want to delete the zone as well, you must do this in the DNS Manager.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Squid Proxy Caching on Linux obzerver Installation/Configuration 4 13th August 2008 19:51
BIND-server problems NejcZ Installation/Configuration 26 8th September 2007 15:09
Unable send receive emails vassilis3 Installation/Configuration 15 19th May 2007 14:34
Zone files are not updated after deletion from web JAYDEE.U Installation/Configuration 1 1st January 2007 10:09
named.conf and zone files latcarf Server Operation 2 6th August 2005 15:00


All times are GMT +2. The time now is 03:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.