Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th April 2010, 02:47
RogueCoder RogueCoder is offline
Junior Member
 
Join Date: Apr 2010
Location: Nova Scotia, Canada
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default Removed execute permissions on /bin contents....

I mistyped a chmod command and removed the execute permissions for every file in /bin . How might I go about fixing this
__________________
"If at first you don't succeed; call it version 1.0"
Reply With Quote
Sponsored Links
  #2  
Old 27th April 2010, 06:10
RogueCoder RogueCoder is offline
Junior Member
 
Join Date: Apr 2010
Location: Nova Scotia, Canada
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well I got my hosting company to boot into a Live CD and fix it, but for next time I set the immutable attribute on /bin/chmod.

Now I'd like to know, can I set the immutable attribute on every file in /bin?

Also, I have a /bin/null dirctory that looks like a user directory and is owned by my FTP account (Pure FTPd). Is this safe to remove?
__________________
"If at first you don't succeed; call it version 1.0"
Reply With Quote
  #3  
Old 29th April 2010, 21:43
BorderAmigos BorderAmigos is offline
Senior Member
 
Join Date: Apr 2008
Location: San Diego & Tijuana
Posts: 302
Thanks: 26
Thanked 33 Times in 31 Posts
Send a message via MSN to BorderAmigos Send a message via Yahoo to BorderAmigos
 
Default

Does an FTP or SCP program use the chmod command to change permissions? If not you could have fixed it on chmod with that.

(Everything in my /bin directory on Debian appears to be 755).
__________________
System6Hosting.com, ISPConfig 3, Debian.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with mail server setup kentor HOWTO-Related Questions 27 16th July 2009 15:22
File Permissions 40esp General 2 22nd June 2009 21:15
Mail doesn't work TheRealLink Installation/Configuration 1 24th April 2009 15:34


All times are GMT +2. The time now is 19:29.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.